gnu: readline: support mingw.

* gnu/packages/patches/readline-7.0-mingw.patch: New file.
* gnu-system.am (dist_patch_DATA): Add it.
* gnu/packages/readline.scm (readline): Support MinGW.
master
Jan Nieuwenhuizen 2016-04-12 15:49:17 +02:00 committed by Ludovic Courtès
parent d230cf61f6
commit ae12d58627
No known key found for this signature in database
GPG Key ID: 090B11993D9AEBB5
3 changed files with 42 additions and 1 deletions

View File

@ -845,6 +845,7 @@ dist_patch_DATA = \
%D%/packages/patches/ratpoison-shell.patch \
%D%/packages/patches/readline-link-ncurses.patch \
%D%/packages/patches/readline-6.2-CVE-2014-2524.patch \
%D%/packages/patches/readline-7.0-mingw.patch \
%D%/packages/patches/ripperx-missing-file.patch \
%D%/packages/patches/rpm-CVE-2014-8118.patch \
%D%/packages/patches/rsem-makefile.patch \

View File

@ -0,0 +1,28 @@
Configure checks for chown; add missing shields in code.
Upstream status: not yet presented upstream.
--- readline-7.0/histfile.c.orig 2016-12-06 20:04:10.058901731 +0100
+++ readline-7.0/histfile.c 2016-12-06 20:05:09.220083801 +0100
@@ -610,8 +610,10 @@
user is running this, it's a no-op. If the shell is running after sudo
with a shared history file, we don't want to leave the history file
owned by root. */
+#if HAVE_CHOWN
if (rv == 0 && exists)
r = chown (filename, finfo.st_uid, finfo.st_gid);
+#endif
xfree (filename);
FREE (tempname);
@@ -757,8 +759,10 @@
user is running this, it's a no-op. If the shell is running after sudo
with a shared history file, we don't want to leave the history file
owned by root. */
+#if HAVE_CHOWN
if (rv == 0 && exists)
mode = chown (histname, finfo.st_uid, finfo.st_gid);
+#endif
FREE (histname);
FREE (tempname);

View File

@ -1,6 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2012, 2013, 2014 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016 Jan Nieuwenhuizen <janneke@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
@ -24,7 +25,8 @@
#:use-module (gnu packages perl)
#:use-module (guix packages)
#:use-module (guix download)
#:use-module (guix build-system gnu))
#:use-module (guix build-system gnu)
#:use-module (guix utils))
(define-public readline
(let ((post-install-phase
@ -61,8 +63,18 @@
;; cross-compiling, so provide the correct answer.
,@(if (%current-target-system)
'("bash_cv_wcwidth_broken=no")
'())
;; MinGW: ncurses provides the termcap api.
,@(if (target-mingw?)
'("bash_cv_termcap_lib=ncurses")
'()))
,@(if (target-mingw?)
;; MinGW: termcap in ncurses
;; some SIG_* #defined in _POSIX
'(#:make-flags '("TERMCAP_LIB=-lncurses"
"CPPFLAGS=-D_POSIX -D'chown(f,o,g)=0'"))
'())
#:phases (alist-cons-after
'install 'post-install
,post-install-phase