gnu: Add glibc-locales.
* gnu/packages/patches/glibc-locales.patch: New file. * gnu-system.am (dist_patch_DATA): Add it. * gnu/packages/base.scm (glibc-locales): New variable.
This commit is contained in:
parent
fbe952c99f
commit
aee6180c10
|
@ -393,6 +393,7 @@ dist_patch_DATA = \
|
|||
gnu/packages/patches/glibc-CVE-2014-7817.patch \
|
||||
gnu/packages/patches/glibc-bootstrap-system.patch \
|
||||
gnu/packages/patches/glibc-ldd-x86_64.patch \
|
||||
gnu/packages/patches/glibc-locales.patch \
|
||||
gnu/packages/patches/glibc-mips-dangling-vfork-ref.patch \
|
||||
gnu/packages/patches/gmp-arm-asm-nothumb.patch \
|
||||
gnu/packages/patches/gnunet-fix-scheduler.patch \
|
||||
|
|
|
@ -33,6 +33,7 @@
|
|||
#:use-module (gnu packages linux)
|
||||
#:use-module (gnu packages texinfo)
|
||||
#:use-module (gnu packages pkg-config)
|
||||
#:use-module (guix utils)
|
||||
#:use-module (guix packages)
|
||||
#:use-module (guix download)
|
||||
#:use-module (guix build-system gnu))
|
||||
|
@ -520,6 +521,40 @@ with the Linux kernel.")
|
|||
(license lgpl2.0+)
|
||||
(home-page "http://www.gnu.org/software/libc/")))
|
||||
|
||||
(define-public glibc-locales
|
||||
(package
|
||||
(inherit glibc)
|
||||
(name "glibc-locales")
|
||||
(source (origin (inherit (package-source glibc))
|
||||
(patches (cons (search-patch "glibc-locales.patch")
|
||||
(origin-patches (package-source glibc))))))
|
||||
(synopsis "All the locales supported by the GNU C Library")
|
||||
(description
|
||||
"This package provides all the locales supported by the GNU C Library,
|
||||
more than 400 in total. To use them set the 'LOCPATH' environment variable to
|
||||
the 'share/locale' sub-directory of this package.")
|
||||
(outputs '("out")) ;110+ MiB
|
||||
(arguments
|
||||
(let ((args `(#:tests? #f #:strip-binaries? #f
|
||||
,@(package-arguments glibc))))
|
||||
(substitute-keyword-arguments args
|
||||
((#:phases phases)
|
||||
`(alist-replace
|
||||
'build
|
||||
(lambda* (#:key outputs #:allow-other-keys)
|
||||
(let ((out (assoc-ref outputs "out")))
|
||||
;; Delete $out/bin, which contains 'bash'.
|
||||
(delete-file-recursively (string-append out "/bin")))
|
||||
|
||||
(zero? (system* "make" "localedata/install-locales"
|
||||
"-j" (number->string (parallel-job-count)))))
|
||||
(alist-delete 'install ,phases)))
|
||||
((#:configure-flags flags)
|
||||
`(append ,flags
|
||||
(list (string-append "libc_cv_localedir="
|
||||
(assoc-ref %outputs "out")
|
||||
"/share/locale")))))))))
|
||||
|
||||
(define-public tzdata
|
||||
(package
|
||||
(name "tzdata")
|
||||
|
|
|
@ -0,0 +1,31 @@
|
|||
This patch allows us to use glibc's build system to build locales
|
||||
in a package separate from glibc.
|
||||
|
||||
1. Use 'localedef' from $PATH since we are not rebuilding it.
|
||||
2. Use '--no-archive' to avoid building the big locale archive, and
|
||||
because the already-built 'localedef' would want to write it
|
||||
to '/run/current-system/locale', which is not possible.
|
||||
3. Pass $(localedir)/$$locale to install files in the right place, and
|
||||
because otherwise, 'localedef' fails with:
|
||||
"cannot write output files to `(null)'".
|
||||
|
||||
--- glibc-2.20/localedata/Makefile 2014-09-07 10:09:09.000000000 +0200
|
||||
+++ glibc-2.20/localedata/Makefile 2015-02-11 10:23:55.560545568 +0100
|
||||
@@ -217,7 +217,7 @@ INSTALL-SUPPORTED-LOCALES=$(addprefix in
|
||||
|
||||
# Sometimes the whole collection of locale files should be installed.
|
||||
LOCALEDEF=I18NPATH=. GCONV_PATH=$(common-objpfx)iconvdata LC_ALL=C \
|
||||
-$(rtld-prefix) $(common-objpfx)locale/localedef
|
||||
+ localedef --no-archive
|
||||
install-locales: $(INSTALL-SUPPORTED-LOCALES)
|
||||
|
||||
install-locales-dir:
|
||||
@@ -234,7 +234,7 @@ $(INSTALL-SUPPORTED-LOCALES): install-lo
|
||||
input=`echo $$locale | sed 's/\([^.]*\)[^@]*\(.*\)/\1\2/'`; \
|
||||
$(LOCALEDEF) --alias-file=../intl/locale.alias \
|
||||
-i locales/$$input -c -f charmaps/$$charset \
|
||||
- $(addprefix --prefix=,$(install_root)) $$locale; \
|
||||
+ $(addprefix --prefix=,$(install_root)) $(localedir)/$$locale; \
|
||||
echo ' done'; \
|
||||
|
||||
tst-setlocale-ENV = LC_ALL=ja_JP.EUC-JP
|
Loading…
Reference in New Issue