gnu: cyrus-sasl: Update to 2.1.27.
* gnu/packages/patches/cyrus-sasl-CVE-2013-4122.patch: Delete file.
* gnu/local.mk (dist_patch_DATA): Remove it.
* gnu/packages/cyrus-sasl.scm (cyrus-sasl): Update to 2.1.27.
[source](patches): Remove.
[inputs]: Move MIT-KRB5 from here ...
[propagated-inputs]: ... to here. New field.
* gnu/packages/openldap.scm (openldap)[arguments]: Adjust
'patch-sasl-path' phase (which was defunct, possibly since b148506df7
) to
add krb5 linker flags.
This commit is contained in:
parent
56ba3771c0
commit
af0162bcc1
|
@ -649,7 +649,6 @@ dist_patch_DATA = \
|
||||||
%D%/packages/patches/cube-nocheck.patch \
|
%D%/packages/patches/cube-nocheck.patch \
|
||||||
%D%/packages/patches/cursynth-wave-rand.patch \
|
%D%/packages/patches/cursynth-wave-rand.patch \
|
||||||
%D%/packages/patches/cvs-2017-12836.patch \
|
%D%/packages/patches/cvs-2017-12836.patch \
|
||||||
%D%/packages/patches/cyrus-sasl-CVE-2013-4122.patch \
|
|
||||||
%D%/packages/patches/datamash-arm-tests.patch \
|
%D%/packages/patches/datamash-arm-tests.patch \
|
||||||
%D%/packages/patches/dbus-helper-search-path.patch \
|
%D%/packages/patches/dbus-helper-search-path.patch \
|
||||||
%D%/packages/patches/deja-dup-use-ref-keyword-for-iter.patch \
|
%D%/packages/patches/deja-dup-use-ref-keyword-for-iter.patch \
|
||||||
|
|
|
@ -31,7 +31,7 @@
|
||||||
(define-public cyrus-sasl
|
(define-public cyrus-sasl
|
||||||
(package
|
(package
|
||||||
(name "cyrus-sasl")
|
(name "cyrus-sasl")
|
||||||
(version "2.1.26")
|
(version "2.1.27")
|
||||||
(source (origin
|
(source (origin
|
||||||
(method url-fetch)
|
(method url-fetch)
|
||||||
(uri (list (string-append
|
(uri (list (string-append
|
||||||
|
@ -40,13 +40,14 @@
|
||||||
(string-append
|
(string-append
|
||||||
"ftp://ftp.cyrusimap.org/cyrus-sasl/cyrus-sasl-"
|
"ftp://ftp.cyrusimap.org/cyrus-sasl/cyrus-sasl-"
|
||||||
version ".tar.gz")))
|
version ".tar.gz")))
|
||||||
(patches (search-patches "cyrus-sasl-CVE-2013-4122.patch"))
|
|
||||||
(sha256 (base32
|
(sha256 (base32
|
||||||
"1hvvbcsg21nlncbgs0cgn3iwlnb3vannzwsp6rwvnn9ba4v53g4g"))))
|
"1m85zcpgfdhm43cavpdkhb1s2zq1b31472hq1w1gs3xh94anp1i6"))))
|
||||||
(build-system gnu-build-system)
|
(build-system gnu-build-system)
|
||||||
(inputs `(("gdbm" ,gdbm)
|
(inputs `(("gdbm" ,gdbm)
|
||||||
("mit-krb5" ,mit-krb5)
|
|
||||||
("openssl" ,openssl)))
|
("openssl" ,openssl)))
|
||||||
|
(propagated-inputs
|
||||||
|
`(;; cyrus-sasl.pc refers to -lkrb5, so propagate it.
|
||||||
|
("mit-krb5" ,mit-krb5)))
|
||||||
(arguments
|
(arguments
|
||||||
'(#:configure-flags (list (string-append "--with-plugindir="
|
'(#:configure-flags (list (string-append "--with-plugindir="
|
||||||
(assoc-ref %outputs "out")
|
(assoc-ref %outputs "out")
|
||||||
|
|
|
@ -91,11 +91,15 @@
|
||||||
;; Give -L arguments for cyrus-sasl to avoid propagation.
|
;; Give -L arguments for cyrus-sasl to avoid propagation.
|
||||||
(lambda* (#:key inputs outputs #:allow-other-keys)
|
(lambda* (#:key inputs outputs #:allow-other-keys)
|
||||||
(let ((out (assoc-ref outputs "out"))
|
(let ((out (assoc-ref outputs "out"))
|
||||||
(sasl (assoc-ref inputs "cyrus-sasl")))
|
(krb5 (assoc-ref inputs "mit-krb5"))) ;propagated from cyrus-sasl
|
||||||
|
|
||||||
|
;; The ancient Libtool bundled with OpenLDAP copies the linker flags
|
||||||
|
;; from Cyrus-SASL and embeds them into its own .la files. Add an
|
||||||
|
;; absolute reference to Kerberos so it does not have to be propagated.
|
||||||
(substitute* (map (lambda (f) (string-append out "/" f))
|
(substitute* (map (lambda (f) (string-append out "/" f))
|
||||||
'("lib/libldap.la" "lib/libldap_r.la"))
|
'("lib/libldap.la" "lib/libldap_r.la"))
|
||||||
(("-lsasl2" lib)
|
(("-lkrb5" lib)
|
||||||
(string-append "-L" sasl "/lib " lib)))
|
(string-append "-L" krb5 "/lib " lib)))
|
||||||
#t))))))
|
#t))))))
|
||||||
(synopsis "Implementation of the Lightweight Directory Access Protocol")
|
(synopsis "Implementation of the Lightweight Directory Access Protocol")
|
||||||
(description
|
(description
|
||||||
|
|
|
@ -1,130 +0,0 @@
|
||||||
Fix CVE-2013-4122.
|
|
||||||
|
|
||||||
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2013-4122
|
|
||||||
|
|
||||||
Patch copied from upstream source repository:
|
|
||||||
https://github.com/cyrusimap/cyrus-sasl/commit/dedad73e5e7a75d01a5f3d5a6702ab8ccd2ff40d
|
|
||||||
|
|
||||||
From dedad73e5e7a75d01a5f3d5a6702ab8ccd2ff40d Mon Sep 17 00:00:00 2001
|
|
||||||
From: mancha <mancha1@hush.com>
|
|
||||||
Date: Thu, 11 Jul 2013 10:08:07 +0100
|
|
||||||
Subject: Handle NULL returns from glibc 2.17+ crypt()
|
|
||||||
|
|
||||||
Starting with glibc 2.17 (eglibc 2.17), crypt() fails with EINVAL
|
|
||||||
(w/ NULL return) if the salt violates specifications. Additionally,
|
|
||||||
on FIPS-140 enabled Linux systems, DES/MD5-encrypted passwords
|
|
||||||
passed to crypt() fail with EPERM (w/ NULL return).
|
|
||||||
|
|
||||||
When using glibc's crypt(), check return value to avoid a possible
|
|
||||||
NULL pointer dereference.
|
|
||||||
|
|
||||||
Patch by mancha1@hush.com.
|
|
||||||
---
|
|
||||||
pwcheck/pwcheck_getpwnam.c | 3 ++-
|
|
||||||
pwcheck/pwcheck_getspnam.c | 4 +++-
|
|
||||||
saslauthd/auth_getpwent.c | 4 +++-
|
|
||||||
saslauthd/auth_shadow.c | 8 +++-----
|
|
||||||
4 files changed, 11 insertions(+), 8 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/pwcheck/pwcheck_getpwnam.c b/pwcheck/pwcheck_getpwnam.c
|
|
||||||
index 4b34222..400289c 100644
|
|
||||||
--- a/pwcheck/pwcheck_getpwnam.c
|
|
||||||
+++ b/pwcheck/pwcheck_getpwnam.c
|
|
||||||
@@ -32,6 +32,7 @@ char *userid;
|
|
||||||
char *password;
|
|
||||||
{
|
|
||||||
char* r;
|
|
||||||
+ char* crpt_passwd;
|
|
||||||
struct passwd *pwd;
|
|
||||||
|
|
||||||
pwd = getpwnam(userid);
|
|
||||||
@@ -41,7 +42,7 @@ char *password;
|
|
||||||
else if (pwd->pw_passwd[0] == '*') {
|
|
||||||
r = "Account disabled";
|
|
||||||
}
|
|
||||||
- else if (strcmp(pwd->pw_passwd, crypt(password, pwd->pw_passwd)) != 0) {
|
|
||||||
+ else if (!(crpt_passwd = crypt(password, pwd->pw_passwd)) || strcmp(pwd->pw_passwd, (const char *)crpt_passwd) != 0) {
|
|
||||||
r = "Incorrect password";
|
|
||||||
}
|
|
||||||
else {
|
|
||||||
diff --git a/pwcheck/pwcheck_getspnam.c b/pwcheck/pwcheck_getspnam.c
|
|
||||||
index 2b11286..6d607bb 100644
|
|
||||||
--- a/pwcheck/pwcheck_getspnam.c
|
|
||||||
+++ b/pwcheck/pwcheck_getspnam.c
|
|
||||||
@@ -32,13 +32,15 @@ char *userid;
|
|
||||||
char *password;
|
|
||||||
{
|
|
||||||
struct spwd *pwd;
|
|
||||||
+ char *crpt_passwd;
|
|
||||||
|
|
||||||
pwd = getspnam(userid);
|
|
||||||
if (!pwd) {
|
|
||||||
return "Userid not found";
|
|
||||||
}
|
|
||||||
|
|
||||||
- if (strcmp(pwd->sp_pwdp, crypt(password, pwd->sp_pwdp)) != 0) {
|
|
||||||
+ crpt_passwd = crypt(password, pwd->sp_pwdp);
|
|
||||||
+ if (!crpt_passwd || strcmp(pwd->sp_pwdp, (const char *)crpt_passwd) != 0) {
|
|
||||||
return "Incorrect password";
|
|
||||||
}
|
|
||||||
else {
|
|
||||||
diff --git a/saslauthd/auth_getpwent.c b/saslauthd/auth_getpwent.c
|
|
||||||
index fc8029d..d4ebe54 100644
|
|
||||||
--- a/saslauthd/auth_getpwent.c
|
|
||||||
+++ b/saslauthd/auth_getpwent.c
|
|
||||||
@@ -77,6 +77,7 @@ auth_getpwent (
|
|
||||||
{
|
|
||||||
/* VARIABLES */
|
|
||||||
struct passwd *pw; /* pointer to passwd file entry */
|
|
||||||
+ char *crpt_passwd; /* encrypted password */
|
|
||||||
int errnum;
|
|
||||||
/* END VARIABLES */
|
|
||||||
|
|
||||||
@@ -105,7 +106,8 @@ auth_getpwent (
|
|
||||||
}
|
|
||||||
}
|
|
||||||
|
|
||||||
- if (strcmp(pw->pw_passwd, (const char *)crypt(password, pw->pw_passwd))) {
|
|
||||||
+ crpt_passwd = crypt(password, pw->pw_passwd);
|
|
||||||
+ if (!crpt_passwd || strcmp(pw->pw_passwd, (const char *)crpt_passwd)) {
|
|
||||||
if (flags & VERBOSE) {
|
|
||||||
syslog(LOG_DEBUG, "DEBUG: auth_getpwent: %s: invalid password", login);
|
|
||||||
}
|
|
||||||
diff --git a/saslauthd/auth_shadow.c b/saslauthd/auth_shadow.c
|
|
||||||
index 677131b..1988afd 100644
|
|
||||||
--- a/saslauthd/auth_shadow.c
|
|
||||||
+++ b/saslauthd/auth_shadow.c
|
|
||||||
@@ -210,8 +210,8 @@ auth_shadow (
|
|
||||||
RETURN("NO Insufficient permission to access NIS authentication database (saslauthd)");
|
|
||||||
}
|
|
||||||
|
|
||||||
- cpw = strdup((const char *)crypt(password, sp->sp_pwdp));
|
|
||||||
- if (strcmp(sp->sp_pwdp, cpw)) {
|
|
||||||
+ cpw = crypt(password, sp->sp_pwdp);
|
|
||||||
+ if (!cpw || strcmp(sp->sp_pwdp, (const char *)cpw)) {
|
|
||||||
if (flags & VERBOSE) {
|
|
||||||
/*
|
|
||||||
* This _should_ reveal the SHADOW_PW_LOCKED prefix to an
|
|
||||||
@@ -221,10 +221,8 @@ auth_shadow (
|
|
||||||
syslog(LOG_DEBUG, "DEBUG: auth_shadow: pw mismatch: '%s' != '%s'",
|
|
||||||
sp->sp_pwdp, cpw);
|
|
||||||
}
|
|
||||||
- free(cpw);
|
|
||||||
RETURN("NO Incorrect password");
|
|
||||||
}
|
|
||||||
- free(cpw);
|
|
||||||
|
|
||||||
/*
|
|
||||||
* The following fields will be set to -1 if:
|
|
||||||
@@ -286,7 +284,7 @@ auth_shadow (
|
|
||||||
RETURN("NO Invalid username");
|
|
||||||
}
|
|
||||||
|
|
||||||
- if (strcmp(upw->upw_passwd, crypt(password, upw->upw_passwd)) != 0) {
|
|
||||||
+ if (!(cpw = crypt(password, upw->upw_passwd)) || (strcmp(upw->upw_passwd, (const char *)cpw) != 0)) {
|
|
||||||
if (flags & VERBOSE) {
|
|
||||||
syslog(LOG_DEBUG, "auth_shadow: pw mismatch: %s != %s",
|
|
||||||
password, upw->upw_passwd);
|
|
||||||
--
|
|
||||||
cgit v0.12
|
|
||||||
|
|
Loading…
Reference in New Issue