gnu: calibre: Update to 2.63.0.
* gnu/packages/ebook.scm (calibre): Update to 2.63.0. [inputs]: Remove unnecessary imagemagick dependency. [phases]: Use modify-phases. * gnu/packages/patches/calibre-drop-unrar.patch: Update for new version. Signed-off-by: Roel Janssen <roel@gnu.org>
This commit is contained in:
parent
cad7e6abaf
commit
b111bdb667
|
@ -1,6 +1,7 @@
|
|||
;;; GNU Guix --- Functional package management for GNU
|
||||
;;; Copyright © 2015, 2016 Andreas Enge <andreas@enge.fr>
|
||||
;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
|
||||
;;; Copyright © 2016 Alex Griffin <a@ajgrf.com>
|
||||
;;;
|
||||
;;; This file is part of GNU Guix.
|
||||
;;;
|
||||
|
@ -31,7 +32,6 @@
|
|||
#:use-module (gnu packages glib)
|
||||
#:use-module (gnu packages icu4c)
|
||||
#:use-module (gnu packages image)
|
||||
#:use-module (gnu packages imagemagick)
|
||||
#:use-module (gnu packages libusb)
|
||||
#:use-module (gnu packages pdf)
|
||||
#:use-module (gnu packages pkg-config)
|
||||
|
@ -61,7 +61,7 @@
|
|||
(define-public calibre
|
||||
(package
|
||||
(name "calibre")
|
||||
(version "2.62.0")
|
||||
(version "2.63.0")
|
||||
(source
|
||||
(origin
|
||||
(method url-fetch)
|
||||
|
@ -70,7 +70,7 @@
|
|||
version ".tar.xz"))
|
||||
(sha256
|
||||
(base32
|
||||
"15qskfsdg3fy9cpw1m3mccwgn45366yn7lci5kim0fdzpw9pnkna"))
|
||||
"1rwgv6rsmy3ljfwcpv42w203ghngw86s5kzb0yjm1zgsxmas2wh6"))
|
||||
;; Remove non-free or doubtful code, see
|
||||
;; https://lists.gnu.org/archive/html/guix-devel/2015-02/msg00478.html
|
||||
(modules '((guix build utils)))
|
||||
|
@ -102,7 +102,6 @@
|
|||
("fontconfig" ,fontconfig)
|
||||
("glib" ,glib)
|
||||
("icu4c" ,icu4c)
|
||||
("imagemagick" ,imagemagick)
|
||||
("libmtp" ,libmtp)
|
||||
("libpng" ,libpng)
|
||||
("libusb" ,libusb)
|
||||
|
@ -128,16 +127,15 @@
|
|||
#:test-target "check"
|
||||
#:tests? #f ; FIXME: enable once flake8 is packaged
|
||||
#:phases
|
||||
(alist-cons-before
|
||||
'build 'configure
|
||||
(modify-phases %standard-phases
|
||||
(add-before 'build 'configure
|
||||
(lambda* (#:key inputs #:allow-other-keys)
|
||||
(let ((podofo (assoc-ref inputs "podofo"))
|
||||
(pyqt (assoc-ref inputs "python2-pyqt")))
|
||||
(substitute* "setup/build_environment.py"
|
||||
(("sys.prefix") (string-append "'" pyqt "'")))
|
||||
(setenv "PODOFO_INC_DIR" (string-append podofo "/include/podofo"))
|
||||
(setenv "PODOFO_LIB_DIR" (string-append podofo "/lib"))))
|
||||
%standard-phases)))
|
||||
(setenv "PODOFO_LIB_DIR" (string-append podofo "/lib"))))))))
|
||||
(home-page "http://calibre-ebook.com/")
|
||||
(synopsis "E-book library management software")
|
||||
(description "Calibre is an ebook library manager. It can view, convert
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
Taken from Debian.
|
||||
Taken from Debian. Updated by Alex Griffin.
|
||||
|
||||
Author: Dmitry Shachnev <mitya57@gmail.com>
|
||||
Description: do not build unrar extension as we strip unrar from the tarball
|
||||
|
@ -7,37 +7,29 @@ Last-Update: 2013-04-04
|
|||
|
||||
Index: calibre/setup/extensions.py
|
||||
===================================================================
|
||||
--- calibre.orig/setup/extensions.py 2014-02-02 10:42:14.510954007 +0100
|
||||
+++ calibre/setup/extensions.py 2014-02-02 10:42:14.502954007 +0100
|
||||
@@ -209,24 +209,6 @@
|
||||
sip_files=['calibre/ebooks/pdf/render/qt_hack.sip']
|
||||
),
|
||||
|
||||
- Extension('unrar',
|
||||
- ['unrar/%s.cpp'%(x.partition('.')[0]) for x in '''
|
||||
- rar.o strlist.o strfn.o pathfn.o savepos.o smallfn.o global.o file.o
|
||||
- filefn.o filcreat.o archive.o arcread.o unicode.o system.o
|
||||
- isnt.o crypt.o crc.o rawread.o encname.o resource.o match.o
|
||||
- timefn.o rdwrfn.o consio.o options.o ulinks.o errhnd.o rarvm.o
|
||||
- secpassword.o rijndael.o getbits.o sha1.o extinfo.o extract.o
|
||||
- volume.o list.o find.o unpack.o cmddata.o filestr.o scantree.o
|
||||
- '''.split()] + ['calibre/utils/unrar.cpp'],
|
||||
- inc_dirs=['unrar'],
|
||||
- cflags=[('/' if iswindows else '-') + x for x in (
|
||||
- 'DSILENT', 'DRARDLL', 'DUNRAR')] + (
|
||||
- [] if iswindows else ['-D_FILE_OFFSET_BITS=64',
|
||||
- '-D_LARGEFILE_SOURCE']),
|
||||
- optimize_level=2,
|
||||
- libraries=['User32', 'Advapi32', 'kernel32', 'Shell32'] if iswindows else []
|
||||
- ),
|
||||
-
|
||||
--- calibre.orig/setup/extensions.json 2016-07-21 21:21:05.000000000 -0500
|
||||
+++ calibre/setup/extensions.json 2016-07-27 11:22:17.167710112 -0500
|
||||
@@ -211,14 +211,5 @@
|
||||
"sources": "calibre/devices/mtp/unix/devices.c calibre/devices/mtp/unix/libmtp.c",
|
||||
"headers": "calibre/devices/mtp/unix/devices.h calibre/devices/mtp/unix/upstream/music-players.h calibre/devices/mtp/unix/upstream/device-flags.h",
|
||||
"libraries": "mtp"
|
||||
- },
|
||||
- {
|
||||
- "name": "unrar",
|
||||
- "sources": "unrar/rar.cpp unrar/strlist.cpp unrar/strfn.cpp unrar/pathfn.cpp unrar/savepos.cpp unrar/smallfn.cpp unrar/global.cpp unrar/file.cpp unrar/filefn.cpp unrar/filcreat.cpp unrar/archive.cpp unrar/arcread.cpp unrar/unicode.cpp unrar/system.cpp unrar/isnt.cpp unrar/crypt.cpp unrar/crc.cpp unrar/rawread.cpp unrar/encname.cpp unrar/resource.cpp unrar/match.cpp unrar/timefn.cpp unrar/rdwrfn.cpp unrar/consio.cpp unrar/options.cpp unrar/ulinks.cpp unrar/errhnd.cpp unrar/rarvm.cpp unrar/secpassword.cpp unrar/rijndael.cpp unrar/getbits.cpp unrar/sha1.cpp unrar/extinfo.cpp unrar/extract.cpp unrar/volume.cpp unrar/list.cpp unrar/find.cpp unrar/unpack.cpp unrar/cmddata.cpp unrar/filestr.cpp unrar/scantree.cpp calibre/utils/unrar.cpp",
|
||||
- "inc_dirs": "unrar",
|
||||
- "defines": "SILENT RARDLL UNRAR _FILE_OFFSET_BITS=64 _LARGEFILE_SOURCE",
|
||||
- "windows_defines": "SILENT RARDLL UNRAR",
|
||||
- "optimize_level": 2,
|
||||
- "windows_libraries": "User32 Advapi32 kernel32 Shell32"
|
||||
}
|
||||
]
|
||||
|
||||
|
||||
Index: calibre/src/calibre/ebooks/metadata/archive.py
|
||||
===================================================================
|
||||
--- calibre.orig/src/calibre/ebooks/metadata/archive.py 2014-02-02 10:42:14.510954007 +0100
|
||||
+++ calibre/src/calibre/ebooks/metadata/archive.py 2014-02-02 10:42:14.502954007 +0100
|
||||
--- calibre.orig/src/calibre/ebooks/metadata/archive.py 2016-07-21 21:21:05.000000000 -0500
|
||||
+++ calibre/src/calibre/ebooks/metadata/archive.py 2016-07-27 11:21:07.793616039 -0500
|
||||
@@ -42,7 +42,7 @@
|
||||
description = _('Extract common e-book formats from archives '
|
||||
'(zip/rar) files. Also try to autodetect if they are actually '
|
||||
|
|
Loading…
Reference in New Issue