gnu: python-keras: Add upstream patch.

* gnu/packages/patches/python-keras-integration-test.patch: New file.
* gnu/local.mk (dist_patch_DATA): Adjust accordingly.
* gnu/packages/machine-learning.scm (python-keras)[source](patches): New field.
master
Marius Bakke 2019-07-19 15:44:26 +02:00
parent ca49d73225
commit b16e082799
No known key found for this signature in database
GPG Key ID: A2A06DF2A33A54FA
3 changed files with 21 additions and 0 deletions

View File

@ -1225,6 +1225,7 @@ dist_patch_DATA = \
%D%/packages/patches/python2-larch-coverage-4.0a6-compatibility.patch \
%D%/packages/patches/python-configobj-setuptools.patch \
%D%/packages/patches/python-faker-fix-build-32bit.patch \
%D%/packages/patches/python-keras-integration-test.patch \
%D%/packages/patches/python-pyfakefs-remove-bad-test.patch \
%D%/packages/patches/python-flint-includes.patch \
%D%/packages/patches/python-mox3-python3.6-compat.patch \

View File

@ -1853,6 +1853,7 @@ with image data, text data, and sequence data.")
(origin
(method url-fetch)
(uri (pypi-uri "Keras" version))
(patches (search-patches "python-keras-integration-test.patch"))
(sha256
(base32
"1j8bsqzh49vjdxy6l1k4iwax5vpjzniynyd041xjavdzvfii1dlh"))))

View File

@ -0,0 +1,19 @@
Fix a test failure with recent versions of ... Pytest? Python?
Taken from upstream:
https://github.com/keras-team/keras/commit/fe35050a8f18dc52304aa8da4e463eececa25240
diff --git a/tests/integration_tests/applications_test.py b/tests/integration_tests/applications_test.py
index 979f2f2abd6..6e3b57fa8e2 100644
--- a/tests/integration_tests/applications_test.py
+++ b/tests/integration_tests/applications_test.py
@@ -58,7 +58,8 @@ def _test_application_basic(app, last_dim=1000):
def _test_application_notop(app, last_dim):
output_shape = _get_output_shape(
lambda: app(weights=None, include_top=False))
- assert output_shape == (None, None, None, last_dim)
+ assert len(output_shape) == 4
+ assert output_shape[-1] == last_dim
def test_mobilenet_v2_legacy_import():