gnu: khal: Update to 0.9.0.

* gnu/packages/calendar.scm (khal): Update to 0.9.0
[source]: Remove obsolete patch.
* gnu/packages/patches/khal-disable-failing-tests.patch: Delete file.
* gnu/local.mk (dist_patch_DATA): Add it.
master
Leo Famulari 2017-01-24 01:59:07 -05:00
parent 4cfd222fa7
commit b2725c53dd
No known key found for this signature in database
GPG Key ID: 2646FA30BACA7F08
3 changed files with 2 additions and 37 deletions

View File

@ -645,7 +645,6 @@ dist_patch_DATA = \
%D%/packages/patches/jbig2dec-ignore-testtest.patch \
%D%/packages/patches/jq-CVE-2015-8863.patch \
%D%/packages/patches/kdbusaddons-kinit-file-name.patch \
%D%/packages/patches/khal-disable-failing-tests.patch \
%D%/packages/patches/khmer-use-libraries.patch \
%D%/packages/patches/kmod-module-directory.patch \
%D%/packages/patches/kobodeluxe-paths.patch \

View File

@ -84,14 +84,13 @@ data units.")
(define-public khal
(package
(name "khal")
(version "0.8.4")
(version "0.9.0")
(source (origin
(method url-fetch)
(uri (pypi-uri "khal" version))
(patches (search-patches "khal-disable-failing-tests.patch"))
(sha256
(base32
"03vy4dp9n43w51mwqjjy08dr5nj7wxqnb085visz3j43vzm42p1f"))))
"138gxynw7zavwqqaw5nzmj8sbpkymmb95xzgxqbdi9fiiqm9kamr"))))
(build-system python-build-system)
(arguments
`(#:phases (modify-phases %standard-phases

View File

@ -1,33 +0,0 @@
Disable some tests that are known to fail:
https://github.com/pimutils/khal/issues/546
https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=844081
diff --git a/tests/khalendar_test.py b/tests/khalendar_test.py
index fd8dcc6..17732bf 100644
--- a/tests/khalendar_test.py
+++ b/tests/khalendar_test.py
@@ -65,6 +65,7 @@ class TestCalendar(object):
else:
mtimes[cal] = mtime
+ @pytest.mark.xfail
def test_db_needs_update(self, coll_vdirs):
coll, vdirs = coll_vdirs
@@ -321,6 +322,7 @@ class TestDbCreation(object):
CalendarCollection(calendars, dbpath=dbpath, locale=aux.locale)
+@pytest.mark.xfail
def test_default_calendar(coll_vdirs):
"""test if an update to the vdir is detected by the CalendarCollection"""
coll, vdirs = coll_vdirs
@@ -341,6 +343,7 @@ def test_default_calendar(coll_vdirs):
assert len(list(coll.get_events_on(today))) == 0
+@pytest.mark.xfail
def test_only_update_old_event(coll_vdirs, monkeypatch):
coll, vdirs = coll_vdirs