gnu: dmd: Update to 0.2.

* gnu/packages/admin.scm (dmd): Update to 0.2; remove 'patches'.
* gnu/packages/patches/dmd-getpw.patch,
  gnu/packages/patches/dmd-tests-longer-sleeps.patch: Remove.
* gnu-system.am (dist_patch_DATA): Adjust accordingly.
master
Ludovic Courtès 2014-07-07 23:54:28 +02:00
parent ac47a7c240
commit b3342b545a
4 changed files with 2 additions and 77 deletions

View File

@ -288,8 +288,6 @@ dist_patch_DATA = \
gnu/packages/patches/cursynth-wave-rand.patch \
gnu/packages/patches/dbus-localstatedir.patch \
gnu/packages/patches/diffutils-gets-undeclared.patch \
gnu/packages/patches/dmd-getpw.patch \
gnu/packages/patches/dmd-tests-longer-sleeps.patch \
gnu/packages/patches/doxygen-test.patch \
gnu/packages/patches/doxygen-tmake.patch \
gnu/packages/patches/emacs-configure-sh.patch \

View File

@ -53,16 +53,14 @@
(define-public dmd
(package
(name "dmd")
(version "0.1")
(version "0.2")
(source (origin
(method url-fetch)
(uri (string-append "ftp://alpha.gnu.org/gnu/dmd/dmd-"
version ".tar.gz"))
(sha256
(base32
"07mddw0p62fcphwjzgb6rfa0pjz5sy6jzbha0sm2vc3rqf459jxg"))
(patches (list (search-patch "dmd-getpw.patch")
(search-patch "dmd-tests-longer-sleeps.patch")))))
"10fl4k96f17gqx2fv8iw9c61ld26gsk4bbrlfqckdmiimz1k175z"))))
(build-system gnu-build-system)
(arguments
'(#:configure-flags '("--localstatedir=/var")))

View File

@ -1,19 +0,0 @@
When bootstrapping and running as PID 1, /etc/{passwd,shadow} may be unavailable.
Gracefully handle that.
diff --git a/modules/dmd/support.scm b/modules/dmd/support.scm
index 9b592c5..602e409 100644
--- a/modules/dmd/support.scm
+++ b/modules/dmd/support.scm
@@ -151,7 +151,10 @@ There is NO WARRANTY, to the extent permitted by law.")))
;; Home directory of the user.
-(define user-homedir (passwd:dir (getpwuid (getuid))))
+(define user-homedir
+ (or (false-if-exception (passwd:dir (getpwuid (getuid))))
+ (getenv "HOME")
+ "/"))
;; Logfile.
(define default-logfile

View File

@ -1,52 +0,0 @@
Increase sleep times in tests, for slower machines.
Patch by Mark H Weaver <mhw@netris.org>.
--- dmd/tests/basic.sh 2013-11-30 17:22:00.000000000 -0500
+++ dmd/tests/basic.sh 2014-02-16 02:18:34.036376953 -0500
@@ -46,7 +46,7 @@
dmd -I -s "$socket" -c "$conf" -l "$log" &
dmd_pid=$!
-sleep 1 # XXX: wait till it's up
+sleep 3 # XXX: wait till it's up
kill -0 $dmd_pid
test -S "$socket"
$deco status dmd | grep -E '(Start.*dmd|Stop.*test)'
--- dmd/tests/respawn.sh 2013-12-01 16:50:37.000000000 -0500
+++ dmd/tests/respawn.sh 2014-02-16 02:19:16.958251953 -0500
@@ -39,7 +39,7 @@
i=0
while ! test -f "$1" && test $i -lt 20
do
- sleep 0.3
+ sleep 1
i=`expr $i + 1`
done
test -f "$1"
@@ -65,14 +65,14 @@
#:provides '(test1)
#:start (make-forkexec-constructor
"$SHELL" "-c"
- "echo \$\$ > $service1_pid ; while true ; do sleep 1 ; done")
+ "echo \$\$ > $service1_pid ; while true ; do sleep 3 ; done")
#:stop (make-kill-destructor)
#:respawn? #t)
(make <service>
#:provides '(test2)
#:start (make-forkexec-constructor
"$SHELL" "-c"
- "echo \$\$ > $service2_pid ; while true ; do sleep 1 ; done")
+ "echo \$\$ > $service2_pid ; while true ; do sleep 3 ; done")
#:stop (make-kill-destructor)
#:respawn? #t))
(start 'test1)
@@ -82,7 +82,7 @@
dmd -I -s "$socket" -c "$conf" -l "$log" &
dmd_pid=$!
-sleep 1 # XXX: wait till it's up
+sleep 3 # XXX: wait till it's up
kill -0 $dmd_pid
test -S "$socket"
$deco status test1 | grep started