gnu: khmer: Update to 3.0.0a3.
* gnu/packages/bioinformatics.scm (khmer): Update to 3.0.0a3. [source]: Remove patch; remove seqan in snippet. [inputs]: Add seqan-1. * gnu/packages/patches/khmer-use-libraries.patch: Remove file. * gnu/local.mk (dist_patch_DATA): Remove it.
This commit is contained in:
parent
c2c4ac0f69
commit
b556abe416
|
@ -951,7 +951,6 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/java-xerces-xjavac_taskdef.patch \
|
||||
%D%/packages/patches/jbig2dec-ignore-testtest.patch \
|
||||
%D%/packages/patches/kdbusaddons-kinit-file-name.patch \
|
||||
%D%/packages/patches/khmer-use-libraries.patch \
|
||||
%D%/packages/patches/libziparchive-add-includes.patch \
|
||||
%D%/packages/patches/localed-xorg-keyboard.patch \
|
||||
%D%/packages/patches/kiki-level-selection-crash.patch \
|
||||
|
|
|
@ -4168,7 +4168,7 @@ command, or queried for specific k-mers with @code{jellyfish query}.")
|
|||
(define-public khmer
|
||||
(package
|
||||
(name "khmer")
|
||||
(version "2.1.2")
|
||||
(version "3.0.0a3")
|
||||
(source
|
||||
(origin
|
||||
(method git-fetch)
|
||||
|
@ -4178,8 +4178,7 @@ command, or queried for specific k-mers with @code{jellyfish query}.")
|
|||
(file-name (git-file-name name version))
|
||||
(sha256
|
||||
(base32
|
||||
"02x38d9jw2r58y8dmnj4hffy9wxv1yc1jwbvdbhby9dxndv94r9m"))
|
||||
(patches (search-patches "khmer-use-libraries.patch"))
|
||||
"01l4jczglkl7yfhgvzx8j0df7k54bk1r8sli9ll16i1mis0d8f37"))
|
||||
(modules '((guix build utils)))
|
||||
(snippet
|
||||
'(begin
|
||||
|
@ -4192,6 +4191,12 @@ command, or queried for specific k-mers with @code{jellyfish query}.")
|
|||
;; https://lists.gnu.org/archive/html/guix-devel/2016-06/msg00977.html
|
||||
(delete-file-recursively "third-party/zlib")
|
||||
(delete-file-recursively "third-party/bzip2")
|
||||
(delete-file-recursively "third-party/seqan")
|
||||
(substitute* "setup.cfg"
|
||||
(("# libraries = z,bz2")
|
||||
"libraries = z,bz2")
|
||||
(("include:third-party/zlib:third-party/bzip2")
|
||||
"include:"))
|
||||
#t))))
|
||||
(build-system python-build-system)
|
||||
(arguments
|
||||
|
@ -4208,6 +4213,7 @@ command, or queried for specific k-mers with @code{jellyfish query}.")
|
|||
(inputs
|
||||
`(("zlib" ,zlib)
|
||||
("bzip2" ,bzip2)
|
||||
("seqan" ,seqan-1)
|
||||
("python-screed" ,python-screed)
|
||||
("python-bz2file" ,python-bz2file)))
|
||||
(home-page "https://khmer.readthedocs.org/")
|
||||
|
|
|
@ -1,16 +0,0 @@
|
|||
Change setup.cfg so that the bundled zlib and bzip2 are not used. This cannot
|
||||
currently be achieved using "--library z,bz2" as instructed in the setup.py.
|
||||
|
||||
diff --git a/setup.cfg b/setup.cfg
|
||||
index c054092..080992e 100644
|
||||
--- a/setup.cfg
|
||||
+++ b/setup.cfg
|
||||
@@ -1,7 +1,7 @@
|
||||
[build_ext]
|
||||
define = SEQAN_HAS_BZIP2,SEQAN_HAS_ZLIB
|
||||
undef = NO_UNIQUE_RC
|
||||
-# libraries = z,bz2
|
||||
+libraries = z,bz2
|
||||
## if using system libraries
|
||||
include-dirs = lib:third-party/zlib:third-party/bzip2:third-party/seqan/core/include:third-party/smhasher
|
||||
# include-dirs = lib
|
Loading…
Reference in New Issue