gnu: mutt: Don't retain reference to GCC.

* gnu/packages/patches/mutt-store-references.patch: New file.
* gnu/packages/mail.scm (mutt)[source]: Use it.
* gnu-system.am (dist_patch_DATA): Add it.
master
Ludovic Courtès 2015-06-26 23:01:43 +02:00
parent 9161ba818d
commit b5b08878b6
3 changed files with 20 additions and 1 deletions

View File

@ -523,6 +523,7 @@ dist_patch_DATA = \
gnu/packages/patches/mumps-build-parallelism.patch \
gnu/packages/patches/mupdf-buildsystem-fix.patch \
gnu/packages/patches/mutt-CVE-2014-9116.patch \
gnu/packages/patches/mutt-store-references.patch \
gnu/packages/patches/net-tools-bitrot.patch \
gnu/packages/patches/ngircd-handle-zombies.patch \
gnu/packages/patches/ngircd-no-dns-in-tests.patch \

View File

@ -184,7 +184,9 @@ aliasing facilities to work just as they would on normal mail.")
(sha256
(base32
"0dzx4qk50pjfsb6cs5jahng96a52k12f7pm0sc78iqdrawg71w1s"))
(patches (list (search-patch "mutt-CVE-2014-9116.patch")))))
(patches (map search-patch
'("mutt-CVE-2014-9116.patch"
"mutt-store-references.patch")))))
(build-system gnu-build-system)
(inputs
`(("cyrus-sasl" ,cyrus-sasl)

View File

@ -0,0 +1,16 @@
By default 'mutt' embeds configure flags and the output of 'gcc -v',
which contains the store file name of Bash and GCC. This patch makes
sure we don't embed a reference to these in 'mutt'.
--- mutt-1.5.23/txt2c.sh 2015-06-26 22:56:56.500731643 +0200
+++ mutt-1.5.23/txt2c.sh 2015-06-26 22:57:26.664583900 +0200
@@ -21,6 +21,8 @@ txt2c_fallback () {
echo ";"
}
+echo "unsigned char $1[] = \"value of '$1' not kept\";"
+exit 0
./txt2c test </dev/null >/dev/null 2>&1 &&
./txt2c "$1" ||
txt2c_fallback "$1"