gnu: calibre: Add a patch to avoid automatic checking for updates.

* gnu/packages/patches/calibre-no-updates-dialog.patch: New file.
* gnu-system.am (dist_patch_DATA): Register patch.
* gnu/packages/ebook.scm (calibre): Use patch.
master
Andreas Enge 2015-03-24 20:35:37 +01:00
parent 2c16316ef4
commit b655b2154c
3 changed files with 21 additions and 1 deletions

View File

@ -375,6 +375,7 @@ dist_patch_DATA = \
gnu/packages/patches/binutils-ld-new-dtags.patch \
gnu/packages/patches/binutils-loongson-workaround.patch \
gnu/packages/patches/calibre-drop-unrar.patch \
gnu/packages/patches/calibre-no-updates-dialog.patch \
gnu/packages/patches/cdparanoia-fpic.patch \
gnu/packages/patches/chmlib-inttypes.patch \
gnu/packages/patches/clucene-pkgconfig.patch \

View File

@ -77,7 +77,8 @@
'(begin
(delete-file-recursively "src/unrar")
(delete-file "src/odf/thumbnail.py")))
(patches (list (search-patch "calibre-drop-unrar.patch")))))
(patches (list (search-patch "calibre-drop-unrar.patch")
(search-patch "calibre-no-updates-dialog.patch")))))
(build-system python-build-system)
(native-inputs
`(("pkg-config" ,pkg-config)

View File

@ -0,0 +1,18 @@
Taken from debian.
# Description: Disable update check by default.
Index: calibre/src/calibre/gui2/main.py
===================================================================
--- calibre.orig/src/calibre/gui2/main.py 2014-02-02 10:41:28.470954623 +0100
+++ calibre/src/calibre/gui2/main.py 2014-02-02 10:41:56.546954247 +0100
@@ -37,8 +37,8 @@
help=_('Start minimized to system tray.'))
parser.add_option('-v', '--verbose', default=0, action='count',
help=_('Ignored, do not use. Present only for legacy reasons'))
- parser.add_option('--no-update-check', default=False, action='store_true',
- help=_('Do not check for updates'))
+ parser.add_option('--update-check', dest='no_update_check', default=True, action='store_false',
+ help=_('Check for updates'))
parser.add_option('--ignore-plugins', default=False, action='store_true',
help=_('Ignore custom plugins, useful if you installed a plugin'
' that is preventing calibre from starting'))