gnu: meandmyshadow: Update to 10.5a.
* gnu/packages/games.scm (meandmyshadow): Update to 10.5a. [source]: Remove patch. * gnu/local.mk (dist_patch_DATA): Unregister patch. * gnu/packages/patches/meandmyshadow-define-paths-earlier.patch: Delete file.
This commit is contained in:
parent
dec0c11c33
commit
b70ff03e59
|
@ -965,7 +965,6 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/mcrypt-CVE-2012-4409.patch \
|
||||
%D%/packages/patches/mcrypt-CVE-2012-4426.patch \
|
||||
%D%/packages/patches/mcrypt-CVE-2012-4527.patch \
|
||||
%D%/packages/patches/meandmyshadow-define-paths-earlier.patch \
|
||||
%D%/packages/patches/mesa-skip-disk-cache-test.patch \
|
||||
%D%/packages/patches/meson-for-build-rpath.patch \
|
||||
%D%/packages/patches/metabat-fix-compilation.patch \
|
||||
|
|
|
@ -573,7 +573,7 @@ automata. The following features are available:
|
|||
(define-public meandmyshadow
|
||||
(package
|
||||
(name "meandmyshadow")
|
||||
(version "0.5")
|
||||
(version "0.5a")
|
||||
(source (origin
|
||||
(method url-fetch)
|
||||
(uri (string-append "mirror://sourceforge/meandmyshadow/"
|
||||
|
@ -581,10 +581,7 @@ automata. The following features are available:
|
|||
"-src.tar.gz"))
|
||||
(sha256
|
||||
(base32
|
||||
"1b6qf83vdfv8jwn2jq9ywmda2qn2f5914i7mwfy04m17wx593m3m"))
|
||||
(patches (search-patches
|
||||
;; This will not be needed in the next release.
|
||||
"meandmyshadow-define-paths-earlier.patch"))))
|
||||
"0i98v6cgmpsxy7mbb0s2y6f6qq6mkwzk2nrv1nz39ncf948aky2h"))))
|
||||
(build-system cmake-build-system)
|
||||
(arguments
|
||||
`(#:tests? #f)) ; there are no tests
|
||||
|
|
|
@ -1,50 +0,0 @@
|
|||
From: Tobias Geerinckx-Rice <me@tobias.gr>
|
||||
Date: Wed, 31 Oct 2018 02:24:26 +0100
|
||||
Subject: [PATCH] gnu: meandmyshadow: Define paths earlier.
|
||||
|
||||
The following patch was taken verbatim from the upstream repository[0]
|
||||
and will be included in the next release.
|
||||
|
||||
[0]: https://github.com/acmepjz/meandmyshadow/pull/29
|
||||
---
|
||||
From 4847e6b5755258a1e0534f2d4b91dce2ce3b459e Mon Sep 17 00:00:00 2001
|
||||
From: Dmitry Marakasov <amdmi3@amdmi3.ru>
|
||||
Date: Wed, 24 Oct 2018 23:31:19 +0300
|
||||
Subject: [PATCH] Define paths earlier in CMakeLists.txt
|
||||
|
||||
At the very least, paths should be defined before Configure_File(), otherwise empty DATAROOTDIR is substituted in config.h
|
||||
---
|
||||
CMakeLists.txt | 13 +++++++------
|
||||
1 file changed, 7 insertions(+), 6 deletions(-)
|
||||
|
||||
diff --git a/CMakeLists.txt b/CMakeLists.txt
|
||||
index e79639a..6321d9d 100644
|
||||
--- a/CMakeLists.txt
|
||||
+++ b/CMakeLists.txt
|
||||
@@ -2,6 +2,13 @@ Project (meandmyshadow)
|
||||
CMake_Minimum_Required (VERSION 3.1)
|
||||
Set (CMAKE_MODULE_PATH ${CMAKE_MODULE_PATH} "${CMAKE_SOURCE_DIR}/cmake/Modules/")
|
||||
|
||||
+#Path options
|
||||
+Set (BINDIR "bin" CACHE STRING "Where to install binaries")
|
||||
+Set (DATAROOTDIR "${CMAKE_INSTALL_PREFIX}/share" CACHE STRING "Sets the root of data directories to a non-default location")
|
||||
+Set (ICONDIR "${DATAROOTDIR}/icons" CACHE STRING "Sets the icon directory for desktop entry to a non-default location.")
|
||||
+Set (DESKTOPDIR "${DATAROOTDIR}/applications" CACHE STRING "Sets the desktop file directory for desktop entry to a non-default location.")
|
||||
+
|
||||
+#Options
|
||||
Option (DEBUG_MODE "Compile the game with debug mode enabled" OFF)
|
||||
Option (DISABLED_DEBUG_STUFF "Enable this you'll see a lot of annoying script debug messages which will lag the game." OFF)
|
||||
|
||||
@@ -164,12 +171,6 @@ Target_Link_Libraries (
|
||||
${LUA_LIBRARIES}
|
||||
)
|
||||
|
||||
-#Path options
|
||||
-Set (BINDIR "bin" CACHE STRING "Where to install binaries")
|
||||
-Set (DATAROOTDIR "${CMAKE_INSTALL_PREFIX}/share" CACHE STRING "Sets the root of data directories to a non-default location")
|
||||
-Set (ICONDIR "${DATAROOTDIR}/icons" CACHE STRING "Sets the icon directory for desktop entry to a non-default location.")
|
||||
-Set (DESKTOPDIR "${DATAROOTDIR}/applications" CACHE STRING "Sets the desktop file directory for desktop entry to a non-default location.")
|
||||
-
|
||||
#Install locations
|
||||
Install (DIRECTORY ${PROJECT_SOURCE_DIR}/data DESTINATION ${DATAROOTDIR}/meandmyshadow/)
|
||||
Install (FILES AUTHORS DESTINATION ${DATAROOTDIR}/meandmyshadow/)
|
Loading…
Reference in New Issue