gnu: Default to GCC 5.
This reinstates and adjusts
commit e3d0fcbf7e
.
* gnu/packages/patches/gcc-libiberty-printf-decl.patch: New file.
* gnu/packages/gcc.scm (gcc-5)[source]: Use it.
[patches]: Add "gcc-arm-bug-71399.patch".
(gcc): Switch to GCC-5.
* gnu/packages/commencement.scm (libstdc++-boot0): New variable.
(gcc-boot0)[inputs]: Add it.
(gcc-toolchain-4.9): Switch to GCC-4.9.
(gcc-toolchain-5): Switch to GCC-FINAL.
* gnu/local.mk (dist_patch_DATA): Add 'gcc-libiberty-printf-decl.patch'.
This commit is contained in:
parent
1d0ceb4775
commit
b810a85019
|
@ -546,6 +546,7 @@ dist_patch_DATA = \
|
||||||
%D%/packages/patches/gcc-arm-bug-71399.patch \
|
%D%/packages/patches/gcc-arm-bug-71399.patch \
|
||||||
%D%/packages/patches/gcc-arm-link-spec-fix.patch \
|
%D%/packages/patches/gcc-arm-link-spec-fix.patch \
|
||||||
%D%/packages/patches/gcc-cross-environment-variables.patch \
|
%D%/packages/patches/gcc-cross-environment-variables.patch \
|
||||||
|
%D%/packages/patches/gcc-libiberty-printf-decl.patch \
|
||||||
%D%/packages/patches/gcc-libvtv-runpath.patch \
|
%D%/packages/patches/gcc-libvtv-runpath.patch \
|
||||||
%D%/packages/patches/gcc-strmov-store-file-names.patch \
|
%D%/packages/patches/gcc-strmov-store-file-names.patch \
|
||||||
%D%/packages/patches/gcc-5.0-libvtv-runpath.patch \
|
%D%/packages/patches/gcc-5.0-libvtv-runpath.patch \
|
||||||
|
|
|
@ -172,6 +172,26 @@
|
||||||
,cf)))))
|
,cf)))))
|
||||||
(inputs %boot0-inputs))))
|
(inputs %boot0-inputs))))
|
||||||
|
|
||||||
|
(define libstdc++-boot0
|
||||||
|
;; GCC's libcc1 is always built as a shared library (the top-level
|
||||||
|
;; 'Makefile.def' forcefully adds --enable-shared) and thus needs to refer
|
||||||
|
;; to libstdc++.so. We cannot build libstdc++-5.3 because it relies on
|
||||||
|
;; C++14 features missing in our bootstrap compiler.
|
||||||
|
(let ((lib (package-with-bootstrap-guile (make-libstdc++ gcc-4.9))))
|
||||||
|
(package
|
||||||
|
(inherit lib)
|
||||||
|
(name "libstdc++-boot0")
|
||||||
|
(arguments
|
||||||
|
`(#:guile ,%bootstrap-guile
|
||||||
|
#:implicit-inputs? #f
|
||||||
|
|
||||||
|
;; XXX: libstdc++.so NEEDs ld.so for some reason.
|
||||||
|
#:validate-runpath? #f
|
||||||
|
|
||||||
|
,@(package-arguments lib)))
|
||||||
|
(inputs %boot0-inputs)
|
||||||
|
(native-inputs '()))))
|
||||||
|
|
||||||
(define gcc-boot0
|
(define gcc-boot0
|
||||||
(package-with-bootstrap-guile
|
(package-with-bootstrap-guile
|
||||||
(package (inherit gcc)
|
(package (inherit gcc)
|
||||||
|
@ -257,6 +277,9 @@
|
||||||
("mpc-source" ,(package-source mpc))
|
("mpc-source" ,(package-source mpc))
|
||||||
("binutils-cross" ,binutils-boot0)
|
("binutils-cross" ,binutils-boot0)
|
||||||
|
|
||||||
|
;; The libstdc++ that libcc1 links against.
|
||||||
|
("libstdc++" ,libstdc++-boot0)
|
||||||
|
|
||||||
;; Call it differently so that the builder can check whether
|
;; Call it differently so that the builder can check whether
|
||||||
;; the "libc" input is #f.
|
;; the "libc" input is #f.
|
||||||
("libc-native" ,@(assoc-ref %boot0-inputs "libc"))
|
("libc-native" ,@(assoc-ref %boot0-inputs "libc"))
|
||||||
|
@ -986,10 +1009,10 @@ and binaries, plus debugging symbols in the 'debug' output), and Binutils.")
|
||||||
(gcc-toolchain gcc-4.8))
|
(gcc-toolchain gcc-4.8))
|
||||||
|
|
||||||
(define-public gcc-toolchain-4.9
|
(define-public gcc-toolchain-4.9
|
||||||
(gcc-toolchain gcc-final))
|
(gcc-toolchain gcc-4.9))
|
||||||
|
|
||||||
(define-public gcc-toolchain-5
|
(define-public gcc-toolchain-5
|
||||||
(gcc-toolchain gcc-5))
|
(gcc-toolchain gcc-final))
|
||||||
|
|
||||||
(define-public gcc-toolchain-6
|
(define-public gcc-toolchain-6
|
||||||
(gcc-toolchain gcc-6))
|
(gcc-toolchain gcc-6))
|
||||||
|
|
|
@ -358,7 +358,8 @@ Go. It also includes runtime support libraries for these languages.")
|
||||||
(sha256
|
(sha256
|
||||||
(base32
|
(base32
|
||||||
"0fihlcy5hnksdxk0sn6bvgnyq8gfrgs8m794b1jxwd1dxinzg3b0"))
|
"0fihlcy5hnksdxk0sn6bvgnyq8gfrgs8m794b1jxwd1dxinzg3b0"))
|
||||||
(patches (search-patches "gcc-strmov-store-file-names.patch"
|
(patches (search-patches "gcc-arm-bug-71399.patch"
|
||||||
|
"gcc-strmov-store-file-names.patch"
|
||||||
"gcc-5.0-libvtv-runpath.patch"))))))
|
"gcc-5.0-libvtv-runpath.patch"))))))
|
||||||
|
|
||||||
(define-public gcc-6
|
(define-public gcc-6
|
||||||
|
@ -377,7 +378,7 @@ Go. It also includes runtime support libraries for these languages.")
|
||||||
|
|
||||||
;; Note: When changing the default gcc version, update
|
;; Note: When changing the default gcc version, update
|
||||||
;; the gcc-toolchain-* definitions accordingly.
|
;; the gcc-toolchain-* definitions accordingly.
|
||||||
(define-public gcc gcc-4.9)
|
(define-public gcc gcc-5)
|
||||||
|
|
||||||
(define-public (make-libstdc++ gcc)
|
(define-public (make-libstdc++ gcc)
|
||||||
"Return a libstdc++ package based on GCC. The primary use case is when
|
"Return a libstdc++ package based on GCC. The primary use case is when
|
||||||
|
|
|
@ -0,0 +1,28 @@
|
||||||
|
This patch makes the exeception specifier of libiberty's 'asprintf'
|
||||||
|
and 'vasprintf' declarations match those of glibc to work around the
|
||||||
|
problem described at <https://gcc.gnu.org/ml/gcc-help/2016-04/msg00039.html>.
|
||||||
|
|
||||||
|
The problem in part stems from the fact that libiberty is configured
|
||||||
|
without _GNU_SOURCE (thus, it sets HAVE_DECL_ASPRINTF to 0), whereas libcc1
|
||||||
|
is configured and built with _GNU_SOURCE, hence the conflicting declarations.
|
||||||
|
|
||||||
|
--- gcc-5.3.0/include/libiberty.h 2016-04-23 22:45:46.262709079 +0200
|
||||||
|
+++ gcc-5.3.0/include/libiberty.h 2016-04-23 22:45:37.110635439 +0200
|
||||||
|
@@ -625,7 +625,7 @@ extern int pwait (int, int *, int);
|
||||||
|
/* Like sprintf but provides a pointer to malloc'd storage, which must
|
||||||
|
be freed by the caller. */
|
||||||
|
|
||||||
|
-extern int asprintf (char **, const char *, ...) ATTRIBUTE_PRINTF_2;
|
||||||
|
+extern int asprintf (char **, const char *, ...) __THROWNL ATTRIBUTE_PRINTF_2;
|
||||||
|
#endif
|
||||||
|
|
||||||
|
/* Like asprintf but allocates memory without fail. This works like
|
||||||
|
@@ -637,7 +637,7 @@ extern char *xasprintf (const char *, ..
|
||||||
|
/* Like vsprintf but provides a pointer to malloc'd storage, which
|
||||||
|
must be freed by the caller. */
|
||||||
|
|
||||||
|
-extern int vasprintf (char **, const char *, va_list) ATTRIBUTE_PRINTF(2,0);
|
||||||
|
+extern int vasprintf (char **, const char *, va_list) __THROWNL ATTRIBUTE_PRINTF(2,0);
|
||||||
|
#endif
|
||||||
|
|
||||||
|
/* Like vasprintf but allocates memory without fail. This works like
|
Loading…
Reference in New Issue