gnu: hdf5: Have configure honor SOURCE_DATE_EPOCH.
* gnu/packages/patches/hdf5-config-date.patch: New patch. * gnu/packages/maths.scm (hdf5)[source]: Use it. * gnu-system.am (dist_patch_DATA): Add it.
This commit is contained in:
parent
f622e2123b
commit
b8d9c93bde
|
@ -531,6 +531,7 @@ dist_patch_DATA = \
|
|||
gnu/packages/patches/gtk2-respect-GUIX_GTK2_PATH.patch \
|
||||
gnu/packages/patches/gtk3-respect-GUIX_GTK3_PATH.patch \
|
||||
gnu/packages/patches/gtkglext-disable-disable-deprecated.patch \
|
||||
gnu/packages/patches/hdf5-config-date.patch \
|
||||
gnu/packages/patches/hop-bigloo-4.0b.patch \
|
||||
gnu/packages/patches/hop-linker-flags.patch \
|
||||
gnu/packages/patches/hydra-automake-1.15.patch \
|
||||
|
|
|
@ -414,7 +414,8 @@ plotting engine by third-party applications like Octave.")
|
|||
version "/src/hdf5-"
|
||||
version ".tar.bz2"))
|
||||
(sha256
|
||||
(base32 "0sj8x0gfs5fb28gipnynb9wpkz113h8wq9sva9mxx66kv27xsdgw"))))
|
||||
(base32 "0sj8x0gfs5fb28gipnynb9wpkz113h8wq9sva9mxx66kv27xsdgw"))
|
||||
(patches (list (search-patch "hdf5-config-date.patch")))))
|
||||
(build-system gnu-build-system)
|
||||
(inputs
|
||||
`(("zlib" ,zlib)))
|
||||
|
@ -424,7 +425,8 @@ plotting engine by third-party applications like Octave.")
|
|||
(add-before 'configure 'patch-configure
|
||||
(lambda _
|
||||
(substitute* "configure"
|
||||
(("/bin/mv") "mv"))))
|
||||
(("/bin/mv") "mv"))
|
||||
#t))
|
||||
(add-after 'install 'patch-references
|
||||
(lambda* (#:key inputs outputs #:allow-other-keys)
|
||||
(let ((bin (string-append (assoc-ref outputs "out") "/bin"))
|
||||
|
|
|
@ -0,0 +1,21 @@
|
|||
Honor SOURCE_DATE_EPOCH when exporting configuration date.
|
||||
Autoconf-level patch submitted upstream on Wed Apr 13 17:03:23 UTC 2016
|
||||
|
||||
--- a/configure
|
||||
+++ b/configure
|
||||
@@ -27737,7 +28573,14 @@
|
||||
|
||||
|
||||
## Configuration date
|
||||
- CONFIG_DATE="`date`"
|
||||
+ CONFIG_DATE="`date -u`"
|
||||
+if test -n "$SOURCE_DATE_EPOCH"; then
|
||||
+ CONFIG_DATE=`date -u -d "@$SOURCE_DATE_EPOCH" 2>/dev/null \
|
||||
+ || date -u -r "$SOURCE_DATE_EPOCH" 2>/dev/null`
|
||||
+ if test -z "$CONFIG_DATE"; then
|
||||
+ as_fn_error $? "malformed SOURCE_DATE_EPOCH" "$LINENO" 5
|
||||
+ fi
|
||||
+fi
|
||||
|
||||
## User doing the configuration
|
||||
CONFIG_USER="`whoami`@`hostname`"
|
Loading…
Reference in New Issue