gnu: translate-shell: Update to 0.9.6.8.

* gnu/packages/dictionaries.scm (translate-shell): Update to 0.9.6.8.
[source]: Remove patch.
* gnu/packages/patches/translate-shell-fix-curl-tests.patch: Delete file.
* gnu/local.mk (dist_patch_DATA): Remove it.
master
Tobias Geerinckx-Rice 2018-08-14 14:52:45 +02:00
parent 422a6cd4c3
commit b92302fd6c
No known key found for this signature in database
GPG Key ID: 0DB0FF884F556D79
3 changed files with 4 additions and 66 deletions

View File

@ -1164,7 +1164,6 @@ dist_patch_DATA = \
%D%/packages/patches/tipp10-fix-compiling.patch \
%D%/packages/patches/tipp10-remove-license-code.patch \
%D%/packages/patches/tk-find-library.patch \
%D%/packages/patches/translate-shell-fix-curl-tests.patch \
%D%/packages/patches/ttf2eot-cstddef.patch \
%D%/packages/patches/ttfautohint-source-date-epoch.patch \
%D%/packages/patches/tophat-build-with-later-seqan.patch \

View File

@ -238,7 +238,7 @@ and a Python library.")
(define-public translate-shell
(package
(name "translate-shell")
(version "0.9.6.7")
(version "0.9.6.8")
(source
(origin
(method url-fetch)
@ -246,14 +246,13 @@ and a Python library.")
version ".tar.gz"))
(sha256
(base32
"0inv6r3qbihn2ff1sgcly89r04k4vgcbvvyl50ln0mxlapbhpy95"))
(patches (search-patches "translate-shell-fix-curl-tests.patch"))
"17yc2kwk8957wwxyih0jmsai720ai2yqyvmrqrglcncqg6zdbz9w"))
(file-name (string-append name "-" version ".tar.gz"))))
(build-system gnu-build-system)
(arguments
`(#:phases
(modify-phases %standard-phases
(delete 'configure) ; no configure phase
(delete 'configure) ; no configure phase
(add-after 'install 'emacs-install
(lambda* (#:key inputs outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))
@ -275,7 +274,7 @@ and a Python library.")
("rlwrap" ,rlwrap)))
(native-inputs
`(("emacs" ,emacs-minimal)
("util-linux" ,util-linux))) ; hexdump, for the test
("util-linux" ,util-linux))) ; hexdump, for the test
(home-page "https://www.soimort.org/translate-shell/")
(synopsis "Translations from the command line")
(description

View File

@ -1,60 +0,0 @@
This patch fixes Curl related tests for 'translate-shell'.
Upstream bug URL:
https://github.com/soimort/translate-shell/issues/221
From bb9f32d3145125ba664b6b05bf0a2fd34108e9d2 Mon Sep 17 00:00:00 2001
From: Mort Yao <soi@mort.ninja>
Date: Sun, 25 Mar 2018 03:14:33 +0200
Subject: [PATCH] TestUtils: perform curl-related tests only if NETWORK_ACCESS
is set to yes (#221)
---
test/TestUtils.awk | 32 +++++++++++++++++---------------
1 file changed, 17 insertions(+), 15 deletions(-)
diff --git a/test/TestUtils.awk b/test/TestUtils.awk
index 08bb2e9..1c141e5 100644
--- a/test/TestUtils.awk
+++ b/test/TestUtils.awk
@@ -30,22 +30,24 @@ BEGIN {
assertTrue(newerVersion("2", "1.9.9999"))
}
- T("curl()", 1)
- {
- delete tokens; delete ast
- tokenize(tokens, curl("https://httpbin.org/get"))
- parseJson(ast, tokens)
- assertEqual(unparameterize(ast[0 SUBSEP "url"]),
- "https://httpbin.org/get")
- }
+ if (yn(ENVIRON["NETWORK_ACCESS"])) { # if network access enabled
+ T("curl()", 1)
+ {
+ delete tokens; delete ast
+ tokenize(tokens, curl("https://httpbin.org/get"))
+ parseJson(ast, tokens)
+ assertEqual(unparameterize(ast[0 SUBSEP "url"]),
+ "https://httpbin.org/get")
+ }
- T("curlPost()", 1)
- {
- delete tokens; delete ast
- tokenize(tokens, curlPost("https://httpbin.org/post", "fizz=buzz"))
- parseJson(ast, tokens)
- assertEqual(unparameterize(ast[0 SUBSEP "url"]),
- "https://httpbin.org/post")
+ T("curlPost()", 1)
+ {
+ delete tokens; delete ast
+ tokenize(tokens, curlPost("https://httpbin.org/post", "fizz=buzz"))
+ parseJson(ast, tokens)
+ assertEqual(unparameterize(ast[0 SUBSEP "url"]),
+ "https://httpbin.org/post")
+ }
}
T("dump()", 3)