gnu: emacs: Update to 26.1.

* gnu/packages/emacs.scm (emacs): Update to 26.1,
[arguments]: disable tests as they do not exist in release.
* gnu/packages/patches/emacs-fix-scheme-indent-function.patch: Update patch
indentation and line numbers.
This commit is contained in:
Mathieu Othacehe 2018-05-28 18:23:07 +02:00
parent ed71cda2ac
commit bb82c3d42b
No known key found for this signature in database
GPG Key ID: 8354763531769CA6
2 changed files with 11 additions and 10 deletions

View File

@ -114,14 +114,14 @@
(define-public emacs (define-public emacs
(package (package
(name "emacs") (name "emacs")
(version "25.3") (version "26.1")
(source (origin (source (origin
(method url-fetch) (method url-fetch)
(uri (string-append "mirror://gnu/emacs/emacs-" (uri (string-append "mirror://gnu/emacs/emacs-"
version ".tar.xz")) version ".tar.xz"))
(sha256 (sha256
(base32 (base32
"02y00y9q42g1iqgz5qhmsja75hwxd88yrn9zp14lanay0zkwafi5")) "0b6k1wq44rc8gkvxhi1bbjxbz3cwg29qbq8mklq2az6p1hjgrx0w"))
(patches (search-patches "emacs-exec-path.patch" (patches (search-patches "emacs-exec-path.patch"
"emacs-fix-scheme-indent-function.patch" "emacs-fix-scheme-indent-function.patch"
"emacs-source-date-epoch.patch")) "emacs-source-date-epoch.patch"))
@ -159,7 +159,8 @@
" "))))))) " ")))))))
(build-system glib-or-gtk-build-system) (build-system glib-or-gtk-build-system)
(arguments (arguments
`(#:phases `(#:tests? #f ; no check target
#:phases
(modify-phases %standard-phases (modify-phases %standard-phases
(add-before 'configure 'fix-/bin/pwd (add-before 'configure 'fix-/bin/pwd
(lambda _ (lambda _

View File

@ -14,16 +14,16 @@ The fix is made by Mark H Weaver <mhw@netris.org>:
--- a/lisp/progmodes/scheme.el --- a/lisp/progmodes/scheme.el
+++ b/lisp/progmodes/scheme.el +++ b/lisp/progmodes/scheme.el
@@ -482,6 +482,12 @@ @@ -494,6 +494,12 @@ indentation."
(> (length function) 3) (> (length function) 3)
(string-match "\\`def" function))) (string-match "\\`def" function)))
(lisp-indent-defform state indent-point)) (lisp-indent-defform state indent-point))
+ ((and (null method) + ((and (null method)
+ (> (length function) 1) + (> (length function) 1)
+ ;; The '#' in '#:' seems to get lost, not sure why + ;; The '#' in '#:' seems to get lost, not sure why
+ (string-match "\\`:" function)) + (string-match "\\`:" function))
+ (let ((lisp-body-indent 1)) + (let ((lisp-body-indent 1))
+ (lisp-indent-defform state indent-point))) + (lisp-indent-defform state indent-point)))
((integerp method) ((integerp method)
(lisp-indent-specform method state (lisp-indent-specform method state
indent-point normal-indent)) indent-point normal-indent))