gnu: dbus: Update to 1.10.0.

* gnu/packages/glib.scm (dbus)[source]: Update to 1.10.0.
  [arguments]: Add --sysconfdir=/etc.
* gnu/packages/patches/dbus-localstatedir.patch: Update.
This commit is contained in:
Ludovic Courtès 2015-10-14 11:56:13 +02:00
parent 9f7ae77fe2
commit bbe04ae102
2 changed files with 34 additions and 20 deletions

View File

@ -57,7 +57,7 @@
(define dbus (define dbus
(package (package
(name "dbus") (name "dbus")
(version "1.8.16") (version "1.10.0")
(source (origin (source (origin
(method url-fetch) (method url-fetch)
(uri (uri
@ -65,16 +65,21 @@
version ".tar.gz")) version ".tar.gz"))
(sha256 (sha256
(base32 (base32
"01rba8mp8kqvmy6ibdmi806kjr3m14swnskqk02gyhykxxl54ybz")) "0jwj7wlrhq5y0fwfh8k2d9rgdpfax06lj8698g6iqbwrzd2rgyqx"))
(patches (list (search-patch "dbus-localstatedir.patch"))))) (patches (list (search-patch "dbus-localstatedir.patch")))))
(build-system gnu-build-system) (build-system gnu-build-system)
(arguments (arguments
'(#:configure-flags (list ;; Install the system bus socket under /var. '(#:configure-flags (list ;; Install the system bus socket under /var.
"--localstatedir=/var" "--localstatedir=/var"
;; XXX: Fix the following to allow system-wide ;; Look for configuration file under
;; config. ;; /etc/dbus-1. This is notably required by
;; "--sysconfdir=/etc" ;; 'dbus-daemon-launch-helper', which looks for
;; the 'system.conf' file in that place,
;; regardless of what '--config-file' was
;; passed to 'dbus-daemon' on the command line;
;; see <https://bugs.freedesktop.org/show_bug.cgi?id=92458>.
"--sysconfdir=/etc"
"--with-session-socket-dir=/tmp") "--with-session-socket-dir=/tmp")
#:phases (alist-cons-after #:phases (alist-cons-after

View File

@ -1,25 +1,34 @@
Do not try to create $localstatedir and $sysconfdir since we cannot do this Do not try to create $localstatedir and $sysconfdir since we cannot do this
when they are /var and /etc. when they are /var and /etc.
--- dbus-1.6.4/bus/Makefile.in 2013-09-11 16:15:13.000000000 +0200 --- a/bus/Makefile.in
+++ dbus-1.6.4/bus/Makefile.in 2013-09-11 16:15:15.000000000 +0200 +++ b/bus/Makefile.in
@@ -1510,9 +1510,6 @@ clean-local: @@ -565,7 +565,7 @@ top_build_prefix = @top_build_prefix@
/bin/rm *.bb *.bbg *.da *.gcov || true top_builddir = @top_builddir@
top_srcdir = @top_srcdir@
dbusdatadir = $(datadir)/dbus-1
-legacydbusdatadir = $(sysconfdir)/dbus-1
+legacydbusdatadir = $(prefix)/etc/dbus-1
dbus_daemon_execdir = $(DBUS_DAEMONDIR)
DBUS_BUS_LIBS = \
$(XML_LIBS) \
@@ -1669,7 +1669,6 @@ clean-local:
install-data-hook: install-data-hook:
- $(mkinstalldirs) $(DESTDIR)$(localstatedir)/run/dbus $(mkinstalldirs) $(DESTDIR)$(dbusdatadir)/session.d
- $(mkinstalldirs) $(DESTDIR)$(configdir)/system.d $(mkinstalldirs) $(DESTDIR)$(dbusdatadir)/services
- $(mkinstalldirs) $(DESTDIR)$(configdir)/session.d -@DBUS_UNIX_TRUE@ $(mkinstalldirs) $(DESTDIR)$(localstatedir)/run/dbus
$(mkinstalldirs) $(DESTDIR)$(datadir)/dbus-1/services @DBUS_UNIX_TRUE@ $(mkinstalldirs) $(DESTDIR)$(dbusdatadir)/system.d
$(mkinstalldirs) $(DESTDIR)$(datadir)/dbus-1/system-services @DBUS_UNIX_TRUE@ $(mkinstalldirs) $(DESTDIR)$(dbusdatadir)/system-services
# Install dbus.socket as default implementation of a D-Bus stack. # Install dbus.socket as default implementation of a D-Bus stack.
diff --git a/tools/Makefile.in b/tools/Makefile.in
--- dbus-1.6.4/tools/Makefile.in 2013-09-11 16:10:31.000000000 +0200 index 915971d..6b6897d 100644
+++ dbus-1.6.4/tools/Makefile.in 2013-09-11 16:10:32.000000000 +0200 --- a/tools/Makefile.in
@@ -757,11 +757,6 @@ uninstall-am: uninstall-binPROGRAMS +++ b/tools/Makefile.in
@@ -1055,12 +1055,6 @@ uninstall-am: uninstall-binPROGRAMS uninstall-dist_examplesSCRIPTS
.PRECIOUS: Makefile
# create the /var/lib/dbus directory for dbus-uuidgen -# create the /var/lib/dbus directory for dbus-uuidgen
-install-data-local: -install-data-local:
- $(MKDIR_P) $(DESTDIR)$(localstatedir)/lib/dbus - $(MKDIR_P) $(DESTDIR)$(localstatedir)/lib/dbus
- -