gnu: xf86-video-vmware: Update to 13.0.2.

* gnu/packages/patches/xf86-video-vmware-glibc-2.20.patch: New file.
* gnu-system.am (dist_patch_DATA): Add it.
* gnu/packages/xorg.scm (xf86-video-vmware): Update to 13.0.2.
  Add patch.  Add mesa to inputs.
master
Mark H Weaver 2014-12-19 21:26:54 -05:00
parent 7dd17c76ae
commit bd6863c245
3 changed files with 21 additions and 3 deletions

View File

@ -475,6 +475,7 @@ dist_patch_DATA = \
gnu/packages/patches/xf86-video-tdfx-remove-mibstore.patch \
gnu/packages/patches/xf86-video-tga-remove-mibstore.patch \
gnu/packages/patches/xf86-video-trident-remove-mibstore.patch \
gnu/packages/patches/xf86-video-vmware-glibc-2.20.patch \
gnu/packages/patches/xfce4-panel-plugins.patch \
gnu/packages/patches/xmodmap-asprintf.patch

View File

@ -0,0 +1,15 @@
Allow builds with glibc 2.20.
Based on a patch by Peter Hutterer <peter.hutterer@who-t.net>.
See <https://raw.githubusercontent.com/openembedded/oe-core/master/meta/recipes-graphics/xorg-driver/xf86-input-synaptics/always_include_xorg_server.h.patch>.
--- xf86-video-vmware-13.0.2/vmwgfx/vmwgfx_overlay.c.~1~ 2014-03-20 09:15:03.000000000 -0400
+++ xf86-video-vmware-13.0.2/vmwgfx/vmwgfx_overlay.c 2014-12-19 02:31:34.759122552 -0500
@@ -35,6 +35,8 @@
*/
+#include <xorg-server.h>
+
#include "xf86xv.h"
#include "fourcc.h"
#define debug_printf(...)

View File

@ -3050,20 +3050,22 @@ kernel mode setting (KMS).")
(define-public xf86-video-vmware
(package
(name "xf86-video-vmware")
(version "12.0.2")
(version "13.0.2")
(source
(origin
(method url-fetch)
(uri (string-append
"mirror://xorg/X11R7.7/src/everything/xf86-video-vmware-"
"mirror://xorg/individual/driver/xf86-video-vmware-"
version
".tar.bz2"))
(sha256
(base32
"0isiwx516gww8hfk3vy7js83yziyjym9mq2zjadyq1a8v5gqf9y8"))))
"0m1wfsv34s4pyr5ry87yyjb2p6vmy6vyypdz5jx0sqnkx8n3vfn8"))
(patches (list (search-patch "xf86-video-vmware-glibc-2.20.patch")))))
(build-system gnu-build-system)
(inputs `(("libx11" ,libx11)
("libxext" ,libxext)
("mesa" ,mesa) ; for xatracker
("xorg-server" ,xorg-server)))
(native-inputs
`(("pkg-config" ,pkg-config)))