gnu: libgit2: Update to 0.28.1.
* gnu/packages/patches/libgit2-oom-test.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Remove it. * gnu/packages/version-control.scm (libgit2): Update to 0.28.1. [source](patches): Remove 'libgit2-oom-test.patch'.
This commit is contained in:
parent
7c1693df42
commit
c11f86ff16
|
@ -972,7 +972,6 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/libexif-CVE-2017-7544.patch \
|
||||
%D%/packages/patches/libgcrypt-make-yat2m-reproducible.patch \
|
||||
%D%/packages/patches/libgit2-mtime-0.patch \
|
||||
%D%/packages/patches/libgit2-oom-test.patch \
|
||||
%D%/packages/patches/libgdata-fix-tests.patch \
|
||||
%D%/packages/patches/libgdata-glib-duplicate-tests.patch \
|
||||
%D%/packages/patches/libgnome-encoding.patch \
|
||||
|
|
|
@ -1,62 +0,0 @@
|
|||
Fix a test failure on 32-bit platforms as reported
|
||||
at <https://github.com/libgit2/libgit2/issues/4868>.
|
||||
|
||||
From 415a8ae9c9b6ac18f0524b6af8e58408b426457d Mon Sep 17 00:00:00 2001
|
||||
From: Edward Thomson <ethomson@edwardthomson.com>
|
||||
Date: Thu, 13 Sep 2018 13:27:07 +0100
|
||||
Subject: [PATCH] tests: don't run buf::oom on 32-bit systems
|
||||
|
||||
On a 32-bit Linux systems, the value large enough to make malloc
|
||||
guarantee a failure is also large enough that valgrind considers it
|
||||
"fishy". Skip this test on those systems entirely.
|
||||
---
|
||||
tests/buf/oom.c | 14 +++++++++-----
|
||||
1 file changed, 9 insertions(+), 5 deletions(-)
|
||||
|
||||
diff --git a/tests/buf/oom.c b/tests/buf/oom.c
|
||||
index 2741a8ddf2..ec3bad9979 100644
|
||||
--- a/tests/buf/oom.c
|
||||
+++ b/tests/buf/oom.c
|
||||
@@ -11,12 +11,8 @@
|
||||
*/
|
||||
#if defined(GIT_ARCH_64) && defined(__linux__)
|
||||
# define TOOBIG 0x0fffffffffffffff
|
||||
-#elif defined(__linux__)
|
||||
-# define TOOBIG 0x0fffffff
|
||||
#elif defined(GIT_ARCH_64)
|
||||
# define TOOBIG 0xffffffffffffff00
|
||||
-#else
|
||||
-# define TOOBIG 0xffffff00
|
||||
#endif
|
||||
|
||||
/**
|
||||
@@ -25,13 +21,18 @@
|
||||
* will fail. And because the git_buf_grow() wrapper always
|
||||
* sets mark_oom, the code in git_buf_try_grow() will free
|
||||
* the internal buffer and set it to git_buf__oom.
|
||||
- *
|
||||
+ *
|
||||
* We initialized the internal buffer to (the static variable)
|
||||
* git_buf__initbuf. The purpose of this test is to make sure
|
||||
* that we don't try to free the static buffer.
|
||||
+ *
|
||||
+ * Skip this test entirely on 32-bit platforms; a buffer large enough
|
||||
+ * to guarantee malloc failures is so large that valgrind considers
|
||||
+ * it likely to be an error.
|
||||
*/
|
||||
void test_buf_oom__grow(void)
|
||||
{
|
||||
+#ifdef GIT_ARCH_64
|
||||
git_buf buf = GIT_BUF_INIT;
|
||||
|
||||
git_buf_clear(&buf);
|
||||
@@ -40,6 +41,9 @@ void test_buf_oom__grow(void)
|
||||
cl_assert(git_buf_oom(&buf));
|
||||
|
||||
git_buf_free(&buf);
|
||||
+#else
|
||||
+ cl_skip();
|
||||
+#endif
|
||||
}
|
||||
|
||||
void test_buf_oom__grow_by(void)
|
|
@ -526,7 +526,7 @@ everything from small to very large projects with speed and efficiency.")
|
|||
(define-public libgit2
|
||||
(package
|
||||
(name "libgit2")
|
||||
(version "0.27.7")
|
||||
(version "0.28.1")
|
||||
(source (origin
|
||||
(method url-fetch)
|
||||
(uri (string-append "https://github.com/libgit2/libgit2/"
|
||||
|
@ -534,9 +534,8 @@ everything from small to very large projects with speed and efficiency.")
|
|||
(file-name (string-append name "-" version ".tar.gz"))
|
||||
(sha256
|
||||
(base32
|
||||
"0c95pbv7hwclwmn51nqnh1lb0cajpcdb24pbdzcir6vmhfj3am0s"))
|
||||
(patches (search-patches "libgit2-mtime-0.patch"
|
||||
"libgit2-oom-test.patch"))
|
||||
"0swk2dyq5a4p1jn5wvbcsrxckhh808vifxz5y8w663avg541188c"))
|
||||
(patches (search-patches "libgit2-mtime-0.patch"))
|
||||
|
||||
;; Remove bundled software.
|
||||
(snippet '(begin
|
||||
|
|
Loading…
Reference in New Issue