gnu: coreutils: Update to 8.24.

* gnu/packages/patches/coreutils-dummy-man.patch: Remove file.
* gnu-system.am (dist_patch_DATA): Remove it.
* gnu/packages/base.scm (coreutils): Update to 8.24.  Remove patch.
master
Mark H Weaver 2015-07-10 14:22:13 -04:00
parent 6f317fa365
commit c2ba49ef8e
3 changed files with 2 additions and 25 deletions

View File

@ -398,7 +398,6 @@ dist_patch_DATA = \
gnu/packages/patches/clang-libc-search-path.patch \
gnu/packages/patches/clucene-pkgconfig.patch \
gnu/packages/patches/cmake-fix-tests.patch \
gnu/packages/patches/coreutils-dummy-man.patch \
gnu/packages/patches/cpio-CVE-2014-9112-pt1.patch \
gnu/packages/patches/cpio-CVE-2014-9112-pt2.patch \
gnu/packages/patches/cpio-CVE-2014-9112-pt3.patch \

View File

@ -238,15 +238,14 @@ used to apply commands with arbitrarily long arguments.")
(define-public coreutils
(package
(name "coreutils")
(version "8.23")
(version "8.24")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnu/coreutils/coreutils-"
version ".tar.xz"))
(sha256
(base32
"0bdq6yggyl7nkc2pbl6pxhhyx15nyqhz3ds6rfn448n6rxdwlhzc"))
(patches (list (search-patch "coreutils-dummy-man.patch")))))
"0w11jw3fb5sslf0f72kxy7llxgk1ia3a6bcw0c9kmvxrlj355mx2"))))
(build-system gnu-build-system)
(inputs `(("acl" ,acl) ; TODO: add SELinux
("gmp" ,gmp)))

View File

@ -1,21 +0,0 @@
Patch adapted from <http://git.yoctoproject.org/cgit.cgi/poky/plain/meta/recipes-core/coreutils/coreutils-8.22/fix-for-dummy-man-usage.patch>.
Fix for 'dummy-man' usage, when cross-compiling.
The options should be before the final argument, otherwise, the following error
would appear when compiling:
dummy-man: too many non-option arguments
--- coreutils-8.23/Makefile.in 2014-07-18 18:22:24.000000000 -0400
+++ coreutils-8.23/Makefile.in 2014-08-03 20:21:10.849158313 -0400
@@ -14076,8 +14076,8 @@
&& $(run_help2man) \
--source='$(PACKAGE_STRING)' \
--include=$(srcdir)/man/$$name.x \
- --output=$$t/$$name.1 $$t/$$argv \
--info-page='coreutils \(aq'$$name' invocation\(aq' \
+ --output=$$t/$$name.1 $$t/$$argv \
&& sed \
-e 's|$*\.td/||g' \
-e '/For complete documentation/d' \