gnu: libmwaw: Update to 0.3.12.
* gnu/packages/libreoffice.scm (libmwaw): Update to 0.3.12. [source](patches): Remove. [arguments]: Remove. * gnu/packages/patches/libmwaw-CVE-2017-9433.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Remove it.
This commit is contained in:
parent
cab4188f8b
commit
c334058f6e
|
@ -797,7 +797,6 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/libmad-armv7-thumb-pt2.patch \
|
||||
%D%/packages/patches/libmad-frame-length.patch \
|
||||
%D%/packages/patches/libmad-mips-newgcc.patch \
|
||||
%D%/packages/patches/libmwaw-CVE-2017-9433.patch \
|
||||
%D%/packages/patches/libsndfile-armhf-type-checks.patch \
|
||||
%D%/packages/patches/libsndfile-CVE-2017-8361-8363-8365.patch \
|
||||
%D%/packages/patches/libsndfile-CVE-2017-8362.patch \
|
||||
|
|
|
@ -599,15 +599,14 @@ text documents, vector drawings, presentations and spreadsheets.")
|
|||
(define-public libmwaw
|
||||
(package
|
||||
(name "libmwaw")
|
||||
(version "0.3.11")
|
||||
(version "0.3.12")
|
||||
(source
|
||||
(origin
|
||||
(method url-fetch)
|
||||
(uri (string-append "mirror://sourceforge/" name "/" name "/" name "-"
|
||||
version "/" name "-" version ".tar.xz"))
|
||||
(patches (search-patches "libmwaw-CVE-2017-9433.patch"))
|
||||
(sha256 (base32
|
||||
"16i9s9p4sjpdpbm3gq6jkc9r3nyfy47ggkdlgh7vr0mydccklj2b"))))
|
||||
"1ryi1v38lgy5kv84fzjqkawidrg30y4hlqrz1v262792wzkad4bn"))))
|
||||
(build-system gnu-build-system)
|
||||
(native-inputs
|
||||
`(("doxygen" ,doxygen)
|
||||
|
@ -617,9 +616,6 @@ text documents, vector drawings, presentations and spreadsheets.")
|
|||
(inputs
|
||||
`(("boost" ,boost)
|
||||
("zlib" ,zlib)))
|
||||
(arguments
|
||||
;; avoid triggering configure errors by simple inclusion of boost headers
|
||||
`(#:configure-flags '("--disable-werror")))
|
||||
(home-page "https://sourceforge.net/p/libmwaw/wiki/Home/")
|
||||
(synopsis "Import library for some old Macintosh text documents")
|
||||
(description "Libmwaw contains some import filters for old Macintosh
|
||||
|
|
|
@ -1,33 +0,0 @@
|
|||
Fix CVE-2017-9433:
|
||||
|
||||
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-9433
|
||||
|
||||
Patch copied from upstream source repository:
|
||||
|
||||
https://sourceforge.net/p/libmwaw/libmwaw/ci/68b3b74569881248bfb6cbb4266177cc253b292f
|
||||
|
||||
From 68b3b74569881248bfb6cbb4266177cc253b292f Mon Sep 17 00:00:00 2001
|
||||
From: David Tardon <dtardon@redhat.com>
|
||||
Date: Sat, 8 Apr 2017 14:03:29 +0200
|
||||
Subject: [PATCH] ofz#1037 resize vector correctly
|
||||
|
||||
---
|
||||
src/lib/MsWrd1Parser.cxx | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/src/lib/MsWrd1Parser.cxx b/src/lib/MsWrd1Parser.cxx
|
||||
index 63547e6..3626064 100644
|
||||
--- a/src/lib/MsWrd1Parser.cxx
|
||||
+++ b/src/lib/MsWrd1Parser.cxx
|
||||
@@ -902,7 +902,7 @@ bool MsWrd1Parser::readFootnoteCorrespondance(MWAWVec2i limits)
|
||||
int id = fIt++->second;
|
||||
fPos[1] = fIt==footnoteMap.end() ? m_state->m_eot : fIt->first;
|
||||
if (id >= int(m_state->m_footnotesList.size()))
|
||||
- m_state->m_footnotesList.resize(size_t(id),MWAWVec2l(0,0));
|
||||
+ m_state->m_footnotesList.resize(size_t(id)+1,MWAWVec2l(0,0));
|
||||
m_state->m_footnotesList[size_t(id)]=fPos;
|
||||
}
|
||||
ascii().addDelimiter(input->tell(),'|');
|
||||
--
|
||||
2.13.1
|
||||
|
Loading…
Reference in New Issue