gnu: xf86-video-sis: Fix FTBFS with xorg-server >= 1.20.
* gnu/packages/patches/xf86-video-sis-xorg-compat.patch: New file. * gnu/local.mk (dist_patch_DATA): Register it. * gnu/packages/xorg.scm (xf86-video-sis)[source](patches): Use it.
This commit is contained in:
parent
92af3ce417
commit
c67f603d55
|
@ -1215,6 +1215,7 @@ dist_patch_DATA = \
|
||||||
%D%/packages/patches/xf86-video-i128-remove-mibstore.patch \
|
%D%/packages/patches/xf86-video-i128-remove-mibstore.patch \
|
||||||
%D%/packages/patches/xf86-video-mach64-glibc-2.20.patch \
|
%D%/packages/patches/xf86-video-mach64-glibc-2.20.patch \
|
||||||
%D%/packages/patches/xf86-video-siliconmotion-fix-ftbfs.patch \
|
%D%/packages/patches/xf86-video-siliconmotion-fix-ftbfs.patch \
|
||||||
|
%D%/packages/patches/xf86-video-sis-xorg-compat.patch \
|
||||||
%D%/packages/patches/xf86-video-tga-remove-mibstore.patch \
|
%D%/packages/patches/xf86-video-tga-remove-mibstore.patch \
|
||||||
%D%/packages/patches/xfce4-panel-plugins.patch \
|
%D%/packages/patches/xfce4-panel-plugins.patch \
|
||||||
%D%/packages/patches/xfce4-session-fix-xflock4.patch \
|
%D%/packages/patches/xfce4-session-fix-xflock4.patch \
|
||||||
|
|
|
@ -0,0 +1,18 @@
|
||||||
|
Remove use of interface no longer provided by xorg-server.
|
||||||
|
|
||||||
|
Patch taken from upstream:
|
||||||
|
https://cgit.freedesktop.org/xorg/driver/xf86-video-sis/commit/?id=4b1356a2b7fd06e9a05d134caa4033681c939737
|
||||||
|
|
||||||
|
diff --git a/src/sis_driver.c b/src/sis_driver.c
|
||||||
|
index 8f06164..513f68b 100644
|
||||||
|
--- a/src/sis_driver.c
|
||||||
|
+++ b/src/sis_driver.c
|
||||||
|
@@ -2738,7 +2738,7 @@ SiSPrintModes(ScrnInfoPtr pScrn)
|
||||||
|
float hsync, refresh = 0.0;
|
||||||
|
char *desc, *desc2, *prefix, *uprefix, *output;
|
||||||
|
|
||||||
|
- xf86DrvMsg(pScrn->scrnIndex, pScrn->virtualFrom, "Virtual size is %dx%d "
|
||||||
|
+ xf86DrvMsg(pScrn->scrnIndex, X_INFO, "Virtual size is %dx%d "
|
||||||
|
"(pitch %d)\n", pScrn->virtualX, pScrn->virtualY,
|
||||||
|
pScrn->displayWidth);
|
||||||
|
|
|
@ -3266,6 +3266,7 @@ Xorg X server.")
|
||||||
"mirror://xorg/individual/driver/xf86-video-sis-"
|
"mirror://xorg/individual/driver/xf86-video-sis-"
|
||||||
version
|
version
|
||||||
".tar.bz2"))
|
".tar.bz2"))
|
||||||
|
(patches (search-patches "xf86-video-sis-xorg-compat.patch"))
|
||||||
(sha256
|
(sha256
|
||||||
(base32
|
(base32
|
||||||
"03f1abjjf68y8y1iz768rn95va9d33wmbwfbsqrgl6k0gi0bf9jj"))))
|
"03f1abjjf68y8y1iz768rn95va9d33wmbwfbsqrgl6k0gi0bf9jj"))))
|
||||||
|
|
Loading…
Reference in New Issue