gnu: bind: Update to 9.14.2.

* gnu/packages/dns.scm (isc-bind): Update to 9.14.2.
[source]: Remove patch.
[arguments]: Run only fuzz tests.
* gnu/packages/patches/bind-fix-unused-pk11-ecc-constants.patch: Delete
file.
* gnu/local.mk (dist_patch_DATA): Remove it.
master
Tobias Geerinckx-Rice 2019-05-16 18:19:38 +02:00
parent e865e0b959
commit c72c10053d
No known key found for this signature in database
GPG Key ID: 0DB0FF884F556D79
3 changed files with 7 additions and 49 deletions

View File

@ -682,7 +682,6 @@ dist_patch_DATA = \
%D%/packages/patches/beets-python-3.7-fix.patch \
%D%/packages/patches/beignet-correct-file-names.patch \
%D%/packages/patches/biber-fix-encoding-write.patch \
%D%/packages/patches/bind-fix-unused-pk11-ecc-constants.patch \
%D%/packages/patches/binutils-loongson-workaround.patch \
%D%/packages/patches/blender-2.79-newer-ffmpeg.patch \
%D%/packages/patches/blender-2.79-python-3.7-fix.patch \

View File

@ -108,7 +108,7 @@ and BOOTP/TFTP for network booting of diskless machines.")
(define-public isc-bind
(package
(name "bind")
(version "9.12.4-P1")
(version "9.14.2")
(source (origin
(method url-fetch)
(uri (string-append
@ -116,9 +116,7 @@ and BOOTP/TFTP for network booting of diskless machines.")
"/bind-" version ".tar.gz"))
(sha256
(base32
"1if7zc5gzrfd28csc63v9bjwrc0rgvm1x9yx058946hc5gp5lyp2"))
(patches
(search-patches "bind-fix-unused-pk11-ecc-constants.patch"))))
"033zqajnj5ys45g899132xkhh9f0hsh76ffv7302wl166xbjfh0f"))))
(build-system gnu-build-system)
(outputs `("out" "utils"))
(inputs
@ -163,7 +161,11 @@ and BOOTP/TFTP for network booting of diskless machines.")
;; (system "bin/tests/system/ifconfig.sh up")))
(replace 'check
(lambda _
(invoke "make" "force-test"))))))
;; XXX Even make force-test tries to create network interfaces
;; and fails. The only working target is the (trivial) fuzz test.
(with-directory-excursion "fuzz"
(invoke "make" "check"))
#t)))))
(synopsis "An implementation of the Domain Name System")
(description "BIND is an implementation of the @dfn{Domain Name System}
(DNS) protocols for the Internet. It is a reference implementation of those

View File

@ -1,43 +0,0 @@
From: Tobias Geerinckx-Rice <me@tobias.gr>
Date: Thu, 25 Apr 2019 04:36:52 +0200
Subject: [PATCH] gnu: bind: Fix unused PKCS#11 ECC constants.
Without this patch, the build fails:
pkcs11-keygen.c: In function main:
pkcs11-keygen.c:424:32: error: pk11_ecc_prime256v1 undeclared (first use in this function)
public_template[4].pValue = pk11_ecc_prime256v1;
^
pkcs11-keygen.c:424:32: note: each undeclared identifier is reported only once for each function it appears in
pkcs11-keygen.c:428:32: error: pk11_ecc_secp384r1 undeclared (first use in this function)
public_template[4].pValue = pk11_ecc_secp384r1;
^
make[2]: *** [Makefile:217: pkcs11-keygen.o] Error 1
Fix copied verbatim from upstream[0].
[0]: https://gitlab.isc.org/isc-projects/bind9/issues/935
---
--- orig-bind-9.11.6/bin/pkcs11/pkcs11-keygen.c 2019-02-27 15:28:15.000000000 -0800
+++ bind-9.11.6/bin/pkcs11/pkcs11-keygen.c 2019-03-11 09:20:50.955257469 -0700
@@ -403,6 +403,10 @@
public_template[RSA_PUBLIC_EXPONENT].ulValueLen = expsize;
break;
case key_ecc:
+#if !defined(HAVE_PKCS11_ECDSA)
+ fprintf(stderr, "prime256v1 and secp3841r1 is not supported\n");
+ usage();
+#else
op_type = OP_EC;
if (bits == 0)
bits = 256;
@@ -429,7 +433,7 @@
public_template[4].ulValueLen =
sizeof(pk11_ecc_secp384r1);
}
-
+#endif
break;
case key_ecx:
#if !defined(CKM_EDDSA_KEY_PAIR_GEN)