gnu: qt: Update to 5.11.3.

* gnu/packages/qt.scm (qt, qtbase, qtsvg, qtimageformats, qtx11extras,
qtxmlpatterns, qtdeclarative, qtconnectivity, qtwebsockets, qtsensors,
qtmultimedia, qtwayland, qtserialport, qtserialbus, qtwebchannel
qtwebglplugin, qtwebview, qtlocation, qttools, qtscript,
qtquickcontrols, qtquickcontrols2, qtgraphicaleffects, qtscxml,
qtgamepad, qtpurchasing, qtcanvas3d, qtcharts, qtdatavis3d,
qtnetworkauth, qtremoteobjects, qtspeech): Update to 5.11.3.
(qt)[source]: Remove patch.
* gnu/packages/patches/qt-5-renameat2.patch: Remove file.
* gnu/local.mk (dist_patch_DATA): Remove it.
master
Efraim Flashner 2019-01-02 09:39:17 +02:00
parent 3e2d4e69c3
commit c82cd3a7bd
No known key found for this signature in database
GPG Key ID: 41AAE7DCCA3D8351
3 changed files with 70 additions and 108 deletions

View File

@ -1177,7 +1177,6 @@ dist_patch_DATA = \
%D%/packages/patches/qt4-ldflags.patch \ %D%/packages/patches/qt4-ldflags.patch \
%D%/packages/patches/qtbase-use-TZDIR.patch \ %D%/packages/patches/qtbase-use-TZDIR.patch \
%D%/packages/patches/qtscript-disable-tests.patch \ %D%/packages/patches/qtscript-disable-tests.patch \
%D%/packages/patches/qt-5-renameat2.patch \
%D%/packages/patches/quagga-reproducible-build.patch \ %D%/packages/patches/quagga-reproducible-build.patch \
%D%/packages/patches/quickswitch-fix-dmenu-check.patch \ %D%/packages/patches/quickswitch-fix-dmenu-check.patch \
%D%/packages/patches/quilt-test-fix-regex.patch \ %D%/packages/patches/quilt-test-fix-regex.patch \

View File

@ -1,35 +0,0 @@
Avoid conflicting declaration of 'renameat2' on glibc 2.28
(see <https://github.com/meta-qt5/meta-qt5/issues/94>.)
Patch from <https://github.com/meta-qt5/meta-qt5/pull/95>
by Andreas Müller <schnitzeltony@gmail.com>.
---
src/corelib/io/qfilesystemengine_unix.cpp | 11 ++++++++++++
1 file changed, 11 insertions(+)
diff --git a/src/corelib/io/qfilesystemengine_unix.cpp b/src/corelib/io/qfilesystemengine_unix.cpp
index be6ce48d0cb..1bf1bebc7f1 100644
--- a/qtbase/src/corelib/io/qfilesystemengine_unix.cpp
+++ b/qtbase/src/corelib/io/qfilesystemengine_unix.cpp
@@ -98,6 +98,17 @@ extern "C" NSString *NSTemporaryDirectory();
# define FICLONE _IOW(0x94, 9, int)
#endif
+// renameat2/statx features for non bootstrapped build
+#ifndef QT_BOOTSTRAPPED
+#ifdef __GLIBC_PREREQ
+# define QT_FEATURE_renameat2 (__GLIBC_PREREQ(2, 28) ? 1 : -1)
+# define QT_FEATURE_statx (__GLIBC_PREREQ(2, 28) ? 1 : -1)
+#else
+# define QT_FEATURE_renameat2 -1
+# define QT_FEATURE_statx -1
+#endif
+#endif
+
# if defined(Q_OS_ANDROID)
// renameat2() and statx() are disabled on Android because quite a few systems
// come with sandboxes that kill applications that make system calls outside a
--
2.14.4

View File

@ -110,7 +110,7 @@ system, and the core design of Django is reused in Grantlee.")
(define-public qt (define-public qt
(package (package
(name "qt") (name "qt")
(version "5.11.2") (version "5.11.3")
(outputs '("out" "examples")) (outputs '("out" "examples"))
(source (origin (source (origin
(method url-fetch) (method url-fetch)
@ -123,8 +123,7 @@ system, and the core design of Django is reused in Grantlee.")
version ".tar.xz")) version ".tar.xz"))
(sha256 (sha256
(base32 (base32
"10faac59jvz6dxxljdkaknlxazpnaxgvqdcszabfbbkc1f24n466")) "0kgzy32s1fr22fxxfhcyncfryb3qxrznlr737r4y5khk4xj1g545"))
(patches (search-patches "qt-5-renameat2.patch"))
(modules '((guix build utils))) (modules '((guix build utils)))
(snippet (snippet
'(begin '(begin
@ -501,7 +500,7 @@ system, and the core design of Django is reused in Grantlee.")
(define-public qtbase (define-public qtbase
(package (package
(name "qtbase") (name "qtbase")
(version "5.11.2") (version "5.11.3")
(source (origin (source (origin
(method url-fetch) (method url-fetch)
(uri (string-append "https://download.qt.io/official_releases/qt/" (uri (string-append "https://download.qt.io/official_releases/qt/"
@ -510,20 +509,19 @@ system, and the core design of Django is reused in Grantlee.")
version ".tar.xz")) version ".tar.xz"))
(sha256 (sha256
(base32 (base32
"01q1rn5rp9biq3z38953z2hgm4nirvp2jfv8wg7isnld8v1yg0b3")) "071yc9iz14qs4s8yvrwllyfdzp5yjxsdpvbjxdrf0g5q69vqigy6"))
;; Use TZDIR to avoid depending on package "tzdata". ;; Use TZDIR to avoid depending on package "tzdata".
(patches (search-patches "qtbase-use-TZDIR.patch")) (patches (search-patches "qtbase-use-TZDIR.patch"))
(modules '((guix build utils))) (modules '((guix build utils)))
(snippet (snippet
;; corelib uses bundled harfbuzz, md4, md5, sha3 ;; corelib uses bundled harfbuzz, md4, md5, sha3
'(begin '(begin
(for-each (with-directory-excursion "src/3rdparty"
(lambda (dir) (for-each delete-file-recursively
(delete-file-recursively (string-append "src/3rdparty/" dir))) (list "double-conversion" "freetype" "harfbuzz-ng"
(list "double-conversion" "freetype" "harfbuzz-ng" "libpng" "libjpeg" "pcre2" "sqlite" "xcb"
"libpng" "libjpeg" "pcre2" "sqlite" "xcb" "xkbcommon" "zlib"))
"xkbcommon" "zlib")) #t)))))
#t))))
(build-system gnu-build-system) (build-system gnu-build-system)
(propagated-inputs (propagated-inputs
`(("mesa" ,mesa) `(("mesa" ,mesa)
@ -741,7 +739,7 @@ developers using C++ or QML, a CSS & JavaScript like language.")
(define-public qtsvg (define-public qtsvg
(package (inherit qtbase) (package (inherit qtbase)
(name "qtsvg") (name "qtsvg")
(version "5.11.2") (version "5.11.3")
(source (origin (source (origin
(method url-fetch) (method url-fetch)
(uri (string-append "https://download.qt.io/official_releases/qt/" (uri (string-append "https://download.qt.io/official_releases/qt/"
@ -750,7 +748,7 @@ developers using C++ or QML, a CSS & JavaScript like language.")
version ".tar.xz")) version ".tar.xz"))
(sha256 (sha256
(base32 (base32
"0rni3cdcli91v7k8ra9s9phpznvkza8qqvcrv9yyfrmlapwbn5mw")))) "14a4rprbj9f9rhixbk7143xdz34d7d39xh9v2sc1w43q9sf2rsi1"))))
(propagated-inputs `()) (propagated-inputs `())
(native-inputs `(("perl" ,perl))) (native-inputs `(("perl" ,perl)))
(inputs (inputs
@ -816,7 +814,7 @@ HostData=lib/qt5
(define-public qtimageformats (define-public qtimageformats
(package (inherit qtsvg) (package (inherit qtsvg)
(name "qtimageformats") (name "qtimageformats")
(version "5.11.2") (version "5.11.3")
(source (origin (source (origin
(method url-fetch) (method url-fetch)
(uri (string-append "https://download.qt.io/official_releases/qt/" (uri (string-append "https://download.qt.io/official_releases/qt/"
@ -825,7 +823,7 @@ HostData=lib/qt5
version ".tar.xz")) version ".tar.xz"))
(sha256 (sha256
(base32 (base32
"0s1s33k0wrnf9fi1wlm1kaq9hs1fx89597nhk53vzdfha42x3r97")) "0zq8igsjyyhxsjr43vpaasrqjw3x0g6rwqf8kaz7y9vs7ny63ch4"))
(modules '((guix build utils))) (modules '((guix build utils)))
(snippet (snippet
'(begin '(begin
@ -847,7 +845,7 @@ support for MNG, TGA, TIFF and WBMP image formats.")))
(define-public qtx11extras (define-public qtx11extras
(package (inherit qtsvg) (package (inherit qtsvg)
(name "qtx11extras") (name "qtx11extras")
(version "5.11.2") (version "5.11.3")
(source (origin (source (origin
(method url-fetch) (method url-fetch)
(uri (string-append "https://download.qt.io/official_releases/qt/" (uri (string-append "https://download.qt.io/official_releases/qt/"
@ -856,7 +854,7 @@ support for MNG, TGA, TIFF and WBMP image formats.")))
version ".tar.xz")) version ".tar.xz"))
(sha256 (sha256
(base32 (base32
"12cha7pd3cjx7zr0l7rbi1j2pfwmfpdwc7w3dsqbyi1d0mhwl1zl")))) "11fd2mc20qmnyv1vqhaqad2q6m0i4lmkr432rmqvpkgphpkfp7pr"))))
(arguments (arguments
(substitute-keyword-arguments (package-arguments qtsvg) (substitute-keyword-arguments (package-arguments qtsvg)
((#:tests? _ #f) #f))) ; TODO: Enable the tests ((#:tests? _ #f) #f))) ; TODO: Enable the tests
@ -871,7 +869,7 @@ from within Qt 5.")))
(define-public qtxmlpatterns (define-public qtxmlpatterns
(package (inherit qtsvg) (package (inherit qtsvg)
(name "qtxmlpatterns") (name "qtxmlpatterns")
(version "5.11.2") (version "5.11.3")
(source (origin (source (origin
(method url-fetch) (method url-fetch)
(uri (string-append "https://download.qt.io/official_releases/qt/" (uri (string-append "https://download.qt.io/official_releases/qt/"
@ -880,7 +878,7 @@ from within Qt 5.")))
version ".tar.xz")) version ".tar.xz"))
(sha256 (sha256
(base32 (base32
"0ik7m1a0shjsyzs8n9hfx8m9hy1p3wg505slcs0xznj0pa0gdmaz")))) "1vhfvgi39miqsx3iq7c9sii2sykq0yfng69b70i0smr20zihpl4b"))))
(arguments (arguments
(substitute-keyword-arguments (package-arguments qtsvg) (substitute-keyword-arguments (package-arguments qtsvg)
((#:phases phases) ((#:phases phases)
@ -900,7 +898,7 @@ xmlpatternsvalidator.")))
(define-public qtdeclarative (define-public qtdeclarative
(package (inherit qtsvg) (package (inherit qtsvg)
(name "qtdeclarative") (name "qtdeclarative")
(version "5.11.2") (version "5.11.3")
(source (origin (source (origin
(method url-fetch) (method url-fetch)
(uri (string-append "https://download.qt.io/official_releases/qt/" (uri (string-append "https://download.qt.io/official_releases/qt/"
@ -909,7 +907,7 @@ xmlpatternsvalidator.")))
version ".tar.xz")) version ".tar.xz"))
(sha256 (sha256
(base32 (base32
"1kgj6q53rk573yi47j32mn1mfk5ag98zvhv9qgrlb78y0gw8c392")))) "1rhsf9bma2zwwpixk2fsg31x7c1pmsk144npypgc9w86swhkc9lf"))))
(arguments (arguments
(substitute-keyword-arguments (package-arguments qtsvg) (substitute-keyword-arguments (package-arguments qtsvg)
((#:tests? _ #f) #f))) ; TODO: Enable the tests ((#:tests? _ #f) #f))) ; TODO: Enable the tests
@ -932,7 +930,7 @@ with JavaScript and C++.")))
(define-public qtconnectivity (define-public qtconnectivity
(package (inherit qtsvg) (package (inherit qtsvg)
(name "qtconnectivity") (name "qtconnectivity")
(version "5.11.2") (version "5.11.3")
(source (origin (source (origin
(method url-fetch) (method url-fetch)
(uri (string-append "https://download.qt.io/official_releases/qt/" (uri (string-append "https://download.qt.io/official_releases/qt/"
@ -941,7 +939,7 @@ with JavaScript and C++.")))
version ".tar.xz")) version ".tar.xz"))
(sha256 (sha256
(base32 (base32
"1ia21llw610wd7licdm81p8zpkrkvkc5yc7y4wplgg6k2jyip42q")))) "0amks3qad31i7cha85kvcaxvlmmgkc3gm4jdkw2p02ixxfygr30l"))))
(native-inputs (native-inputs
`(("perl" ,perl) `(("perl" ,perl)
("pkg-config" ,pkg-config) ("pkg-config" ,pkg-config)
@ -956,7 +954,7 @@ with Bluetooth and NFC.")))
(define-public qtwebsockets (define-public qtwebsockets
(package (inherit qtsvg) (package (inherit qtsvg)
(name "qtwebsockets") (name "qtwebsockets")
(version "5.11.2") (version "5.11.3")
(source (origin (source (origin
(method url-fetch) (method url-fetch)
(uri (string-append "https://download.qt.io/official_releases/qt/" (uri (string-append "https://download.qt.io/official_releases/qt/"
@ -965,7 +963,7 @@ with Bluetooth and NFC.")))
version ".tar.xz")) version ".tar.xz"))
(sha256 (sha256
(base32 (base32
"13cbr2pffv1hwvm8d8kzask0pyc2j3brgq23vi5i1i70kihrfqdf")))) "1ffmapfy68xwwbxbg19ng6b5h8v42cf78s21j7rgq49gm70r0402"))))
(arguments (arguments
(substitute-keyword-arguments (package-arguments qtsvg) (substitute-keyword-arguments (package-arguments qtsvg)
((#:tests? _ #f) #f))) ; TODO: Enable the tests ((#:tests? _ #f) #f))) ; TODO: Enable the tests
@ -983,7 +981,7 @@ consume data received from the server, or both.")))
(define-public qtsensors (define-public qtsensors
(package (inherit qtsvg) (package (inherit qtsvg)
(name "qtsensors") (name "qtsensors")
(version "5.11.2") (version "5.11.3")
(source (origin (source (origin
(method url-fetch) (method url-fetch)
(uri (string-append "https://download.qt.io/official_releases/qt/" (uri (string-append "https://download.qt.io/official_releases/qt/"
@ -992,7 +990,7 @@ consume data received from the server, or both.")))
version ".tar.xz")) version ".tar.xz"))
(sha256 (sha256
(base32 (base32
"1iv3gmk121myqdr64d9lf2m816ypxrb526gn0ssxx8gp4j4c69qf")))) "0n88c8xi9pbyh7q1pcqv4yjv6nx62abflj8qgfr4qzb0sp8m6mx7"))))
(arguments (arguments
(substitute-keyword-arguments (package-arguments qtsvg) (substitute-keyword-arguments (package-arguments qtsvg)
((#:parallel-tests? _ #f) #f) ; can lead to race condition ((#:parallel-tests? _ #f) #f) ; can lead to race condition
@ -1016,7 +1014,7 @@ recognition API for devices.")))
(define-public qtmultimedia (define-public qtmultimedia
(package (inherit qtsvg) (package (inherit qtsvg)
(name "qtmultimedia") (name "qtmultimedia")
(version "5.11.2") (version "5.11.3")
(source (origin (source (origin
(method url-fetch) (method url-fetch)
(uri (string-append "https://download.qt.io/official_releases/qt/" (uri (string-append "https://download.qt.io/official_releases/qt/"
@ -1025,7 +1023,7 @@ recognition API for devices.")))
version ".tar.xz")) version ".tar.xz"))
(sha256 (sha256
(base32 (base32
"0vbjrxsdahgbgpc2zcvgg3mpijzd5kknz5clfcw2cq3310yqyq15")) "0h9wx86zj20n4xc3qnml0i360x2dc1yd2z2af1flj8fwyzppi03j"))
(modules '((guix build utils))) (modules '((guix build utils)))
(snippet (snippet
'(begin '(begin
@ -1067,7 +1065,7 @@ set of plugins for interacting with pulseaudio and GStreamer.")))
(define-public qtwayland (define-public qtwayland
(package (inherit qtsvg) (package (inherit qtsvg)
(name "qtwayland") (name "qtwayland")
(version "5.11.2") (version "5.11.3")
(source (origin (source (origin
(method url-fetch) (method url-fetch)
(uri (string-append "https://download.qt.io/official_releases/qt/" (uri (string-append "https://download.qt.io/official_releases/qt/"
@ -1076,7 +1074,7 @@ set of plugins for interacting with pulseaudio and GStreamer.")))
version ".tar.xz")) version ".tar.xz"))
(sha256 (sha256
(base32 (base32
"0wdpxjr3zfmgcfg14zlwd8mjbc191pvlchj1xxd0lj30ldfy2daf")) "1chz4wchgkzd45h143i5hkqg0whcgdbj37gkg7j4kj31whllzjb2"))
(modules '((guix build utils))) (modules '((guix build utils)))
(snippet (snippet
;; The examples try to build and cause the build to fail ;; The examples try to build and cause the build to fail
@ -1119,7 +1117,7 @@ compositor libraries.")))
(define-public qtserialport (define-public qtserialport
(package (inherit qtsvg) (package (inherit qtsvg)
(name "qtserialport") (name "qtserialport")
(version "5.11.2") (version "5.11.3")
(source (origin (source (origin
(method url-fetch) (method url-fetch)
(uri (string-append "https://download.qt.io/official_releases/qt/" (uri (string-append "https://download.qt.io/official_releases/qt/"
@ -1128,7 +1126,7 @@ compositor libraries.")))
version ".tar.xz")) version ".tar.xz"))
(sha256 (sha256
(base32 (base32
"0vkgvicm67vds2iqmhnjsqwnx1f8zhbzc31w6q198i0x8b76j6xh")))) "1nkbfsxzgicwns3k11hhzjxy2hgrigj8xcw2by0jc1j71mnmxi4n"))))
(native-inputs `(("perl" ,perl))) (native-inputs `(("perl" ,perl)))
(inputs (inputs
`(("qtbase" ,qtbase) `(("qtbase" ,qtbase)
@ -1153,7 +1151,7 @@ interacting with serial ports from within Qt.")))
(define-public qtserialbus (define-public qtserialbus
(package (inherit qtsvg) (package (inherit qtsvg)
(name "qtserialbus") (name "qtserialbus")
(version "5.11.2") (version "5.11.3")
(source (origin (source (origin
(method url-fetch) (method url-fetch)
(uri (string-append "https://download.qt.io/official_releases/qt/" (uri (string-append "https://download.qt.io/official_releases/qt/"
@ -1162,7 +1160,7 @@ interacting with serial ports from within Qt.")))
version ".tar.xz")) version ".tar.xz"))
(sha256 (sha256
(base32 (base32
"07k4g5qfh657das2f5i6ph0hl4bva13yzlmxnay7qpzqcb0w4x0p")))) "0vf12jk1ma0v0dlpliw1x9i04iaik1kjkiaby7gaxm2abprxwr2n"))))
(inputs (inputs
`(("qtbase" ,qtbase) `(("qtbase" ,qtbase)
("qtserialport" ,qtserialport))) ("qtserialport" ,qtserialport)))
@ -1174,7 +1172,7 @@ and others.")))
(define-public qtwebchannel (define-public qtwebchannel
(package (inherit qtsvg) (package (inherit qtsvg)
(name "qtwebchannel") (name "qtwebchannel")
(version "5.11.2") (version "5.11.3")
(source (origin (source (origin
(method url-fetch) (method url-fetch)
(uri (string-append "https://download.qt.io/official_releases/qt/" (uri (string-append "https://download.qt.io/official_releases/qt/"
@ -1183,7 +1181,7 @@ and others.")))
version ".tar.xz")) version ".tar.xz"))
(sha256 (sha256
(base32 (base32
"1z02dhrd1h2rpdhww9py9dnhss80xwf45n568y7gr3gay7ldlpwl")))) "1wrdawlqvcw84h8q52mvbjhp1vkd6fhz6c8ijlg9rw0s3fj4y99w"))))
(native-inputs (native-inputs
`(("perl" ,perl) `(("perl" ,perl)
("qtdeclarative" ,qtdeclarative) ("qtdeclarative" ,qtdeclarative)
@ -1198,7 +1196,7 @@ popular web engines, Qt WebKit 2 and Qt WebEngine.")))
(define-public qtwebglplugin (define-public qtwebglplugin
(package (inherit qtsvg) (package (inherit qtsvg)
(name "qtwebglplugin") (name "qtwebglplugin")
(version "5.11.2") (version "5.11.3")
(source (origin (source (origin
(method url-fetch) (method url-fetch)
(uri (string-append "https://download.qt.io/official_releases/qt/" (uri (string-append "https://download.qt.io/official_releases/qt/"
@ -1207,7 +1205,7 @@ popular web engines, Qt WebKit 2 and Qt WebEngine.")))
version ".tar.xz")) version ".tar.xz"))
(sha256 (sha256
(base32 (base32
"0vazz9yr1qgpcq7p77vg9mrjxy6hjabvwj9irw5l5w7fmsk2ns0n")))) "0wqz8lycmi7pffzy0pz5960w109lbk4mkbw0l1lh64avl6clq7b9"))))
(arguments (arguments
(substitute-keyword-arguments (package-arguments qtsvg) (substitute-keyword-arguments (package-arguments qtsvg)
((#:phases phases) ((#:phases phases)
@ -1233,7 +1231,7 @@ OpenGL ES 2.0 and can be used in HTML5 canvas elements")))
(define-public qtwebview (define-public qtwebview
(package (inherit qtsvg) (package (inherit qtsvg)
(name "qtwebview") (name "qtwebview")
(version "5.11.2") (version "5.11.3")
(source (origin (source (origin
(method url-fetch) (method url-fetch)
(uri (string-append "https://download.qt.io/official_releases/qt/" (uri (string-append "https://download.qt.io/official_releases/qt/"
@ -1242,7 +1240,7 @@ OpenGL ES 2.0 and can be used in HTML5 canvas elements")))
version ".tar.xz")) version ".tar.xz"))
(sha256 (sha256
(base32 (base32
"1r30n9vjcgh2cd2iycfwwwpmbz7grrd3iqrc0afwnri3vylnfqil")))) "1njmn1n03dp4md8cz58cq2z6bsxd8nwlw0238zmavh7px3jzc9kh"))))
(native-inputs (native-inputs
`(("perl" ,perl))) `(("perl" ,perl)))
(inputs (inputs
@ -1256,7 +1254,7 @@ native APIs where it makes sense.")))
(define-public qtlocation (define-public qtlocation
(package (inherit qtsvg) (package (inherit qtsvg)
(name "qtlocation") (name "qtlocation")
(version "5.11.2") (version "5.11.3")
(source (origin (source (origin
(method url-fetch) (method url-fetch)
(uri (string-append "https://download.qt.io/official_releases/qt/" (uri (string-append "https://download.qt.io/official_releases/qt/"
@ -1265,7 +1263,7 @@ native APIs where it makes sense.")))
version ".tar.xz")) version ".tar.xz"))
(sha256 (sha256
(base32 (base32
"0kh2c2ahg8xkpvqsva13i35ndsc0x0ypnmd6vix5pm5jvwg9366n")))) "1sq0f41jwmsimv9a1wl2nk5nifjppm5j92rr4n4s7qwnnjjrir2q"))))
(arguments (arguments
(substitute-keyword-arguments (package-arguments qtsvg) (substitute-keyword-arguments (package-arguments qtsvg)
((#:tests? _ #f) #f))) ; TODO: Enable the tests ((#:tests? _ #f) #f))) ; TODO: Enable the tests
@ -1286,7 +1284,7 @@ positioning and geolocation plugins.")))
(define-public qttools (define-public qttools
(package (inherit qtsvg) (package (inherit qtsvg)
(name "qttools") (name "qttools")
(version "5.11.2") (version "5.11.3")
(source (origin (source (origin
(method url-fetch) (method url-fetch)
(uri (string-append "https://download.qt.io/official_releases/qt/" (uri (string-append "https://download.qt.io/official_releases/qt/"
@ -1295,7 +1293,7 @@ positioning and geolocation plugins.")))
version ".tar.xz")) version ".tar.xz"))
(sha256 (sha256
(base32 (base32
"1f1iqvksrlgkxdbagb6vvjib3argbv9l7iis6ymb8n0rfwn37s7h")))) "13lzdxxi02yhvx4mflhisl6aqv2fiss5m804cqccd1wvp8dyh1f2"))))
(arguments (arguments
(substitute-keyword-arguments (package-arguments qtsvg) (substitute-keyword-arguments (package-arguments qtsvg)
((#:tests? _ #f) #f))) ; TODO: Enable the tests ((#:tests? _ #f) #f))) ; TODO: Enable the tests
@ -1314,7 +1312,7 @@ that helps in Qt development.")))
(define-public qtscript (define-public qtscript
(package (inherit qtsvg) (package (inherit qtsvg)
(name "qtscript") (name "qtscript")
(version "5.11.2") (version "5.11.3")
(source (origin (source (origin
(method url-fetch) (method url-fetch)
(uri (string-append "https://download.qt.io/official_releases/qt/" (uri (string-append "https://download.qt.io/official_releases/qt/"
@ -1323,7 +1321,7 @@ that helps in Qt development.")))
version ".tar.xz")) version ".tar.xz"))
(sha256 (sha256
(base32 (base32
"0xprhd1brn30dqf5vy4inqgzpq48i8nlc428x9rr8fk5hdm4dhmj")) "027cvggbcvwyz76cn1bl1zvqg0nq7iica1b7yx7xyy0hb36g715v"))
(patches (search-patches "qtscript-disable-tests.patch")))) (patches (search-patches "qtscript-disable-tests.patch"))))
(native-inputs (native-inputs
`(("perl" ,perl) `(("perl" ,perl)
@ -1338,7 +1336,7 @@ ECMAScript and Qt.")))
(define-public qtquickcontrols (define-public qtquickcontrols
(package (inherit qtsvg) (package (inherit qtsvg)
(name "qtquickcontrols") (name "qtquickcontrols")
(version "5.11.2") (version "5.11.3")
(source (origin (source (origin
(method url-fetch) (method url-fetch)
(uri (string-append "https://download.qt.io/official_releases/qt/" (uri (string-append "https://download.qt.io/official_releases/qt/"
@ -1347,7 +1345,7 @@ ECMAScript and Qt.")))
version ".tar.xz")) version ".tar.xz"))
(sha256 (sha256
(base32 (base32
"1q11nr85436xzrf4mbrbav306hrz0s2qaclqhhb0g88vzcq2wxww")))) "0dvmy31qbl76yy0j5y8m7mvnmqyg2c01fmlkn0snvc5h5ah5skjf"))))
(arguments (arguments
(substitute-keyword-arguments (package-arguments qtsvg) (substitute-keyword-arguments (package-arguments qtsvg)
((#:tests? _ #f) #f))) ; TODO: Enable the tests ((#:tests? _ #f) #f))) ; TODO: Enable the tests
@ -1362,7 +1360,7 @@ can be used to build complete interfaces in Qt Quick.")))
(define-public qtquickcontrols2 (define-public qtquickcontrols2
(package (inherit qtsvg) (package (inherit qtsvg)
(name "qtquickcontrols2") (name "qtquickcontrols2")
(version "5.11.2") (version "5.11.3")
(source (origin (source (origin
(method url-fetch) (method url-fetch)
(uri (string-append "https://download.qt.io/official_releases/qt/" (uri (string-append "https://download.qt.io/official_releases/qt/"
@ -1371,7 +1369,7 @@ can be used to build complete interfaces in Qt Quick.")))
version ".tar.xz")) version ".tar.xz"))
(sha256 (sha256
(base32 (base32
"116b5nhmsx898626s37r446yci7kxd3k7xap1dh9spqklkwlj1da")))) "11nhpb0xckv5jjkqj5szr94c2rvyjwr89ch58hh64nsqaav30mpl"))))
(arguments (arguments
(substitute-keyword-arguments (package-arguments qtsvg) (substitute-keyword-arguments (package-arguments qtsvg)
((#:tests? _ #f) #f))) ; TODO: Enable the tests ((#:tests? _ #f) #f))) ; TODO: Enable the tests
@ -1387,7 +1385,7 @@ not available.")))
(define-public qtgraphicaleffects (define-public qtgraphicaleffects
(package (inherit qtsvg) (package (inherit qtsvg)
(name "qtgraphicaleffects") (name "qtgraphicaleffects")
(version "5.11.2") (version "5.11.3")
(source (origin (source (origin
(method url-fetch) (method url-fetch)
(uri (string-append "https://download.qt.io/official_releases/qt/" (uri (string-append "https://download.qt.io/official_releases/qt/"
@ -1396,7 +1394,7 @@ not available.")))
version ".tar.xz")) version ".tar.xz"))
(sha256 (sha256
(base32 (base32
"1zd9wjh2hhd6lby0z3ak0ff6zkbv73hh0drrg9qp2yrgjfismp59")))) "1qjpdzkamf27cg5n1wsf0zk939lcgppgydfjzap9s4fxzj1nkn0l"))))
(arguments (arguments
(substitute-keyword-arguments (package-arguments qtsvg) (substitute-keyword-arguments (package-arguments qtsvg)
((#:tests? _ #f) #f))) ; TODO: Enable the tests ((#:tests? _ #f) #f))) ; TODO: Enable the tests
@ -1442,7 +1440,7 @@ backend for QtQuick scene graph.")
(define-public qtgamepad (define-public qtgamepad
(package (inherit qtsvg) (package (inherit qtsvg)
(name "qtgamepad") (name "qtgamepad")
(version "5.11.2") (version "5.11.3")
(source (origin (source (origin
(method url-fetch) (method url-fetch)
(uri (string-append "https://download.qt.io/official_releases/qt/" (uri (string-append "https://download.qt.io/official_releases/qt/"
@ -1451,7 +1449,7 @@ backend for QtQuick scene graph.")
version ".tar.xz")) version ".tar.xz"))
(sha256 (sha256
(base32 (base32
"076874iyadj7pkprlk24h257nb8i4sni9c6kbixm5zrr2y73fbxf")))) "1k222cx18zq48sfna91hmy427qzk2n2xz3dlyz59iyz72k6915g9"))))
(native-inputs (native-inputs
`(("perl" ,perl) `(("perl" ,perl)
("pkg-config" ,pkg-config))) ("pkg-config" ,pkg-config)))
@ -1472,7 +1470,7 @@ and mobile applications targeting TV-like form factors.")))
(define-public qtscxml (define-public qtscxml
(package (inherit qtsvg) (package (inherit qtsvg)
(name "qtscxml") (name "qtscxml")
(version "5.11.2") (version "5.11.3")
(source (origin (source (origin
(method url-fetch) (method url-fetch)
(uri (string-append "https://download.qt.io/official_releases/qt/" (uri (string-append "https://download.qt.io/official_releases/qt/"
@ -1481,7 +1479,7 @@ and mobile applications targeting TV-like form factors.")))
version ".tar.xz")) version ".tar.xz"))
(sha256 (sha256
(base32 (base32
"197p5x1dadgjb39pd2vw60r63lvz68i0pm5i8xbyzgzm94hwn9fn")) "1mv8mz36v34dckrzy5r41mq3sqznbalrhndk3avz2154xmkjf5qk"))
(modules '((guix build utils))) (modules '((guix build utils)))
(snippet (snippet
'(begin '(begin
@ -1503,7 +1501,7 @@ also contains functionality to support data models and executable content.")))
(define-public qtpurchasing (define-public qtpurchasing
(package (inherit qtsvg) (package (inherit qtsvg)
(name "qtpurchasing") (name "qtpurchasing")
(version "5.11.2") (version "5.11.3")
(source (origin (source (origin
(method url-fetch) (method url-fetch)
(uri (string-append "https://download.qt.io/official_releases/qt/" (uri (string-append "https://download.qt.io/official_releases/qt/"
@ -1512,7 +1510,7 @@ also contains functionality to support data models and executable content.")))
version ".tar.xz")) version ".tar.xz"))
(sha256 (sha256
(base32 (base32
"1xld1yx085mhnqdipy29g2yy5af67hfm0wy4mvj7pl6y5qj8jw9d")))) "1fd0gxdj5mrh81iwimq1243i3n47sqv9ik8nslahfh0q3dsx7k8n"))))
(inputs (inputs
`(("qtbase" ,qtbase) `(("qtbase" ,qtbase)
("qtdeclarative" ,qtdeclarative))) ("qtdeclarative" ,qtdeclarative)))
@ -1523,7 +1521,7 @@ purchasing goods and services.")))
(define-public qtcanvas3d (define-public qtcanvas3d
(package (inherit qtsvg) (package (inherit qtsvg)
(name "qtcanvas3d") (name "qtcanvas3d")
(version "5.11.2") (version "5.11.3")
(source (origin (source (origin
(method url-fetch) (method url-fetch)
(uri (string-append "https://download.qt.io/official_releases/qt/" (uri (string-append "https://download.qt.io/official_releases/qt/"
@ -1532,7 +1530,7 @@ purchasing goods and services.")))
version ".tar.xz")) version ".tar.xz"))
(sha256 (sha256
(base32 (base32
"0h7arss7wr0jwl87kiwgbf0nlcgpbriyf7cnv9j4h7g8d09a777x")) "0f110z7cmkzns9k00aa5zhzq2fpybfxkd7gdlwzcbhc8hn20986m"))
(modules '((guix build utils))) (modules '((guix build utils)))
(snippet (snippet
'(begin '(begin
@ -1562,7 +1560,7 @@ drawing calls from Qt Quick JavaScript.")))
(define-public qtcharts (define-public qtcharts
(package (inherit qtsvg) (package (inherit qtsvg)
(name "qtcharts") (name "qtcharts")
(version "5.11.2") (version "5.11.3")
(source (origin (source (origin
(method url-fetch) (method url-fetch)
(uri (string-append "https://download.qt.io/official_releases/qt/" (uri (string-append "https://download.qt.io/official_releases/qt/"
@ -1571,7 +1569,7 @@ drawing calls from Qt Quick JavaScript.")))
version ".tar.xz")) version ".tar.xz"))
(sha256 (sha256
(base32 (base32
"0551qfqnsfiy8kb1ng2v0yn7s6ggy7ghcmis983sbzxzjv2i58zn")))) "1p4m1nkbbxlkwmbmasx5r83skzssmlcgfzyvj30x2dyrqkmz7627"))))
(arguments (arguments
(substitute-keyword-arguments (package-arguments qtsvg) (substitute-keyword-arguments (package-arguments qtsvg)
((#:tests? _ #f) #f))) ; TODO: Enable the tests ((#:tests? _ #f) #f))) ; TODO: Enable the tests
@ -1589,7 +1587,7 @@ selecting one of the charts themes.")
(define-public qtdatavis3d (define-public qtdatavis3d
(package (inherit qtsvg) (package (inherit qtsvg)
(name "qtdatavis3d") (name "qtdatavis3d")
(version "5.11.2") (version "5.11.3")
(source (origin (source (origin
(method url-fetch) (method url-fetch)
(uri (string-append "https://download.qt.io/official_releases/qt/" (uri (string-append "https://download.qt.io/official_releases/qt/"
@ -1598,7 +1596,7 @@ selecting one of the charts themes.")
version ".tar.xz")) version ".tar.xz"))
(sha256 (sha256
(base32 (base32
"05pzvrhvxhxjlav4axrhwlnxjzlr7mi8k3f06g59ryrwmb99kd37")))) "1kqwr3avcvcyy4i28vjgxk1bsjj9011zr668hsk1zrjxnnwjwdl3"))))
(arguments (arguments
(substitute-keyword-arguments (package-arguments qtsvg) (substitute-keyword-arguments (package-arguments qtsvg)
((#:tests? _ #f) #f))) ; TODO: Enable the tests ((#:tests? _ #f) #f))) ; TODO: Enable the tests
@ -1616,7 +1614,7 @@ customized by using themes or by adding custom items and labels to them.")
(define-public qtnetworkauth (define-public qtnetworkauth
(package (inherit qtsvg) (package (inherit qtsvg)
(name "qtnetworkauth") (name "qtnetworkauth")
(version "5.11.2") (version "5.11.3")
(source (origin (source (origin
(method url-fetch) (method url-fetch)
(uri (string-append "https://download.qt.io/official_releases/qt/" (uri (string-append "https://download.qt.io/official_releases/qt/"
@ -1625,7 +1623,7 @@ customized by using themes or by adding custom items and labels to them.")
version ".tar.xz")) version ".tar.xz"))
(sha256 (sha256
(base32 (base32
"1zmpvkhf2kmnr8vsa6jq675d5cpnmsg3f8yds6g91yq1g3prqdvr")))) "0dd35698wzg89975vi2ijl2lym495fjizsl03mjixsjnvb1x0q50"))))
(arguments (arguments
(substitute-keyword-arguments (package-arguments qtsvg) (substitute-keyword-arguments (package-arguments qtsvg)
((#:phases phases) ((#:phases phases)
@ -1645,7 +1643,7 @@ implementation of OAuth and OAuth2 authenticathon methods for Qt.")))
(define-public qtremoteobjects (define-public qtremoteobjects
(package (inherit qtsvg) (package (inherit qtsvg)
(name "qtremoteobjects") (name "qtremoteobjects")
(version "5.11.2") (version "5.11.3")
(source (origin (source (origin
(method url-fetch) (method url-fetch)
(uri (string-append "https://download.qt.io/official_releases/qt/" (uri (string-append "https://download.qt.io/official_releases/qt/"
@ -1654,7 +1652,7 @@ implementation of OAuth and OAuth2 authenticathon methods for Qt.")))
version ".tar.xz")) version ".tar.xz"))
(sha256 (sha256
(base32 (base32
"06awsaf15rch1y9p2q9kdlmlaa8g28whbzf04b10zfflyijnvg7j")))) "1d3jzsxfyjhgb6wj9iv1388bv7j6pi08346nmkm1c1a4iykhc0zp"))))
(arguments (arguments
(substitute-keyword-arguments (package-arguments qtsvg) (substitute-keyword-arguments (package-arguments qtsvg)
((#:phases phases) ((#:phases phases)
@ -1678,7 +1676,7 @@ processes or computers.")))
(define-public qtspeech (define-public qtspeech
(package (inherit qtsvg) (package (inherit qtsvg)
(name "qtspeech") (name "qtspeech")
(version "5.11.2") (version "5.11.3")
(source (origin (source (origin
(method url-fetch) (method url-fetch)
(uri (string-append "https://download.qt.io/official_releases/qt/" (uri (string-append "https://download.qt.io/official_releases/qt/"
@ -1687,7 +1685,7 @@ processes or computers.")))
version ".tar.xz")) version ".tar.xz"))
(sha256 (sha256
(base32 (base32
"110xr2y174sayi9f6swzp1wx7mx4sw9rifcdx2bkbsnbfab6zg8a")))) "158p7zqd0vg55gf88jzc3d4f7649ihh80k0m1q46m2yp6fpdjbxr"))))
(arguments (arguments
(substitute-keyword-arguments (package-arguments qtsvg) (substitute-keyword-arguments (package-arguments qtsvg)
((#:tests? _ #f) #f))) ; TODO: Enable the tests ((#:tests? _ #f) #f))) ; TODO: Enable the tests