gnu: mesa: Update to 17.2.1.

* gnu/packages/gl.scm (mesa): Update to 17.2.1.
[inputs]: Add WAYLAND-PROTOCOLS.
* gnu/packages/patches/mesa-skip-disk-cache-test.patch: Adjust context.
master
Marius Bakke 2017-09-20 19:54:56 +02:00
parent 7c9b87600b
commit cb6392698a
No known key found for this signature in database
GPG Key ID: A2A06DF2A33A54FA
2 changed files with 7 additions and 6 deletions

View File

@ -217,7 +217,7 @@ also known as DXTn or DXTC) for Mesa.")
(define-public mesa
(package
(name "mesa")
(version "17.1.8")
(version "17.2.1")
(source
(origin
(method url-fetch)
@ -229,7 +229,7 @@ also known as DXTn or DXTC) for Mesa.")
version "/mesa-" version ".tar.xz")))
(sha256
(base32
"1nv9aaz7ay2bs4fc8j3rf6ky3qla8s346a8g2lvdbp96msp2xvbm"))
"07msr6xismw2jq87irwhz7vygvzj6hi38d71paij9zvwh8bmsf3p"))
(patches
(search-patches "mesa-wayland-egl-symbols-check-mips.patch"
"mesa-skip-disk-cache-test.patch"))))
@ -261,7 +261,8 @@ also known as DXTn or DXTC) for Mesa.")
("makedepend" ,makedepend)
("presentproto" ,presentproto)
("s2tc" ,s2tc)
("wayland" ,wayland)))
("wayland" ,wayland)
("wayland-protocols" ,wayland-protocols)))
(native-inputs
`(("pkg-config" ,pkg-config)
("python" ,python-2)

View File

@ -8,12 +8,12 @@ for now.
@@ -170,11 +170,6 @@
unsetenv("MESA_GLSL_CACHE_DIR");
unsetenv("XDG_CACHE_HOME");
- cache = disk_cache_create("test", "make_check");
- cache = disk_cache_create("test", "make_check", 0);
- expect_non_null(cache, "disk_cache_create with no environment variables");
-
- disk_cache_destroy(cache);
-
/* Test with XDG_CACHE_HOME set */
setenv("XDG_CACHE_HOME", CACHE_TEST_TMP "/xdg-cache-home", 1);
cache = disk_cache_create("test", "make_check");
cache = disk_cache_create("test", "make_check", 0);