gnu: meson: Update to 0.47.1.
* gnu/packages/build-tools.scm (meson): Update to 0.47.1. * gnu/packages/patches/meson-for-build-rpath.patch: Adjust to file rename and indendation change.
This commit is contained in:
parent
94eb59fb4a
commit
cb8f7d6d2f
|
@ -100,7 +100,7 @@ generate such a compilation database.")
|
||||||
(define-public meson
|
(define-public meson
|
||||||
(package
|
(package
|
||||||
(name "meson")
|
(name "meson")
|
||||||
(version "0.46.1")
|
(version "0.47.1")
|
||||||
(source (origin
|
(source (origin
|
||||||
(method url-fetch)
|
(method url-fetch)
|
||||||
(uri (string-append "https://github.com/mesonbuild/meson/"
|
(uri (string-append "https://github.com/mesonbuild/meson/"
|
||||||
|
@ -108,7 +108,7 @@ generate such a compilation database.")
|
||||||
version ".tar.gz"))
|
version ".tar.gz"))
|
||||||
(sha256
|
(sha256
|
||||||
(base32
|
(base32
|
||||||
"0y7f5hhy16q99l7x06x8sid9p9dbg6d7i60zs7c07cz5ww1plj8r"))))
|
"19mdap2ncvczajx220bd73xmwhd8x906382y18cn9c5syxwxwwyn"))))
|
||||||
(build-system python-build-system)
|
(build-system python-build-system)
|
||||||
(arguments
|
(arguments
|
||||||
`(;; FIXME: Tests require many additional inputs, a fix for the RUNPATH
|
`(;; FIXME: Tests require many additional inputs, a fix for the RUNPATH
|
||||||
|
|
|
@ -4,20 +4,21 @@ meson-build-system.
|
||||||
|
|
||||||
Patch by Peter Mikkelsen <petermikkelsen10@gmail.com>
|
Patch by Peter Mikkelsen <petermikkelsen10@gmail.com>
|
||||||
|
|
||||||
--- meson-0.42.0/mesonbuild/scripts/meson_install.py.orig 2017-09-09 01:49:39.147374148 +0200
|
--- meson-0.42.0/mesonbuild/minstall.py.orig 2017-09-09 01:49:39.147374148 +0200
|
||||||
+++ meson-0.42.0/mesonbuild/scripts/meson_install.py 2017-09-09 01:51:01.209134717 +0200
|
+++ meson-0.42.0/mesonbuild/minstall.py 2017-09-09 01:51:01.209134717 +0200
|
||||||
@@ -391,14 +391,6 @@
|
@@ -436,15 +436,6 @@
|
||||||
print("Symlink creation does not work on this platform. "
|
print("Symlink creation does not work on this platform. "
|
||||||
"Skipping all symlinking.")
|
"Skipping all symlinking.")
|
||||||
printed_symlink_error = True
|
printed_symlink_error = True
|
||||||
- if os.path.isfile(outname):
|
- if os.path.isfile(outname):
|
||||||
- try:
|
- try:
|
||||||
- depfixer.fix_rpath(outname, install_rpath, False)
|
- depfixer.fix_rpath(outname, install_rpath, final_path,
|
||||||
- except SystemExit as e:
|
- install_name_mappings, verbose=False)
|
||||||
- if isinstance(e.code, int) and e.code == 0:
|
- except SystemExit as e:
|
||||||
- pass
|
- if isinstance(e.code, int) and e.code == 0:
|
||||||
- else:
|
- pass
|
||||||
- raise
|
- else:
|
||||||
|
- raise
|
||||||
|
|
||||||
def run(args):
|
def run(args):
|
||||||
global install_log_file
|
parser = buildparser()
|
||||||
|
|
Loading…
Reference in New Issue