gnu: bcftools: Update to 1.8.
* gnu/packages/bioinformatics.scm (bcftools): Update to 1.8. * gnu/local.mk: Remove patch. * gnu/packages/patches/bcftools-regidx-unsigned-char.patch: Remove file.
This commit is contained in:
parent
8df0267ad4
commit
cbd9f91c32
|
@ -575,7 +575,6 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/azr3.patch \
|
||||
%D%/packages/patches/bash-completion-directories.patch \
|
||||
%D%/packages/patches/bazaar-CVE-2017-14176.patch \
|
||||
%D%/packages/patches/bcftools-regidx-unsigned-char.patch \
|
||||
%D%/packages/patches/binutils-ld-new-dtags.patch \
|
||||
%D%/packages/patches/binutils-loongson-workaround.patch \
|
||||
%D%/packages/patches/blast+-fix-makefile.patch \
|
||||
|
|
|
@ -285,7 +285,7 @@ BAM files.")
|
|||
(define-public bcftools
|
||||
(package
|
||||
(name "bcftools")
|
||||
(version "1.5")
|
||||
(version "1.8")
|
||||
(source (origin
|
||||
(method url-fetch)
|
||||
(uri (string-append
|
||||
|
@ -293,12 +293,11 @@ BAM files.")
|
|||
version "/bcftools-" version ".tar.bz2"))
|
||||
(sha256
|
||||
(base32
|
||||
"0093hkkvxmbwfaa7905s6185jymynvg42kq6sxv7fili11l5mxwz"))
|
||||
(patches (search-patches "bcftools-regidx-unsigned-char.patch"))
|
||||
"1vgw2mwngq20c530zim52zvgmw1lci8rzl33pvh44xqk3xlzvjsa"))
|
||||
(modules '((guix build utils)))
|
||||
(snippet
|
||||
;; Delete bundled htslib.
|
||||
'(delete-file-recursively "htslib-1.5"))))
|
||||
'(delete-file-recursively "htslib-1.8"))))
|
||||
(build-system gnu-build-system)
|
||||
(arguments
|
||||
`(#:test-target "test"
|
||||
|
|
|
@ -1,16 +0,0 @@
|
|||
Description: Fix test-regidx argument parsing on archs with unsigned char
|
||||
On architectures where char is unsigned "c >= 0" was always true.
|
||||
Author: Adrian Bunk <bunk@debian.org>
|
||||
Bug-Debian: https://bugs.debian.org/865060
|
||||
|
||||
--- a/test/test-regidx.c
|
||||
+++ b/test/test-regidx.c
|
||||
@@ -336,7 +336,7 @@
|
||||
{"seed",1,0,'s'},
|
||||
{0,0,0,0}
|
||||
};
|
||||
- char c;
|
||||
+ int c;
|
||||
int seed = (int)time(NULL);
|
||||
while ((c = getopt_long(argc, argv, "hvs:",loptions,NULL)) >= 0)
|
||||
{
|
Loading…
Reference in New Issue