gnu: ninja: Update to 1.7.2.

* gnu/packages/ninja.scm (ninja): Update to 1.7.2.
[source]: Remove patch.
* gnu/packages/patches/ninja-tests.patch: Delete file.
* gnu/local.mk (dist_patch_DATA): Remove it.
master
Marius Bakke 2017-03-17 11:15:01 +01:00
parent 039601e097
commit cbef2796ed
No known key found for this signature in database
GPG Key ID: A2A06DF2A33A54FA
3 changed files with 3 additions and 53 deletions

View File

@ -778,7 +778,6 @@ dist_patch_DATA = \
%D%/packages/patches/netsurf-longer-test-timeout.patch \
%D%/packages/patches/ngircd-handle-zombies.patch \
%D%/packages/patches/ngircd-no-dns-in-tests.patch \
%D%/packages/patches/ninja-tests.patch \
%D%/packages/patches/ninja-zero-mtime.patch \
%D%/packages/patches/node-9077.patch \
%D%/packages/patches/nss-pkgconfig.patch \

View File

@ -29,7 +29,7 @@
(define-public ninja
(package
(name "ninja")
(version "1.7.1")
(version "1.7.2")
(source (origin
(method url-fetch)
(uri (string-append "https://github.com/martine/ninja/"
@ -37,9 +37,8 @@
(file-name (string-append name "-" version ".tar.gz"))
(sha256
(base32
"06dy2dc1aafm61ynw9gzig88la3km9dsh53bxf4mnw7l7kjisn2i"))
(patches (search-patches "ninja-zero-mtime.patch"
"ninja-tests.patch"))))
"1n8n3g26ppwh7zwrc37n3alkbpbj0wki34ih53s3rkhs8ajs1p9f"))
(patches (search-patches "ninja-zero-mtime.patch"))))
(build-system gnu-build-system)
(native-inputs `(("python" ,python-2)))
(arguments

View File

@ -1,48 +0,0 @@
From 67d6b9262efad99f8aad63ab81efc8e689748766 Mon Sep 17 00:00:00 2001
From: Efraim Flashner <efraim@flashner.co.il>
Date: Sun, 3 Jul 2016 11:55:43 +0300
Subject: [PATCH] patch
---
src/subprocess_test.cc | 4 ++++
1 file changed, 4 insertions(+)
diff --git a/src/subprocess_test.cc b/src/subprocess_test.cc
index ee16190..a537c11 100644
--- a/src/subprocess_test.cc
+++ b/src/subprocess_test.cc
@@ -72,6 +72,7 @@ TEST_F(SubprocessTest, NoSuchCommand) {
#ifndef _WIN32
+#if 0
TEST_F(SubprocessTest, InterruptChild) {
Subprocess* subproc = subprocs_.Add("kill -INT $$");
ASSERT_NE((Subprocess *) 0, subproc);
@@ -82,6 +83,7 @@ TEST_F(SubprocessTest, InterruptChild) {
EXPECT_EQ(ExitInterrupted, subproc->Finish());
}
+#endif
TEST_F(SubprocessTest, InterruptParent) {
Subprocess* subproc = subprocs_.Add("kill -INT $PPID ; sleep 1");
@@ -217,6 +219,7 @@ TEST_F(SubprocessTest, SetWithMulti) {
// OS X's process limit is less than 1025 by default
// (|sysctl kern.maxprocperuid| is 709 on 10.7 and 10.8 and less prior to that).
#if !defined(__APPLE__) && !defined(_WIN32)
+#if 0
TEST_F(SubprocessTest, SetWithLots) {
// Arbitrary big number; needs to be over 1024 to confirm we're no longer
// hostage to pselect.
@@ -245,6 +248,7 @@ TEST_F(SubprocessTest, SetWithLots) {
}
ASSERT_EQ(kNumProcs, subprocs_.finished_.size());
}
+#endif
#endif // !__APPLE__ && !_WIN32
// TODO: this test could work on Windows, just not sure how to simply
--
2.9.0