gnu: tar: Update to 1.17.
* gnu/packages/base.scm (tar): Update to 1.17. Remove 'arguments' and 'inputs'. * gnu/packages/patches/tar-gets-undeclared.patch: Remove. * gnu-system.am (dist_patch_DATA): Remove 'tar-gets-undeclared.patch'.
This commit is contained in:
parent
fb6c2fa82e
commit
cdecf77501
|
@ -239,7 +239,6 @@ dist_patch_DATA = \
|
|||
gnu/packages/patches/readline-link-ncurses.patch \
|
||||
gnu/packages/patches/ripperx-libm.patch \
|
||||
gnu/packages/patches/scheme48-tests.patch \
|
||||
gnu/packages/patches/tar-gets-undeclared.patch \
|
||||
gnu/packages/patches/tcsh-fix-autotest.patch \
|
||||
gnu/packages/patches/teckit-cstdio.patch \
|
||||
gnu/packages/patches/valgrind-glibc.patch \
|
||||
|
|
|
@ -130,18 +130,15 @@ is often used for substituting text patterns in a stream.")
|
|||
(define-public tar
|
||||
(package
|
||||
(name "tar")
|
||||
(version "1.26")
|
||||
(version "1.27")
|
||||
(source (origin
|
||||
(method url-fetch)
|
||||
(uri (string-append "mirror://gnu/tar/tar-"
|
||||
version ".tar.bz2"))
|
||||
(sha256
|
||||
(base32
|
||||
"0hbdkzmchq9ycr2x1pxqdcgdbaxksh8c6ac0jf75jajhcks6jlss"))))
|
||||
"0yrwmx2f721ahpnki4fnzvnmrd3md3bq417icb4wrjky7k3caf12"))))
|
||||
(build-system gnu-build-system)
|
||||
(inputs `(("patch/gets" ,(search-patch "tar-gets-undeclared.patch"))))
|
||||
(arguments
|
||||
`(#:patches (list (assoc-ref %build-inputs "patch/gets"))))
|
||||
(synopsis "Managing tar archives")
|
||||
(description
|
||||
"Tar provides the ability to create tar archives, as well as the
|
||||
|
|
|
@ -1,26 +0,0 @@
|
|||
This patch is needed to allow builds with newer versions of
|
||||
the GNU libc (2.16+).
|
||||
|
||||
This is a backport of this patch:
|
||||
|
||||
commit 66712c23388e93e5c518ebc8515140fa0c807348
|
||||
Author: Eric Blake <eblake@redhat.com>
|
||||
Date: Thu Mar 29 13:30:41 2012 -0600
|
||||
|
||||
stdio: don't assume gets any more
|
||||
|
||||
--- tar-1.26/gnu/stdio.in.h 2012-07-02 14:28:45.000000000 +0200
|
||||
+++ tar-1.26/gnu/stdio.in.h 2012-07-02 14:28:50.000000000 +0200
|
||||
@@ -160,12 +160,6 @@ _GL_WARN_ON_USE (fflush, "fflush is not
|
||||
"use gnulib module fflush for portable POSIX compliance");
|
||||
#endif
|
||||
|
||||
-/* It is very rare that the developer ever has full control of stdin,
|
||||
- so any use of gets warrants an unconditional warning. Assume it is
|
||||
- always declared, since it is required by C89. */
|
||||
-#undef gets
|
||||
-_GL_WARN_ON_USE (gets, "gets is a security hole - use fgets instead");
|
||||
-
|
||||
#if @GNULIB_FOPEN@
|
||||
# if @REPLACE_FOPEN@
|
||||
# if !(defined __cplusplus && defined GNULIB_NAMESPACE)
|
Loading…
Reference in New Issue