gnu: hwloc: Upgrade to 1.10.1.

* gnu/packages/patches/hwloc-gather-topology-lstopo.patch: New patch.
* gnu/packages/mpi.scm (hwloc): Upgrade to 1.10.1.
  [source]: Use patch.
  [propagated-inputs]: Remove libpci.
  [inputs]: Add libpciaccess.
* gnu-system.am (dist_patch_DATA): Add patch.
master
Eric Bavier 2015-06-14 17:11:00 -05:00
parent 7362371da5
commit ce7d9c989d
3 changed files with 24 additions and 13 deletions

View File

@ -462,6 +462,7 @@ dist_patch_DATA = \
gnu/packages/patches/gtkglext-disable-disable-deprecated.patch \
gnu/packages/patches/hop-bigloo-4.0b.patch \
gnu/packages/patches/hop-linker-flags.patch \
gnu/packages/patches/hwloc-gather-topology-lstopo.patch \
gnu/packages/patches/hydra-automake-1.15.patch \
gnu/packages/patches/hydra-disable-darcs-test.patch \
gnu/packages/patches/irrlicht-mesa-10.patch \

View File

@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2014 Eric Bavier <bavier@member.fsf.org>
;;; Copyright © 2014, 2015 Eric Bavier <bavier@member.fsf.org>
;;; Copyright © 2014 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2014 Ian Denhardt <ian@zenhack.net>
;;;
@ -39,30 +39,29 @@
(define-public hwloc
(package
(name "hwloc")
(version "1.9")
(version "1.10.1")
(source (origin
(method url-fetch)
(uri (string-append "http://www.open-mpi.org/software/hwloc/v"
version "/downloads/hwloc-"
version ".tar.bz2"))
(version-major+minor version)
"/downloads/hwloc-" version ".tar.bz2"))
(sha256
(base32
"0zjgiili2a8v63s8ly3a8qp8ibxv1jw3zbgm7diic3w1qgqiza14"))))
"0jji5rphy05s0lp6bknn8lxwixrq0hy5rjzsqvhjszbkl2li7kim"))
(patches (list
(search-patch "hwloc-gather-topology-lstopo.patch")))))
(build-system gnu-build-system)
(arguments
;; Enable libpci support, which effectively makes hwloc GPLv2+.
'(#:configure-flags '("--enable-libpci")))
(inputs
`(("libx11" ,libx11)
("cairo" ,cairo)
("ncurses" ,ncurses)
("libpciaccess" ,libpciaccess)
("expat" ,expat)))
(native-inputs
`(("pkg-config" ,pkg-config)))
(propagated-inputs
;; 'hwloc.pc' refers to libpci and libnuma, hence the propagation.
`(("numactl" ,numactl)
("pciutils" ,pciutils)))
;; 'hwloc.pc' refers to libnuma, hence the propagation.
`(("numactl" ,numactl)))
(home-page "http://www.open-mpi.org/projects/hwloc/")
(synopsis "Abstraction of hardware architectures")
(description
@ -77,8 +76,6 @@ exploit it accordingly and efficiently.
hwloc may display the topology in multiple convenient formats. It also offers
a powerful programming interface to gather information about the hardware,
bind processes, and much more.")
;; But see above about linking against libpci.
(license bsd-3)))
(define-public openmpi

View File

@ -0,0 +1,13 @@
Derived from upstream commit 0a32f719c.
--- hwloc-1.10.1/tests/linux/Makefile.in 2015-01-26 03:37:52.000000000 -0600
+++ hwloc-1.10.1/tests/linux/Makefile.in 2015-06-15 11:21:49.824842511 -0500
@@ -1633,7 +1633,7 @@
install-exec-hook:
- $(SED) -e 's/HWLOC_top_builddir\/utils/bindir/' -e '/HWLOC_top_builddir/d' $(DESTDIR)$(bindir)/hwloc-gather-topology > $(DESTDIR)$(bindir)/hwloc-gather-topology.tmp && mv -f $(DESTDIR)$(bindir)/hwloc-gather-topology.tmp $(DESTDIR)$(bindir)/hwloc-gather-topology
+ $(SED) -e 's/HWLOC_top_builddir\/utils\/lstopo/bindir/' -e '/HWLOC_top_builddir/d' $(DESTDIR)$(bindir)/hwloc-gather-topology > $(DESTDIR)$(bindir)/hwloc-gather-topology.tmp && mv -f $(DESTDIR)$(bindir)/hwloc-gather-topology.tmp $(DESTDIR)$(bindir)/hwloc-gather-topology
chmod +x $(DESTDIR)$(bindir)/hwloc-gather-topology
# Tell versions [3.59,3.63) of GNU make to not export all variables.