gnu: python-3.4: Update to 3.4.5.

* gnu/packages/patches/python-disable-ssl-test.patch: Delete file.
* gnu/local.mk (dist_patch_DATA): Remove it.
* gnu/packages/python.scm (python-3.4): Update to 3.4.5.
[source]: Remove patch.
[arguments]: Remove field.
(python-minimal)[inputs]: Add libffi.
master
Christopher Allan Webber 2016-06-20 14:05:20 -05:00 committed by Leo Famulari
parent 568230c378
commit d0b73960db
No known key found for this signature in database
GPG Key ID: 2646FA30BACA7F08
3 changed files with 5 additions and 22 deletions

View File

@ -748,7 +748,6 @@ dist_patch_DATA = \
%D%/packages/patches/python-3-deterministic-build-info.patch \
%D%/packages/patches/python-3-search-paths.patch \
%D%/packages/patches/python-dendropy-exclude-failing-tests.patch \
%D%/packages/patches/python-disable-ssl-test.patch \
%D%/packages/patches/python-fix-tests.patch \
%D%/packages/patches/python-ipython-inputhook-ctype.patch \
%D%/packages/patches/python-rarfile-fix-tests.patch \

View File

@ -1,12 +0,0 @@
Disable a test that fails with openssl-1.0.2b.
--- Lib/test/test_ssl.py.orig 2015-02-25 06:27:45.000000000 -0500
+++ Lib/test/test_ssl.py 2015-06-12 03:14:09.395212502 -0400
@@ -2718,6 +2718,7 @@
chatty=True, connectionchatty=True)
self.assertIs(stats['compression'], None)
+ @unittest.skipIf(True, "openssl 1.0.2b complains: dh key too small")
def test_dh_params(self):
# Check we can get a connection with ephemeral Diffie-Hellman
context = ssl.SSLContext(ssl.PROTOCOL_TLSv1)

View File

@ -295,21 +295,19 @@ data types.")
(define-public python-3.4
(package (inherit python-2)
(version "3.4.3")
(version "3.4.5")
(source (origin
(method url-fetch)
(uri (string-append "https://www.python.org/ftp/python/"
version "/Python-" version ".tar.xz"))
(patches (search-patches
"python-fix-tests.patch"
;; XXX Try removing this patch for python > 3.4.3
"python-disable-ssl-test.patch"
"python-3-deterministic-build-info.patch"
"python-3-search-paths.patch"))
(patch-flags '("-p0"))
(sha256
(base32
"1f4nm4z08sy0kqwisvv95l02crv6dyysdmx44p1mz3bn6csrdcxm"))))
"12l9klp778wklxmckhghniy5hklss8r26995pyd00qbllk4b2r7f"))))
(arguments (substitute-keyword-arguments (package-arguments python-2)
((#:tests? _) #t)))
(native-search-paths
@ -342,14 +340,12 @@ data types.")
(package (inherit python)
(name "python-minimal")
(outputs '("out"))
(arguments
(substitute-keyword-arguments (package-arguments python)
((#:configure-flags cf)
`(append ,cf '("--without-system-ffi")))))
;; Build fails due to missing ctypes without libffi.
;; OpenSSL is a mandatory dependency of Python 3.x, for urllib;
;; zlib is required by 'zipimport', used by pip.
(inputs `(("openssl" ,openssl)
(inputs `(("libffi" ,libffi)
("openssl" ,openssl)
("zlib" ,zlib)))))
(define* (wrap-python3 python