gnu: hwloc@2: Update to 2.0.1.

* gnu/packages/mpi.scm (hwloc-2.0): Update to 2.0.1.
[source]: Remove 'patches'.
* gnu/packages/patches/hwloc-tests-without-sysfs.patch: Remove.
* gnu/local.mk (dist_patch_DATA): Adjust accordingly.
master
Ludovic Courtès 2018-03-26 18:03:57 +02:00 committed by Ludovic Courtès
parent bab9793f54
commit d2c036557a
No known key found for this signature in database
GPG Key ID: 090B11993D9AEBB5
3 changed files with 2 additions and 46 deletions

View File

@ -781,7 +781,6 @@ dist_patch_DATA = \
%D%/packages/patches/htop-fix-process-tree.patch \
%D%/packages/patches/hubbub-sort-entities.patch \
%D%/packages/patches/hurd-fix-eth-multiplexer-dependency.patch \
%D%/packages/patches/hwloc-tests-without-sysfs.patch \
%D%/packages/patches/hydra-disable-darcs-test.patch \
%D%/packages/patches/icecat-avoid-bundled-libraries.patch \
%D%/packages/patches/icecat-use-system-graphite2.patch \

View File

@ -117,7 +117,7 @@ bind processes, and much more.")
;; Note: 2.0 isn't the default yet, see above.
(package
(inherit hwloc)
(version "2.0.0")
(version "2.0.1")
(source (origin
(method url-fetch)
(uri (string-append "https://www.open-mpi.org/software/hwloc/v"
@ -125,8 +125,7 @@ bind processes, and much more.")
"/downloads/hwloc-" version ".tar.bz2"))
(sha256
(base32
"021765f9y6pxcxrvfpzzwaig16ypfbph5xjpkd29qkhzs9r6zrcr"))
(patches (search-patches "hwloc-tests-without-sysfs.patch"))))
"0jf0krj1h95flmb784ifv9vnkdnajjz00p4zbhmja7vm4v67axdr"))))
;; libnuma is no longer needed.
(inputs (alist-delete "numactl" (package-inputs hwloc)))))

View File

@ -1,42 +0,0 @@
Fix a test failure in the build environment, where /sys is missing.
From <https://github.com/bgoglin/hwloc/commit/a2cc4f2e2bf4a8bbdd61b578a62e27e7482799cf.patch>.
From a2cc4f2e2bf4a8bbdd61b578a62e27e7482799cf Mon Sep 17 00:00:00 2001
From: Brice Goglin <Brice.Goglin@inria.fr>
Date: Tue, 6 Feb 2018 17:13:26 +0100
Subject: [PATCH] linux: honor the filtering cores and packages when reading
topology from cpuinfo
Caused a make check crash in lstopo --filter all:none in chroot without sysfs.
Thanks to Ludovic Courtes for the report.
Signed-off-by: Brice Goglin <Brice.Goglin@inria.fr>
---
hwloc/topology-linux.c | 6 ++++--
1 file changed, 4 insertions(+), 2 deletions(-)
diff --git a/hwloc/topology-linux.c b/hwloc/topology-linux.c
index 290da0d72..e1bbf94e1 100644
--- a/hwloc/topology-linux.c
+++ b/hwloc/topology-linux.c
@@ -4101,7 +4101,8 @@ look_cpuinfo(struct hwloc_topology *topology,
}
/* create package objects */
hwloc_debug("%u pkgs%s\n", numpkgs, missingpkg ? ", but some missing package" : "");
- if (!missingpkg && numpkgs>0) {
+ if (!missingpkg && numpkgs>0
+ && hwloc_filter_check_keep_object_type(topology, HWLOC_OBJ_PACKAGE)) {
for (i = 0; i < numpkgs; i++) {
struct hwloc_obj *obj = hwloc_alloc_setup_object(topology, HWLOC_OBJ_PACKAGE, Lpkg_to_Ppkg[i]);
int doneinfos = 0;
@@ -4145,7 +4146,8 @@ look_cpuinfo(struct hwloc_topology *topology,
}
/* create Core objects */
hwloc_debug("%u cores%s\n", numcores, missingcore ? ", but some missing core" : "");
- if (!missingcore && numcores>0) {
+ if (!missingcore && numcores>0
+ && hwloc_filter_check_keep_object_type(topology, HWLOC_OBJ_CORE)) {
for (i = 0; i < numcores; i++) {
struct hwloc_obj *obj = hwloc_alloc_setup_object(topology, HWLOC_OBJ_CORE, Lcore_to_Pcore[i]);
obj->cpuset = hwloc_bitmap_alloc();