gnu: metabat: Fix boost-related compilation issue.
Reported by Leo Famulari. * gnu/packages/patches/metabat-fix-boost-issue.patch: New file. * gnu/packages/bioinformatics.scm (metabat): Use it. * gnu/local.mk (dist_patch_DATA): Add it.
This commit is contained in:
parent
6c1a317e29
commit
d3dce32216
|
@ -822,6 +822,7 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/mesa-wayland-egl-symbols-check-mips.patch \
|
||||
%D%/packages/patches/metabat-remove-compilation-date.patch \
|
||||
%D%/packages/patches/metabat-fix-compilation.patch \
|
||||
%D%/packages/patches/metabat-fix-boost-issue.patch \
|
||||
%D%/packages/patches/mhash-keygen-test-segfault.patch \
|
||||
%D%/packages/patches/mingw-w64-5.0rc2-gcc-4.9.3.patch \
|
||||
%D%/packages/patches/mpc123-initialize-ao.patch \
|
||||
|
|
|
@ -3480,7 +3480,8 @@ form of assemblies or reads.")
|
|||
(base32
|
||||
"0ll00l81aflscgggs5nfhj12cbvdiz3gg7f7n5f537a3xhx60vn9"))
|
||||
(patches (search-patches "metabat-remove-compilation-date.patch"
|
||||
"metabat-fix-compilation.patch"))))
|
||||
"metabat-fix-compilation.patch"
|
||||
"metabat-fix-boost-issue.patch"))))
|
||||
(build-system gnu-build-system)
|
||||
(arguments
|
||||
`(#:phases
|
||||
|
|
|
@ -0,0 +1,27 @@
|
|||
This patch fixes the issue described at
|
||||
https://bitbucket.org/berkeleylab/metabat/issues/28/compilation-fail-with-boost-164
|
||||
|
||||
diff --git a/src/metabat.h b/src/metabat.h
|
||||
index 32ae94c..2292c04 100644
|
||||
--- a/src/metabat.h
|
||||
+++ b/src/metabat.h
|
||||
@@ -35,6 +35,7 @@ KSEQ_INIT(gzFile, gzread)
|
||||
|
||||
#include <boost/program_options.hpp>
|
||||
#include <boost/algorithm/string.hpp>
|
||||
+#include <boost/serialization/array_wrapper.hpp>
|
||||
#include <boost/numeric/ublas/matrix.hpp>
|
||||
#include <boost/math/distributions.hpp>
|
||||
#include <boost/serialization/serialization.hpp>
|
||||
diff --git a/src/metabat2.h b/src/metabat2.h
|
||||
index 60a9998..19fa815 100644
|
||||
--- a/src/metabat2.h
|
||||
+++ b/src/metabat2.h
|
||||
@@ -41,6 +41,7 @@ KSEQ_INIT(gzFile, gzread)
|
||||
|
||||
#include <boost/program_options.hpp>
|
||||
#include <boost/algorithm/string.hpp>
|
||||
+#include <boost/serialization/array_wrapper.hpp>
|
||||
#include <boost/numeric/ublas/matrix.hpp>
|
||||
#include <boost/numeric/ublas/matrix_sparse.hpp>
|
||||
#include <boost/numeric/ublas/matrix_proxy.hpp>
|
Loading…
Reference in New Issue