gnu: elogind: Fix build with glibc-2.27.
* gnu/packages/patches/elogind-glibc-2.27.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/freedesktop.scm (elogind)[source]: Add patch. [arguments]: Replace the bootstrap phase with what was previously the autogen phase.
This commit is contained in:
parent
78666a68a5
commit
d4040f6e23
|
@ -628,6 +628,7 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/eigen-arm-neon-fixes.patch \
|
||||
%D%/packages/patches/elfutils-tests-ptrace.patch \
|
||||
%D%/packages/patches/elixir-disable-failing-tests.patch \
|
||||
%D%/packages/patches/elogind-glibc-2.27.patch \
|
||||
%D%/packages/patches/einstein-build.patch \
|
||||
%D%/packages/patches/emacs-browse-at-remote-cgit-gnu.patch \
|
||||
%D%/packages/patches/emacs-exec-path.patch \
|
||||
|
|
|
@ -7,7 +7,7 @@
|
|||
;;; Copyright © 2015 David Hashe <david.hashe@dhashe.com>
|
||||
;;; Copyright © 2016, 2017 Efraim Flashner <efraim@flashner.co.il>
|
||||
;;; Copyright © 2016 Kei Kebreau <kkebreau@posteo.net>
|
||||
;;; Copyright © 2017 Mark H Weaver <mhw@netris.org>
|
||||
;;; Copyright © 2017, 2018 Mark H Weaver <mhw@netris.org>
|
||||
;;; Copyright © 2017, 2018 Marius Bakke <mbakke@fastmail.com>
|
||||
;;; Copyright © 2017 Rutger Helling <rhelling@mykolab.com>
|
||||
;;; Copyright © 2017 Brendan Tildesley <brendan.tildesley@openmailbox.org>
|
||||
|
@ -38,6 +38,7 @@
|
|||
#:use-module (guix build-system meson)
|
||||
#:use-module (guix build-system perl)
|
||||
#:use-module (guix build-system python)
|
||||
#:use-module (gnu packages)
|
||||
#:use-module (gnu packages acl)
|
||||
#:use-module (gnu packages admin)
|
||||
#:use-module (gnu packages autotools)
|
||||
|
@ -236,6 +237,7 @@ the freedesktop.org XDG Base Directory specification.")
|
|||
(sha256
|
||||
(base32
|
||||
"1qcxian48z2dj5gfmp7brrngdydqf2jm00f4rjr5sy1myh8fy931"))
|
||||
(patches (search-patches "elogind-glibc-2.27.patch"))
|
||||
(modules '((guix build utils)))
|
||||
(snippet
|
||||
'(begin
|
||||
|
@ -277,7 +279,7 @@ the freedesktop.org XDG Base Directory specification.")
|
|||
(substitute* "src/basic/parse-util.c"
|
||||
(("xlocale\\.h") "locale.h"))
|
||||
#t))
|
||||
(add-before 'configure 'autogen
|
||||
(replace 'bootstrap
|
||||
(lambda _
|
||||
(invoke "intltoolize" "--force" "--automake")
|
||||
(invoke "autoreconf" "-vif")))
|
||||
|
|
|
@ -0,0 +1,22 @@
|
|||
Look for memfd_create in sys/mman.h instead of linux/memfd.h.
|
||||
Needed to build with glibc-2.27.
|
||||
|
||||
--- a/configure.ac 1969-12-31 19:00:00.000000000 -0500
|
||||
+++ b/configure.ac 2018-03-27 23:54:15.414589005 -0400
|
||||
@@ -360,7 +360,7 @@
|
||||
# ------------------------------------------------------------------------------
|
||||
|
||||
AC_CHECK_HEADERS([sys/capability.h], [], [AC_MSG_ERROR([*** POSIX caps headers not found])])
|
||||
-AC_CHECK_HEADERS([linux/memfd.h], [], [])
|
||||
+AC_CHECK_HEADERS([sys/mman.h], [], [])
|
||||
|
||||
AC_CHECK_HEADERS([printf.h], [have_printf_h=yes], [have_printf_h=no])
|
||||
AS_IF([test x$have_printf_h = xyes], [
|
||||
@@ -395,6 +395,7 @@
|
||||
[], [], [[
|
||||
#include <sys/types.h>
|
||||
#include <unistd.h>
|
||||
+#include <sys/mman.h>
|
||||
#include <sys/mount.h>
|
||||
#include <fcntl.h>
|
||||
#include <sched.h>
|
Loading…
Reference in New Issue