gnu: inetutils: Apply syslogd patch.
* gnu/packages/patches/inetutils-syslogd.patch: New file. * gnu-system.am (dist_patch_DATA): Add it. * gnu/packages/admin.scm (inetutils)[source]: Use it. [native-inputs]: New field.
This commit is contained in:
parent
de4b3828ca
commit
d525da858d
|
@ -438,6 +438,7 @@ dist_patch_DATA = \
|
||||||
gnu/packages/patches/guix-test-networking.patch \
|
gnu/packages/patches/guix-test-networking.patch \
|
||||||
gnu/packages/patches/gtkglext-disable-disable-deprecated.patch \
|
gnu/packages/patches/gtkglext-disable-disable-deprecated.patch \
|
||||||
gnu/packages/patches/hop-bigloo-4.0b.patch \
|
gnu/packages/patches/hop-bigloo-4.0b.patch \
|
||||||
|
gnu/packages/patches/inetutils-syslogd.patch \
|
||||||
gnu/packages/patches/irrlicht-mesa-10.patch \
|
gnu/packages/patches/irrlicht-mesa-10.patch \
|
||||||
gnu/packages/patches/jbig2dec-ignore-testtest.patch \
|
gnu/packages/patches/jbig2dec-ignore-testtest.patch \
|
||||||
gnu/packages/patches/kmod-module-directory.patch \
|
gnu/packages/patches/kmod-module-directory.patch \
|
||||||
|
|
|
@ -55,7 +55,8 @@
|
||||||
#:use-module (gnu packages libftdi)
|
#:use-module (gnu packages libftdi)
|
||||||
#:use-module (gnu packages image)
|
#:use-module (gnu packages image)
|
||||||
#:use-module (gnu packages xorg)
|
#:use-module (gnu packages xorg)
|
||||||
#:use-module (gnu packages python))
|
#:use-module (gnu packages python)
|
||||||
|
#:use-module (gnu packages man))
|
||||||
|
|
||||||
(define-public dmd
|
(define-public dmd
|
||||||
(package
|
(package
|
||||||
|
@ -158,13 +159,18 @@ re-executing them as necessary.")
|
||||||
version ".tar.gz"))
|
version ".tar.gz"))
|
||||||
(sha256
|
(sha256
|
||||||
(base32
|
(base32
|
||||||
"04wrm0v7l4890mmbaawd6wjwdv08bkglgqhpz0q4dkb0l50fl8q4"))))
|
"04wrm0v7l4890mmbaawd6wjwdv08bkglgqhpz0q4dkb0l50fl8q4"))
|
||||||
|
(patches (list (search-patch "inetutils-syslogd.patch")))))
|
||||||
(build-system gnu-build-system)
|
(build-system gnu-build-system)
|
||||||
(arguments `(;; FIXME: `tftp.sh' relies on `netstat' from utils-linux,
|
(arguments `(;; FIXME: `tftp.sh' relies on `netstat' from utils-linux,
|
||||||
;; which is currently missing.
|
;; which is currently missing.
|
||||||
#:tests? #f))
|
#:tests? #f))
|
||||||
(inputs `(("ncurses" ,ncurses)
|
(inputs `(("ncurses" ,ncurses)
|
||||||
("readline" ,readline))) ; for 'ftp'
|
("readline" ,readline))) ; for 'ftp'
|
||||||
|
|
||||||
|
;; Help2man is needed because of the patch that modifies syslogd.c.
|
||||||
|
(native-inputs `(("help2man" ,help2man)))
|
||||||
|
|
||||||
(home-page "http://www.gnu.org/software/inetutils/")
|
(home-page "http://www.gnu.org/software/inetutils/")
|
||||||
(synopsis "Basic networking utilities")
|
(synopsis "Basic networking utilities")
|
||||||
(description
|
(description
|
||||||
|
|
|
@ -0,0 +1,20 @@
|
||||||
|
From <http://lists.gnu.org/archive/html/bug-inetutils/2015-04/msg00001.html>.
|
||||||
|
|
||||||
|
2015-04-01 Ludovic Courtès <ludo@gnu.org>
|
||||||
|
|
||||||
|
* src/syslogd.c (load_conffile): Use 'bcopy' instead of 'strcpy'
|
||||||
|
since the two regions may overlap.
|
||||||
|
Reported by Alex Kost <alezost@gmail.com>
|
||||||
|
at <http://lists.gnu.org/archive/html/guix-devel/2015-03/msg00780.html>.
|
||||||
|
|
||||||
|
--- a/src/syslogd.c
|
||||||
|
+++ b/src/syslogd.c
|
||||||
|
@@ -1989,7 +1989,7 @@ load_conffile (const char *filename, struct filed **nextp)
|
||||||
|
if (*p == '\0' || *p == '#')
|
||||||
|
continue;
|
||||||
|
|
||||||
|
- strcpy (cline, p);
|
||||||
|
+ bcopy (p, cline, strlen (p) + 1);
|
||||||
|
|
||||||
|
/* Cut the trailing spaces. */
|
||||||
|
for (p = strchr (cline, '\0'); isspace (*--p);)
|
Loading…
Reference in New Issue