gnu: libffi: Fix builds on Alpha.
* gnu/packages/patches/libffi-3.2.1-complex_alpha.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/libffi.scm (libffi)[source]: Use it. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
This commit is contained in:
parent
bd54c5e3fa
commit
dc4ebebd61
|
@ -697,6 +697,7 @@ dist_patch_DATA = \
|
||||||
%D%/packages/patches/libevent-2.1-skip-failing-test.patch \
|
%D%/packages/patches/libevent-2.1-skip-failing-test.patch \
|
||||||
%D%/packages/patches/libextractor-ffmpeg-3.patch \
|
%D%/packages/patches/libextractor-ffmpeg-3.patch \
|
||||||
%D%/packages/patches/libgit2-use-after-free.patch \
|
%D%/packages/patches/libgit2-use-after-free.patch \
|
||||||
|
%D%/packages/patches/libffi-3.2.1-complex-alpha.patch \
|
||||||
%D%/packages/patches/libjxr-fix-function-signature.patch \
|
%D%/packages/patches/libjxr-fix-function-signature.patch \
|
||||||
%D%/packages/patches/libjxr-fix-typos.patch \
|
%D%/packages/patches/libjxr-fix-typos.patch \
|
||||||
%D%/packages/patches/liboop-mips64-deplibs-fix.patch \
|
%D%/packages/patches/liboop-mips64-deplibs-fix.patch \
|
||||||
|
|
|
@ -42,7 +42,8 @@
|
||||||
name "-" version ".tar.gz"))
|
name "-" version ".tar.gz"))
|
||||||
(sha256
|
(sha256
|
||||||
(base32
|
(base32
|
||||||
"0dya49bnhianl0r65m65xndz6ls2jn1xngyn72gd28ls3n7bnvnh"))))
|
"0dya49bnhianl0r65m65xndz6ls2jn1xngyn72gd28ls3n7bnvnh"))
|
||||||
|
(patches (search-patches "libffi-3.2.1-complex-alpha.patch"))))
|
||||||
(build-system gnu-build-system)
|
(build-system gnu-build-system)
|
||||||
(arguments `(#:phases (alist-cons-after 'install 'post-install
|
(arguments `(#:phases (alist-cons-after 'install 'post-install
|
||||||
,post-install-phase
|
,post-install-phase
|
||||||
|
|
|
@ -0,0 +1,28 @@
|
||||||
|
The patch fixes build failure of form:
|
||||||
|
../src/alpha/osf.S:298:2: error: #error "osf.S out of sync with ffi.h"
|
||||||
|
Upstream fixed the bug in a more invasive way
|
||||||
|
but didn't have releases since 3.2.1.
|
||||||
|
|
||||||
|
The patch is taken from Gentoo:
|
||||||
|
https://gitweb.gentoo.org/repo/gentoo.git/tree/dev-libs/libffi/files/libffi-3.2.1-complex_alpha.patch
|
||||||
|
|
||||||
|
--- libffi-3.2.1/src/alpha/osf.S 2015-01-16 10:46:15.000000000 +0100
|
||||||
|
+++ libffi-3.2.1/src/alpha/osf.S 2015-01-16 10:46:24.000000000 +0100
|
||||||
|
@@ -279,6 +279,7 @@
|
||||||
|
.gprel32 $load_64 # FFI_TYPE_SINT64
|
||||||
|
.gprel32 $load_none # FFI_TYPE_STRUCT
|
||||||
|
.gprel32 $load_64 # FFI_TYPE_POINTER
|
||||||
|
+ .gprel32 $load_none # FFI_TYPE_COMPLEX
|
||||||
|
|
||||||
|
/* Assert that the table above is in sync with ffi.h. */
|
||||||
|
|
||||||
|
@@ -294,7 +295,8 @@
|
||||||
|
|| FFI_TYPE_SINT64 != 12 \
|
||||||
|
|| FFI_TYPE_STRUCT != 13 \
|
||||||
|
|| FFI_TYPE_POINTER != 14 \
|
||||||
|
- || FFI_TYPE_LAST != 14
|
||||||
|
+ || FFI_TYPE_COMPLEX != 15 \
|
||||||
|
+ || FFI_TYPE_LAST != 15
|
||||||
|
#error "osf.S out of sync with ffi.h"
|
||||||
|
#endif
|
||||||
|
|
Loading…
Reference in New Issue