gnu: python@2.7: Fix getentropy() calls on kernels < 3.17.
* gnu/packages/patches/python-2.7-getentropy-on-old-kernels.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/python.scm (python-2.7)[source]: Use it.
This commit is contained in:
parent
3f9543aee1
commit
dc5cec21f2
|
@ -848,6 +848,7 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/pygpgme-disable-problematic-tests.patch \
|
||||
%D%/packages/patches/pyqt-configure.patch \
|
||||
%D%/packages/patches/python-2-deterministic-build-info.patch \
|
||||
%D%/packages/patches/python-2.7-getentropy-on-old-kernels.patch \
|
||||
%D%/packages/patches/python-2.7-search-paths.patch \
|
||||
%D%/packages/patches/python-2.7-site-prefixes.patch \
|
||||
%D%/packages/patches/python-2.7-source-date-epoch.patch \
|
||||
|
|
|
@ -0,0 +1,54 @@
|
|||
This patch resolves a compatibility issue when compiled against glibc
|
||||
2.25
|
||||
and run runder kernels < 3.17:
|
||||
|
||||
https://bugzilla.redhat.com/show_bug.cgi?id=1410175
|
||||
|
||||
Upstream bug URLs:
|
||||
|
||||
https://bugs.python.org/issue29157
|
||||
https://bugs.python.org/issue29188
|
||||
|
||||
Patch adapted from upstream source repository:
|
||||
|
||||
https://github.com/python/cpython/commit/01bdbad3e951014c58581635b94b22868537901c
|
||||
|
||||
From 01bdbad3e951014c58581635b94b22868537901c Mon Sep 17 00:00:00 2001
|
||||
From: Victor Stinner <victor.stinner@gmail.com>
|
||||
Date: Mon, 9 Jan 2017 11:10:41 +0100
|
||||
Subject: [PATCH] Don't use getentropy() on Linux
|
||||
|
||||
Issue #29188: Support glibc 2.24 on Linux: don't use getentropy() function but
|
||||
read from /dev/urandom to get random bytes, for example in os.urandom(). On
|
||||
Linux, getentropy() is implemented which getrandom() is blocking mode, whereas
|
||||
os.urandom() should not block.
|
||||
---
|
||||
Misc/NEWS | 5 +++++
|
||||
Python/random.c | 11 +++++++++--
|
||||
2 files changed, 14 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/Python/random.c b/Python/random.c
|
||||
index 57c41ffcd6..000cb36938 100644
|
||||
--- a/Python/random.c
|
||||
+++ b/Python/random.c
|
||||
@@ -97,8 +97,15 @@ win32_urandom(unsigned char *buffer, Py_ssize_t size, int raise)
|
||||
}
|
||||
|
||||
/* Issue #25003: Don't use getentropy() on Solaris (available since
|
||||
- * Solaris 11.3), it is blocking whereas os.urandom() should not block. */
|
||||
-#elif defined(HAVE_GETENTROPY) && !defined(sun)
|
||||
+ Solaris 11.3), it is blocking whereas os.urandom() should not block.
|
||||
+
|
||||
+ Issue #29188: Don't use getentropy() on Linux since the glibc 2.24
|
||||
+ implements it with the getrandom() syscall which can fail with ENOSYS,
|
||||
+ and this error is not supported in py_getentropy() and getrandom() is called
|
||||
+ with flags=0 which blocks until system urandom is initialized, which is not
|
||||
+ the desired behaviour to seed the Python hash secret nor for os.urandom():
|
||||
+ see the PEP 524 which was only implemented in Python 3.6. */
|
||||
+#elif defined(HAVE_GETENTROPY) && !defined(sun) && !defined(linux)
|
||||
#define PY_GETENTROPY 1
|
||||
|
||||
/* Fill buffer with size pseudo-random bytes generated by getentropy().
|
||||
--
|
||||
2.12.0
|
||||
|
|
@ -133,7 +133,8 @@
|
|||
(patches (search-patches "python-2.7-search-paths.patch"
|
||||
"python-2-deterministic-build-info.patch"
|
||||
"python-2.7-site-prefixes.patch"
|
||||
"python-2.7-source-date-epoch.patch"))
|
||||
"python-2.7-source-date-epoch.patch"
|
||||
"python-2.7-getentropy-on-old-kernels.patch"))
|
||||
(modules '((guix build utils)))
|
||||
;; suboptimal to delete failing tests here, but if we delete them in the
|
||||
;; arguments then we need to make sure to strip out that phase when it
|
||||
|
|
Loading…
Reference in New Issue