gnu: python-2: Honor 'SOURCE_DATE_EPOCH'.
* gnu/packages/patches/python-2.7-source-date-epoch.patch: New file. * gnu/packages/python.scm (python-2)[source]: Use it. [arguments]: Set SOURCE_DATE_EPOCH in 'patch-lib-shells' phase. * guix/build/python-build-system.scm (set-SOURCE-DATE-EPOCH): New procedure. (%standard-phases): Add it. * gnu-system.am (dist_patch_DATA): Add patch.
This commit is contained in:
parent
f8e7fdc416
commit
dedc832070
|
@ -670,6 +670,7 @@ dist_patch_DATA = \
|
|||
gnu/packages/patches/pybugz-stty.patch \
|
||||
gnu/packages/patches/pyqt-configure.patch \
|
||||
gnu/packages/patches/python-2.7-search-paths.patch \
|
||||
gnu/packages/patches/python-2.7-source-date-epoch.patch \
|
||||
gnu/packages/patches/python-3-search-paths.patch \
|
||||
gnu/packages/patches/python-disable-ssl-test.patch \
|
||||
gnu/packages/patches/python-fix-tests.patch \
|
||||
|
|
|
@ -0,0 +1,33 @@
|
|||
Honor the 'SOURCE_DATE_EPOCH' environment variable to allow for
|
||||
determinitic builds.
|
||||
|
||||
--- a/Lib/py_compile.py
|
||||
+++ b/Lib/py_compile.py
|
||||
@@ -105,7 +105,10 @@ def compile(file, cfile=None, dfile=None, doraise=False):
|
||||
"""
|
||||
with open(file, 'U') as f:
|
||||
try:
|
||||
- timestamp = long(os.fstat(f.fileno()).st_mtime)
|
||||
+ if 'SOURCE_DATE_EPOCH' in os.environ:
|
||||
+ timestamp = long(os.environ['SOURCE_DATE_EPOCH'])
|
||||
+ else:
|
||||
+ timestamp = long(os.fstat(f.fileno()).st_mtime)
|
||||
except AttributeError:
|
||||
timestamp = long(os.stat(file).st_mtime)
|
||||
codestring = f.read()
|
||||
diff --git a/Python/import.c b/Python/import.c
|
||||
index e47ce63..7eecf9c 100644
|
||||
--- a/Python/import.c
|
||||
+++ b/Python/import.c
|
||||
@@ -945,6 +945,11 @@ write_compiled_module(PyCodeObject *co, char *cpathname, struct stat *srcstat, t
|
||||
/* Now write the true mtime (as a 32-bit field) */
|
||||
fseek(fp, 4L, 0);
|
||||
assert(mtime <= 0xFFFFFFFF);
|
||||
+ if (Py_GETENV("SOURCE_DATE_EPOCH") != NULL) {
|
||||
+ const char *epoch = Py_GETENV("SOURCE_DATE_EPOCH");
|
||||
+ mtime = atoi(epoch);
|
||||
+ }
|
||||
+
|
||||
PyMarshal_WriteLongToFile((long)mtime, fp, Py_MARSHAL_VERSION);
|
||||
fflush(fp);
|
||||
fclose(fp);
|
|
@ -92,7 +92,9 @@
|
|||
(sha256
|
||||
(base32
|
||||
"1h7zbrf9pkj29hlm18b10548ch9757f75m64l47sy75rh43p7lqw"))
|
||||
(patches (list (search-patch "python-2.7-search-paths.patch")))))
|
||||
(patches (map search-patch
|
||||
'("python-2.7-search-paths.patch"
|
||||
"python-2.7-source-date-epoch.patch")))))
|
||||
(build-system gnu-build-system)
|
||||
(arguments
|
||||
`(#:tests? #f
|
||||
|
@ -158,6 +160,11 @@
|
|||
"Lib/distutils/tests/test_spawn.py"
|
||||
"Lib/test/test_subprocess.py"))
|
||||
(("/bin/sh") (which "sh")))
|
||||
|
||||
;; Use zero as the timestamp in .pyc files so that builds are
|
||||
;; deterministic. TODO: Remove it when this variable is set in
|
||||
;; gnu-build-system.scm.
|
||||
(setenv "SOURCE_DATE_EPOCH" "0")
|
||||
#t))
|
||||
(add-before
|
||||
'check 'pre-check
|
||||
|
|
|
@ -136,11 +136,18 @@ installed with setuptools."
|
|||
#t))
|
||||
#t))
|
||||
|
||||
(define* (set-SOURCE-DATE-EPOCH #:rest _)
|
||||
"Set the 'SOURCE_DATE_EPOCH' environment variable."
|
||||
;; Use zero as the timestamp in .pyc files so that builds are deterministic.
|
||||
;; TODO: Remove it when this variable is set in GNU:%STANDARD-PHASES.
|
||||
(setenv "SOURCE_DATE_EPOCH" "0"))
|
||||
|
||||
(define %standard-phases
|
||||
;; 'configure' and 'build' phases are not needed. Everything is done during
|
||||
;; 'install'.
|
||||
(modify-phases gnu:%standard-phases
|
||||
(add-after 'unpack 'ensure-no-mtimes-pre-1980 ensure-no-mtimes-pre-1980)
|
||||
(add-after 'unpack 'set-SOURCE-DATE-EPOCH set-SOURCE-DATE-EPOCH)
|
||||
(delete 'configure)
|
||||
(replace 'install install)
|
||||
(replace 'check check)
|
||||
|
|
Loading…
Reference in New Issue