gnu: x265: Update to 2.9.
* gnu/packages/video.scm (x265): Update to 2.9. [source]: Remove x265-fix-ppc64le-build.patch. * gnu/packages/patches/x265-fix-ppc64le-build.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Remove it.
This commit is contained in:
parent
4702d45280
commit
dfe05297f3
|
@ -1228,7 +1228,6 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/wpa-supplicant-krack-followups.patch \
|
||||
%D%/packages/patches/wxmaxima-do-not-use-old-gnuplot-parameters.patch \
|
||||
%D%/packages/patches/x265-arm-asm-primitives.patch \
|
||||
%D%/packages/patches/x265-fix-ppc64le-build.patch \
|
||||
%D%/packages/patches/xapian-revert-5489fb2f8.patch \
|
||||
%D%/packages/patches/xboing-CVE-2004-0149.patch \
|
||||
%D%/packages/patches/xf86-video-ark-remove-mibstore.patch \
|
||||
|
|
|
@ -1,25 +0,0 @@
|
|||
https://sources.debian.org/data/main/x/x265/2.8-3/debian/patches/0003-Fix-build-error-on-on-ppc64le.patch
|
||||
|
||||
This patch also fixes building on armhf-linux and aarch64-linux
|
||||
|
||||
From: Jayashree <jayashree.c@multicorewareinc.com>
|
||||
Date: Fri, 25 May 2018 10:26:05 +0530
|
||||
Subject: Fix build error on on ppc64le
|
||||
|
||||
---
|
||||
source/common/param.cpp | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/source/common/param.cpp b/source/common/param.cpp
|
||||
index 31bcbc7..4a6d0c8 100644
|
||||
--- a/source/common/param.cpp
|
||||
+++ b/source/common/param.cpp
|
||||
@@ -633,7 +633,7 @@ int x265_param_parse(x265_param* p, const char* name, const char* value)
|
||||
if (bValueWasNull)
|
||||
p->cpuid = atobool(value);
|
||||
else
|
||||
- p->cpuid = parseCpuName(value, bError);
|
||||
+ p->cpuid = parseCpuName(value, bError, false);
|
||||
#endif
|
||||
}
|
||||
OPT("fps")
|
|
@ -392,7 +392,7 @@ and creating Matroska files from other media files (@code{mkvmerge}).")
|
|||
(define-public x265
|
||||
(package
|
||||
(name "x265")
|
||||
(version "2.8")
|
||||
(version "2.9")
|
||||
(source
|
||||
(origin
|
||||
(method url-fetch)
|
||||
|
@ -400,9 +400,8 @@ and creating Matroska files from other media files (@code{mkvmerge}).")
|
|||
"x265_" version ".tar.gz"))
|
||||
(sha256
|
||||
(base32
|
||||
"0qx8mavwdzdpkkby7n29i9av7zsnklavacwfz537mf62q2pzjnbf"))
|
||||
(patches (search-patches "x265-fix-ppc64le-build.patch"
|
||||
"x265-arm-asm-primitives.patch"))
|
||||
"090hp4216isis8q5gb7bwzia8rfyzni54z21jnwm97x3hiy6ibpb"))
|
||||
(patches (search-patches "x265-arm-asm-primitives.patch"))
|
||||
(modules '((guix build utils)))
|
||||
(snippet '(begin
|
||||
(delete-file-recursively "source/compat/getopt")
|
||||
|
|
Loading…
Reference in New Issue