gnu: acl: Update to 2.2.53.
* gnu/packages/patches/acl-hurd-path-max.patch, gnu/packages/patches/acl-fix-perl-regex.patch: Delete files. * gnu/local.mk (dist_patch_DATA): Adjust accordingly. * gnu/packages/acl.scm (acl): Update to 2.2.53. [source](uri): Adjust for renamed tarball. [arguments]: Remove #:test-target. Adjust disabled tests. Don't override install phase.
This commit is contained in:
parent
ceb831d338
commit
e02671939b
|
@ -627,8 +627,6 @@ dist_patch_DATA = \
|
||||||
%D%/packages/patches/a2ps-CVE-2014-0466.patch \
|
%D%/packages/patches/a2ps-CVE-2014-0466.patch \
|
||||||
%D%/packages/patches/abiword-explictly-cast-bools.patch \
|
%D%/packages/patches/abiword-explictly-cast-bools.patch \
|
||||||
%D%/packages/patches/abiword-black-drawing-with-gtk322.patch \
|
%D%/packages/patches/abiword-black-drawing-with-gtk322.patch \
|
||||||
%D%/packages/patches/acl-fix-perl-regex.patch \
|
|
||||||
%D%/packages/patches/acl-hurd-path-max.patch \
|
|
||||||
%D%/packages/patches/adb-add-libraries.patch \
|
%D%/packages/patches/adb-add-libraries.patch \
|
||||||
%D%/packages/patches/aegis-constness-error.patch \
|
%D%/packages/patches/aegis-constness-error.patch \
|
||||||
%D%/packages/patches/aegis-perl-tempdir1.patch \
|
%D%/packages/patches/aegis-perl-tempdir1.patch \
|
||||||
|
|
|
@ -4,6 +4,7 @@
|
||||||
;;; Copyright © 2014 Andreas Enge <andreas@enge.fr>
|
;;; Copyright © 2014 Andreas Enge <andreas@enge.fr>
|
||||||
;;; Copyright © 2017 Efraim Flashner <efraim@flashner.co.il>
|
;;; Copyright © 2017 Efraim Flashner <efraim@flashner.co.il>
|
||||||
;;; Copyright © 2018 Ricardo Wurmus <rekado@elephly.net>
|
;;; Copyright © 2018 Ricardo Wurmus <rekado@elephly.net>
|
||||||
|
;;; Copyright © 2019 Marius Bakke <mbakke@fastmail.com>
|
||||||
;;;
|
;;;
|
||||||
;;; This file is part of GNU Guix.
|
;;; This file is part of GNU Guix.
|
||||||
;;;
|
;;;
|
||||||
|
@ -34,21 +35,18 @@
|
||||||
(define-public acl
|
(define-public acl
|
||||||
(package
|
(package
|
||||||
(name "acl")
|
(name "acl")
|
||||||
(version "2.2.52")
|
(version "2.2.53")
|
||||||
(source
|
(source
|
||||||
(origin
|
(origin
|
||||||
(method url-fetch)
|
(method url-fetch)
|
||||||
(uri (string-append "mirror://savannah/acl/acl-"
|
(uri (string-append "mirror://savannah/acl/acl-"
|
||||||
version ".src.tar.gz"))
|
version ".tar.gz"))
|
||||||
(sha256
|
(sha256
|
||||||
(base32
|
(base32
|
||||||
"08qd9s3wfhv0ajswsylnfwr5h0d7j9d4rgip855nrh400nxp940p"))
|
"1ir6my3w74s6nfbgbqgzj6w570sn0qjf3524zx8xh67lqrjrigh6"))))
|
||||||
(patches (search-patches "acl-fix-perl-regex.patch"
|
|
||||||
"acl-hurd-path-max.patch"))))
|
|
||||||
(build-system gnu-build-system)
|
(build-system gnu-build-system)
|
||||||
(arguments
|
(arguments
|
||||||
`(#:test-target "tests"
|
`(#:modules ((ice-9 ftw)
|
||||||
#:modules ((ice-9 ftw)
|
|
||||||
,@%gnu-build-system-modules)
|
,@%gnu-build-system-modules)
|
||||||
#:phases
|
#:phases
|
||||||
(modify-phases %standard-phases
|
(modify-phases %standard-phases
|
||||||
|
@ -75,13 +73,11 @@
|
||||||
(("\\| sed.*'") ""))
|
(("\\| sed.*'") ""))
|
||||||
;; These tests require the existence of a user named "bin", but
|
;; These tests require the existence of a user named "bin", but
|
||||||
;; this user does not exist within Guix's build environment.
|
;; this user does not exist within Guix's build environment.
|
||||||
(for-each (lambda (file)
|
(substitute* "Makefile.in"
|
||||||
(delete-file (string-append "test/" file)))
|
((".*test/misc\\.test.*") "")
|
||||||
'("setfacl-X.test" "cp.test" "misc.test"))
|
((".*test/cp\\.test.*") "")
|
||||||
#t))
|
((".*test/setfacl-X\\.test.*") ""))
|
||||||
(replace 'install
|
#t)))))
|
||||||
(lambda _
|
|
||||||
(invoke "make" "install" "install-lib" "install-dev"))))))
|
|
||||||
(inputs `(("attr" ,attr)))
|
(inputs `(("attr" ,attr)))
|
||||||
(native-inputs
|
(native-inputs
|
||||||
`(("gettext" ,gettext-minimal)
|
`(("gettext" ,gettext-minimal)
|
||||||
|
|
|
@ -1,22 +0,0 @@
|
||||||
This can be removed with the next acl release
|
|
||||||
|
|
||||||
---
|
|
||||||
test/run | 2 +-
|
|
||||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
||||||
|
|
||||||
diff --git a/test/run b/test/run
|
|
||||||
index 2cf52e8..4627cd2 100755
|
|
||||||
--- a/test/run
|
|
||||||
+++ b/test/run
|
|
||||||
@@ -70,7 +70,7 @@ for (;;) {
|
|
||||||
if (defined $line) {
|
|
||||||
# Substitute %VAR and %{VAR} with environment variables.
|
|
||||||
$line =~ s[%(\w+)][$ENV{$1}]eg;
|
|
||||||
- $line =~ s[%{(\w+)}][$ENV{$1}]eg;
|
|
||||||
+ $line =~ s[%\{(\w+)\}][$ENV{$1}]eg;
|
|
||||||
}
|
|
||||||
if (defined $line) {
|
|
||||||
if ($line =~ s/^\s*< ?//) {
|
|
||||||
--
|
|
||||||
2.15.0
|
|
||||||
|
|
|
@ -1,80 +0,0 @@
|
||||||
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=636512
|
|
||||||
|
|
||||||
From: Svante Signell <srs@kth.se>
|
|
||||||
Subject: acl: Fix FTBFS on hurd-i386
|
|
||||||
Date: Wed, 03 Aug 2011 19:36:27 +0200
|
|
||||||
|
|
||||||
Currently acl does not compile on hurd-i386. The problem is a PATH_MAX
|
|
||||||
definition which is not supported on GNU/Hurd.
|
|
||||||
|
|
||||||
Index: acl-2.2.52/setfacl/parse.c
|
|
||||||
===================================================================
|
|
||||||
--- acl-2.2.52/setfacl/parse.c
|
|
||||||
+++ acl-2.2.52/setfacl/parse.c
|
|
||||||
@@ -419,7 +419,13 @@ read_acl_comments(
|
|
||||||
bytes for "# file: ". Not a good solution but for now it is the
|
|
||||||
best I can do without too much impact on the code. [tw]
|
|
||||||
*/
|
|
||||||
+
|
|
||||||
+#ifdef __GNU__
|
|
||||||
+ char *linebuf;
|
|
||||||
+ size_t dummy = 0;
|
|
||||||
+#else
|
|
||||||
char linebuf[(4*PATH_MAX)+9];
|
|
||||||
+#endif
|
|
||||||
char *cp;
|
|
||||||
char *p;
|
|
||||||
int comments_read = 0;
|
|
||||||
@@ -449,9 +455,13 @@ read_acl_comments(
|
|
||||||
if (line)
|
|
||||||
(*line)++;
|
|
||||||
|
|
||||||
+#ifdef __GNU__
|
|
||||||
+ if (getline(&linebuf, &dummy, file) == -1)
|
|
||||||
+ break;
|
|
||||||
+#else
|
|
||||||
if (fgets(linebuf, sizeof(linebuf), file) == NULL)
|
|
||||||
break;
|
|
||||||
-
|
|
||||||
+#endif
|
|
||||||
comments_read = 1;
|
|
||||||
|
|
||||||
p = strrchr(linebuf, '\0');
|
|
||||||
@@ -473,7 +483,12 @@ read_acl_comments(
|
|
||||||
goto fail;
|
|
||||||
*path_p = (char*)malloc(strlen(cp)+1);
|
|
||||||
if (!*path_p)
|
|
||||||
+ {
|
|
||||||
+#ifdef __GNU__
|
|
||||||
+ free (linebuf);
|
|
||||||
+#endif
|
|
||||||
return -1;
|
|
||||||
+ }
|
|
||||||
strcpy(*path_p, cp);
|
|
||||||
}
|
|
||||||
} else if (strncmp(cp, "owner:", 6) == 0) {
|
|
||||||
@@ -522,13 +537,24 @@ read_acl_comments(
|
|
||||||
}
|
|
||||||
}
|
|
||||||
if (ferror(file))
|
|
||||||
+ {
|
|
||||||
+#ifdef __GNU__
|
|
||||||
+ free (linebuf);
|
|
||||||
+#endif
|
|
||||||
return -1;
|
|
||||||
+ }
|
|
||||||
+#ifdef __GNU__
|
|
||||||
+ free (linebuf);
|
|
||||||
+#endif
|
|
||||||
return comments_read;
|
|
||||||
fail:
|
|
||||||
if (path_p && *path_p) {
|
|
||||||
free(*path_p);
|
|
||||||
*path_p = NULL;
|
|
||||||
}
|
|
||||||
+#ifdef __GNU__
|
|
||||||
+ free (linebuf);
|
|
||||||
+#endif
|
|
||||||
return -EINVAL;
|
|
||||||
}
|
|
||||||
|
|
Loading…
Reference in New Issue