gnu: mesa: Update to 18.0.4.
* gnu/packages/gl.scm (mesa): Update to 18.0.4. [source]: Remove mesa-wayland-egl-symbols-check-mips.patch. [arguments]: Remove wayland from --with-platforms configure flag. * gnu/local.mk: Remove mesa-wayland-egl-symbols-check-mips.patch. * gnu/packages/patches/mesa-wayland-egl-symbols-check-mips.patch: Remove file.
This commit is contained in:
parent
6069bb0ab4
commit
e0c9aed820
|
@ -914,7 +914,6 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/mcrypt-CVE-2012-4426.patch \
|
||||
%D%/packages/patches/mcrypt-CVE-2012-4527.patch \
|
||||
%D%/packages/patches/mesa-skip-disk-cache-test.patch \
|
||||
%D%/packages/patches/mesa-wayland-egl-symbols-check-mips.patch \
|
||||
%D%/packages/patches/meson-for-build-rpath.patch \
|
||||
%D%/packages/patches/metabat-fix-compilation.patch \
|
||||
%D%/packages/patches/mhash-keygen-test-segfault.patch \
|
||||
|
|
|
@ -222,7 +222,7 @@ also known as DXTn or DXTC) for Mesa.")
|
|||
(define-public mesa
|
||||
(package
|
||||
(name "mesa")
|
||||
(version "18.0.2")
|
||||
(version "18.0.4")
|
||||
(source
|
||||
(origin
|
||||
(method url-fetch)
|
||||
|
@ -234,10 +234,9 @@ also known as DXTn or DXTC) for Mesa.")
|
|||
version "/mesa-" version ".tar.xz")))
|
||||
(sha256
|
||||
(base32
|
||||
"1cz7p4b4yy201djzv3s28zx27f5cqwv0zgzqp5lcaba8d2bibylq"))
|
||||
"03wjlb5qy1mn8d6zm0q1pq35x60agrfxyh9bmq6w59ghrvkwyfqz"))
|
||||
(patches
|
||||
(search-patches "mesa-wayland-egl-symbols-check-mips.patch"
|
||||
"mesa-skip-disk-cache-test.patch"))))
|
||||
(search-patches "mesa-skip-disk-cache-test.patch"))))
|
||||
(build-system gnu-build-system)
|
||||
(propagated-inputs
|
||||
`(("glproto" ,glproto)
|
||||
|
@ -285,7 +284,7 @@ also known as DXTn or DXTC) for Mesa.")
|
|||
'("--with-gallium-drivers=i915,nouveau,r300,r600,radeonsi,svga,swrast,virgl")))
|
||||
;; Enable various optional features. TODO: opencl requires libclc,
|
||||
;; omx requires libomxil-bellagio
|
||||
"--with-platforms=x11,drm,wayland,surfaceless"
|
||||
"--with-platforms=x11,drm,surfaceless"
|
||||
"--enable-glx-tls" ;Thread Local Storage, improves performance
|
||||
;; "--enable-opencl"
|
||||
;; "--enable-omx"
|
||||
|
|
|
@ -1,15 +0,0 @@
|
|||
Fix 'wayland-egl-symbols-check' on mips64el-linux, where an additional symbol
|
||||
(_ftext) is present in libwayland-egl.so.
|
||||
|
||||
Patch by Mark H Weaver <mhw@netris.org>
|
||||
|
||||
--- mesa-12.0.1/src/egl/wayland/wayland-egl/wayland-egl-symbols-check.orig 2016-01-18 02:39:25.000000000 -0500
|
||||
+++ mesa-12.0.1/src/egl/wayland/wayland-egl/wayland-egl-symbols-check 2016-10-24 16:25:07.110721426 -0400
|
||||
@@ -7,6 +7,7 @@
|
||||
wl_egl_window_destroy
|
||||
wl_egl_window_get_attached_size
|
||||
_fini
|
||||
+_ftext
|
||||
_init
|
||||
EOF
|
||||
done)
|
Loading…
Reference in New Issue