gnu: libtool: Add 2.4.4.
* gnu/packages/patches/libtool-2.4-skip-tests.patch: New file. * gnu-system.am (dist_patch_DATA): Add it. * gnu/packages/autotools.scm (libtool-2.4.4): New variable.
This commit is contained in:
parent
4b2fd119be
commit
e13f715be0
|
@ -1,5 +1,5 @@
|
|||
# GNU Guix --- Functional package management for GNU
|
||||
# Copyright © 2012, 2013, 2014 Ludovic Courtès <ludo@gnu.org>
|
||||
# Copyright © 2012, 2013, 2014, 2015 Ludovic Courtès <ludo@gnu.org>
|
||||
# Copyright © 2013, 2014 Andreas Enge <andreas@enge.fr>
|
||||
# Copyright © 2013, 2014 Mark H Weaver <mhw@netris.org>
|
||||
#
|
||||
|
@ -406,6 +406,7 @@ dist_patch_DATA = \
|
|||
gnu/packages/patches/libtheora-config-guess.patch \
|
||||
gnu/packages/patches/libtool-skip-tests.patch \
|
||||
gnu/packages/patches/libtool-skip-tests-for-mips.patch \
|
||||
gnu/packages/patches/libtool-2.4-skip-tests.patch \
|
||||
gnu/packages/patches/libssh-CVE-2014-0017.patch \
|
||||
gnu/packages/patches/lm-sensors-hwmon-attrs.patch \
|
||||
gnu/packages/patches/luit-posix.patch \
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
;;; GNU Guix --- Functional package management for GNU
|
||||
;;; Copyright © 2012 Nikita Karetnikov <nikita@karetnikov.org>
|
||||
;;; Copyright © 2012, 2013, 2014 Ludovic Courtès <ludo@gnu.org>
|
||||
;;; Copyright © 2012, 2013, 2014, 2015 Ludovic Courtès <ludo@gnu.org>
|
||||
;;; Copyright © 2014 Manolis Fragkiskos Ragkousis <manolis837@gmail.com>
|
||||
;;;
|
||||
;;; This file is part of GNU Guix.
|
||||
|
@ -291,3 +291,20 @@ presenting a single consistent, portable interface that hides the usual
|
|||
complexity of working with shared libraries across platforms.")
|
||||
(license gpl3+)
|
||||
(home-page "http://www.gnu.org/software/libtool/")))
|
||||
|
||||
(define-public libtool-2.4.4
|
||||
(package (inherit libtool)
|
||||
(version "2.4.4")
|
||||
(source (origin
|
||||
(method url-fetch)
|
||||
(uri (string-append "mirror://gnu/libtool/libtool-"
|
||||
version ".tar.xz"))
|
||||
(sha256
|
||||
(base32
|
||||
"0v3zq08qxv7k5067mpqrkjkjl3wphhg06i696mka90mzadc5nad8"))
|
||||
(patches
|
||||
(list (search-patch "libtool-2.4-skip-tests.patch")))))
|
||||
|
||||
(native-inputs `(("automake" ,automake) ;some tests rely on 'aclocal'
|
||||
("autoconf" ,(autoconf-wrapper)) ;others on 'autom4te'
|
||||
,@(package-native-inputs libtool)))))
|
||||
|
|
|
@ -0,0 +1,24 @@
|
|||
Because our GCC 'lib' spec automatically adds '-rpath' for each '-L'
|
||||
and a couple more '-rpath, there are two test failures:
|
||||
one in demo.test, and one in destdir.at. Disable these.
|
||||
|
||||
--- libtool-2.4.4/tests/testsuite 2014-11-29 17:43:11.000000000 +0100
|
||||
+++ libtool-2.4.4/tests/testsuite 2015-01-03 23:00:09.367775122 +0100
|
||||
@@ -9185,7 +9185,7 @@ read at_status <"$at_status_file"
|
||||
#AT_START_33
|
||||
at_fn_group_banner 33 'demo.at:548' \
|
||||
"hardcoding library path" " " 3
|
||||
-at_xfail=no
|
||||
+at_xfail=yes
|
||||
test no = "$ACLOCAL" && at_xfail=yes
|
||||
test no = "$AUTOHEADER" && at_xfail=yes
|
||||
test no = "$AUTOMAKE" && at_xfail=yes
|
||||
@@ -27052,7 +27052,7 @@ read at_status <"$at_status_file"
|
||||
#AT_START_97
|
||||
at_fn_group_banner 97 'destdir.at:75' \
|
||||
"DESTDIR with in-package deplibs" " " 7
|
||||
-at_xfail=no
|
||||
+at_xfail=yes
|
||||
eval `$LIBTOOL --config | $GREP '^fast_install='`
|
||||
case $fast_install in no) :;; *) false;; esac && at_xfail=yes
|
||||
(
|
Loading…
Reference in New Issue