gnu: qemu: Upgrade to 1.7.1; add virtfs support.
* gnu/packages/qemu.scm (qemu-headless): Upgrade to 1.7.1. [source]: Remove 'patches' field. [arguments]: Add --enable-virtfs configure flag. [inputs]: Add libcap and attr. * gnu/packages/patches/qemu-make-4.0.patch: Remove. * gnu-system.am (dist_patch_DATA): Adjust accordingly.
This commit is contained in:
parent
57e544e8f7
commit
e1f88ff0ab
|
@ -319,7 +319,6 @@ dist_patch_DATA = \
|
||||||
gnu/packages/patches/procps-make-3.82.patch \
|
gnu/packages/patches/procps-make-3.82.patch \
|
||||||
gnu/packages/patches/python-fix-tests.patch \
|
gnu/packages/patches/python-fix-tests.patch \
|
||||||
gnu/packages/patches/python-libffi-mips-n32-fix.patch \
|
gnu/packages/patches/python-libffi-mips-n32-fix.patch \
|
||||||
gnu/packages/patches/qemu-make-4.0.patch \
|
|
||||||
gnu/packages/patches/qemu-multiple-smb-shares.patch \
|
gnu/packages/patches/qemu-multiple-smb-shares.patch \
|
||||||
gnu/packages/patches/qt4-tests.patch \
|
gnu/packages/patches/qt4-tests.patch \
|
||||||
gnu/packages/patches/ratpoison-shell.patch \
|
gnu/packages/patches/ratpoison-shell.patch \
|
||||||
|
|
|
@ -1,32 +0,0 @@
|
||||||
Allow compilation with GNU Make 4.0.
|
|
||||||
Patch from <http://lists.gnu.org/archive/html/qemu-devel/2013-10/msg02758.html>.
|
|
||||||
Anaylsis at <http://lists.gnu.org/archive/html/bug-make/2013-10/msg00151.html>.
|
|
||||||
|
|
||||||
--- a/configure
|
|
||||||
+++ b/configure
|
|
||||||
@@ -308,6 +308,9 @@ query_pkg_config() {
|
|
||||||
pkg_config=query_pkg_config
|
|
||||||
sdl_config="${SDL_CONFIG-${cross_prefix}sdl-config}"
|
|
||||||
|
|
||||||
+# If the user hasn't specified ARFLAGS, default to 'rv', just as make does.
|
|
||||||
+ARFLAGS="${ARFLAGS-rv}"
|
|
||||||
+
|
|
||||||
# default flags for all hosts
|
|
||||||
QEMU_CFLAGS="-fno-strict-aliasing $QEMU_CFLAGS"
|
|
||||||
QEMU_CFLAGS="-Wall -Wundef -Wwrite-strings -Wmissing-prototypes $QEMU_CFLAGS"
|
|
||||||
@@ -3664,6 +3667,7 @@ echo "C compiler $cc"
|
|
||||||
echo "Host C compiler $host_cc"
|
|
||||||
echo "C++ compiler $cxx"
|
|
||||||
echo "Objective-C compiler $objcc"
|
|
||||||
+echo "ARFLAGS $ARFLAGS"
|
|
||||||
echo "CFLAGS $CFLAGS"
|
|
||||||
echo "QEMU_CFLAGS $QEMU_CFLAGS"
|
|
||||||
echo "LDFLAGS $LDFLAGS"
|
|
||||||
@@ -4239,6 +4243,7 @@ echo "HOST_CC=$host_cc" >> $config_host_mak
|
|
||||||
echo "CXX=$cxx" >> $config_host_mak
|
|
||||||
echo "OBJCC=$objcc" >> $config_host_mak
|
|
||||||
echo "AR=$ar" >> $config_host_mak
|
|
||||||
+echo "ARFLAGS=$ARFLAGS" >> $config_host_mak
|
|
||||||
echo "AS=$as" >> $config_host_mak
|
|
||||||
echo "CPP=$cpp" >> $config_host_mak
|
|
||||||
echo "OBJCOPY=$objcopy" >> $config_host_mak
|
|
|
@ -44,15 +44,14 @@
|
||||||
;; This is QEMU without GUI support.
|
;; This is QEMU without GUI support.
|
||||||
(package
|
(package
|
||||||
(name "qemu-headless")
|
(name "qemu-headless")
|
||||||
(version "1.6.1")
|
(version "1.7.1")
|
||||||
(source (origin
|
(source (origin
|
||||||
(method url-fetch)
|
(method url-fetch)
|
||||||
(uri (string-append "http://wiki.qemu-project.org/download/qemu-"
|
(uri (string-append "http://wiki.qemu-project.org/download/qemu-"
|
||||||
version ".tar.bz2"))
|
version ".tar.bz2"))
|
||||||
(sha256
|
(sha256
|
||||||
(base32
|
(base32
|
||||||
"152jc18mjs543k8ggbcwgra8d0zw81z0lcc1r0iq4iqhm926ywzw"))
|
"1x5y06zhp0gc97g1sb98vf7dkawg63xywv0mbnpfnbi20jh452fn"))))
|
||||||
(patches (list (search-patch "qemu-make-4.0.patch")))))
|
|
||||||
(build-system gnu-build-system)
|
(build-system gnu-build-system)
|
||||||
(arguments
|
(arguments
|
||||||
'(#:phases (alist-replace
|
'(#:phases (alist-replace
|
||||||
|
@ -74,6 +73,7 @@
|
||||||
(system* "./configure"
|
(system* "./configure"
|
||||||
(string-append "--cc=" (which "gcc"))
|
(string-append "--cc=" (which "gcc"))
|
||||||
"--disable-debug-info" ; save build space
|
"--disable-debug-info" ; save build space
|
||||||
|
"--enable-virtfs" ; just to be sure
|
||||||
(string-append "--prefix=" out)
|
(string-append "--prefix=" out)
|
||||||
(string-append "--smbd=" samba
|
(string-append "--smbd=" samba
|
||||||
"/sbin/smbd")))))
|
"/sbin/smbd")))))
|
||||||
|
@ -103,6 +103,8 @@
|
||||||
("pixman" ,pixman)
|
("pixman" ,pixman)
|
||||||
;; ("vde2" ,vde2)
|
;; ("vde2" ,vde2)
|
||||||
("util-linux" ,util-linux)
|
("util-linux" ,util-linux)
|
||||||
|
("libcap" ,libcap) ; virtfs support requires libcap & libattr
|
||||||
|
("libattr" ,attr)
|
||||||
;; ("pciutils" ,pciutils)
|
;; ("pciutils" ,pciutils)
|
||||||
("alsa-lib" ,alsa-lib)
|
("alsa-lib" ,alsa-lib)
|
||||||
("zlib" ,zlib)
|
("zlib" ,zlib)
|
||||||
|
|
Loading…
Reference in New Issue