gnu: glibc-locales: Update to glibc 2.22.
* gnu/packages/base.scm (glibc-locales)[arguments]: Remove 'delete-file-recursively' call from 'build' phase. * gnu/packages/patches/glibc-locales.patch: Adjust to glibc 2.22.
This commit is contained in:
parent
c3aeac385a
commit
e2aace769c
|
@ -640,10 +640,6 @@ the 'share/locale' sub-directory of this package.")
|
||||||
`(alist-replace
|
`(alist-replace
|
||||||
'build
|
'build
|
||||||
(lambda* (#:key outputs #:allow-other-keys)
|
(lambda* (#:key outputs #:allow-other-keys)
|
||||||
(let ((out (assoc-ref outputs "out")))
|
|
||||||
;; Delete $out/bin, which contains 'bash'.
|
|
||||||
(delete-file-recursively (string-append out "/bin")))
|
|
||||||
|
|
||||||
(zero? (system* "make" "localedata/install-locales"
|
(zero? (system* "make" "localedata/install-locales"
|
||||||
"-j" (number->string (parallel-job-count)))))
|
"-j" (number->string (parallel-job-count)))))
|
||||||
(alist-delete 'install ,phases)))
|
(alist-delete 'install ,phases)))
|
||||||
|
|
|
@ -9,9 +9,9 @@ in a package separate from glibc.
|
||||||
because otherwise, 'localedef' fails with:
|
because otherwise, 'localedef' fails with:
|
||||||
"cannot write output files to `(null)'".
|
"cannot write output files to `(null)'".
|
||||||
|
|
||||||
--- glibc-2.20/localedata/Makefile 2014-09-07 10:09:09.000000000 +0200
|
--- glibc-2.22/localedata/Makefile 1970-01-01 01:00:00.000000000 +0100
|
||||||
+++ glibc-2.20/localedata/Makefile 2015-02-11 10:23:55.560545568 +0100
|
+++ glibc-2.22/localedata/Makefile 2015-09-25 14:18:34.698941752 +0200
|
||||||
@@ -217,7 +217,7 @@ INSTALL-SUPPORTED-LOCALES=$(addprefix in
|
@@ -195,7 +195,7 @@ INSTALL-SUPPORTED-LOCALES=$(addprefix in
|
||||||
|
|
||||||
# Sometimes the whole collection of locale files should be installed.
|
# Sometimes the whole collection of locale files should be installed.
|
||||||
LOCALEDEF=I18NPATH=. GCONV_PATH=$(common-objpfx)iconvdata LC_ALL=C \
|
LOCALEDEF=I18NPATH=. GCONV_PATH=$(common-objpfx)iconvdata LC_ALL=C \
|
||||||
|
@ -20,12 +20,12 @@ in a package separate from glibc.
|
||||||
install-locales: $(INSTALL-SUPPORTED-LOCALES)
|
install-locales: $(INSTALL-SUPPORTED-LOCALES)
|
||||||
|
|
||||||
install-locales-dir:
|
install-locales-dir:
|
||||||
@@ -234,7 +234,7 @@ $(INSTALL-SUPPORTED-LOCALES): install-lo
|
@@ -212,7 +212,7 @@ $(INSTALL-SUPPORTED-LOCALES): install-lo
|
||||||
input=`echo $$locale | sed 's/\([^.]*\)[^@]*\(.*\)/\1\2/'`; \
|
input=`echo $$locale | sed 's/\([^.]*\)[^@]*\(.*\)/\1\2/'`; \
|
||||||
$(LOCALEDEF) --alias-file=../intl/locale.alias \
|
$(LOCALEDEF) --alias-file=../intl/locale.alias \
|
||||||
-i locales/$$input -c -f charmaps/$$charset \
|
-i locales/$$input -c -f charmaps/$$charset \
|
||||||
- $(addprefix --prefix=,$(install_root)) $$locale; \
|
- $(addprefix --prefix=,$(install_root)) $$locale \
|
||||||
+ $(addprefix --prefix=,$(install_root)) $(localedir)/$$locale; \
|
+ $(addprefix --prefix=,$(install_root)) $(localedir)/$$locale \
|
||||||
echo ' done'; \
|
&& echo ' done'; \
|
||||||
|
|
||||||
tst-setlocale-ENV = LC_ALL=ja_JP.EUC-JP
|
tst-setlocale-ENV = LC_ALL=ja_JP.EUC-JP
|
||||||
|
|
Loading…
Reference in New Issue