gnu: totem: Fix build on i686.
* gnu/packages/patches/totem-debug-format-fix.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/gnome.scm (totem)[source]: Add patch.
This commit is contained in:
parent
4e823eae64
commit
e2b89203db
|
@ -754,6 +754,7 @@ dist_patch_DATA = \
|
|||
gnu/packages/patches/ttfautohint-source-date-epoch.patch \
|
||||
gnu/packages/patches/tophat-build-with-later-seqan.patch \
|
||||
gnu/packages/patches/torsocks-dns-test.patch \
|
||||
gnu/packages/patches/totem-debug-format-fix.patch \
|
||||
gnu/packages/patches/unzip-CVE-2014-8139.patch \
|
||||
gnu/packages/patches/unzip-CVE-2014-8140.patch \
|
||||
gnu/packages/patches/unzip-CVE-2014-8141.patch \
|
||||
|
|
|
@ -3095,7 +3095,8 @@ for application developers.")
|
|||
name "-" version ".tar.xz"))
|
||||
(sha256
|
||||
(base32
|
||||
"09swnhp46cyy2svqx02fzy555pjgc61lyjw56v9rz1mfc41lh8kg"))))
|
||||
"09swnhp46cyy2svqx02fzy555pjgc61lyjw56v9rz1mfc41lh8kg"))
|
||||
(patches (search-patches "totem-debug-format-fix.patch"))))
|
||||
(build-system glib-or-gtk-build-system)
|
||||
(native-inputs
|
||||
`(("pkg-config" ,pkg-config)
|
||||
|
|
|
@ -0,0 +1,11 @@
|
|||
--- totem-3.20.1/src/backend/bacon-video-widget.c.orig 2016-03-22 12:45:32.000000000 -0400
|
||||
+++ totem-3.20.1/src/backend/bacon-video-widget.c 2016-05-11 02:49:55.299109551 -0400
|
||||
@@ -2334,7 +2334,7 @@
|
||||
if (!gst_toc_entry_get_start_stop_times (entry, &start, &stop)) {
|
||||
GST_DEBUG ("Chapter #%d (couldn't get times)", i);
|
||||
} else {
|
||||
- GST_DEBUG ("Chapter #%d (start: %li stop: %li)", i, start, stop);
|
||||
+ GST_DEBUG ("Chapter #%d (start: %li stop: %li)", i, (long) start, (long) stop);
|
||||
}
|
||||
}
|
||||
|
Loading…
Reference in New Issue