gnu: python-cython: Update to 0.26.
* gnu/packages/python.scm (python-cython, python2-cython): Update to 0.26. [source]: Remove patch. * gnu/packages/patches/python-cython-fix-tests-32bit.patch: Remove file. * gnu/local.mk (dist_patch_DATA): Remove it.
This commit is contained in:
parent
d6ef422fe7
commit
e3b861ce38
|
@ -975,7 +975,6 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/python2-rdflib-drop-sparqlwrapper.patch \
|
||||
%D%/packages/patches/python-statsmodels-fix-tests.patch \
|
||||
%D%/packages/patches/python-configobj-setuptools.patch \
|
||||
%D%/packages/patches/python-cython-fix-tests-32bit.patch \
|
||||
%D%/packages/patches/python-faker-fix-build-32bit.patch \
|
||||
%D%/packages/patches/python-pandas-skip-failing-tests.patch \
|
||||
%D%/packages/patches/python-paste-remove-website-test.patch \
|
||||
|
|
|
@ -1,27 +0,0 @@
|
|||
This fixes a test failure on 32-bit platforms.
|
||||
|
||||
Upstream bug URL: https://github.com/cython/cython/issues/1548
|
||||
|
||||
Patch copied from upstream source repository:
|
||||
|
||||
https://github.com/cython/cython/commit/d92a718a26c9354fbf35f31a17de5c069865a447
|
||||
|
||||
From d92a718a26c9354fbf35f31a17de5c069865a447 Mon Sep 17 00:00:00 2001
|
||||
From: Robert Bradshaw <robertwb@gmail.com>
|
||||
Date: Tue, 24 Jan 2017 16:57:00 -0800
|
||||
Subject: [PATCH] Normalize possible L suffix.
|
||||
|
||||
---
|
||||
tests/run/cpdef_enums.pyx | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/tests/run/cpdef_enums.pyx b/tests/run/cpdef_enums.pyx
|
||||
index 167c762..c264ec5 100644
|
||||
--- a/tests/run/cpdef_enums.pyx
|
||||
+++ b/tests/run/cpdef_enums.pyx
|
||||
@@ -93,4 +93,4 @@ def verify_resolution_GH1533():
|
||||
3
|
||||
"""
|
||||
THREE = 100
|
||||
- return PyxEnum.THREE
|
||||
+ return int(PyxEnum.THREE)
|
|
@ -3607,15 +3607,14 @@ is designed to have a low barrier to entry.")
|
|||
(define-public python-cython
|
||||
(package
|
||||
(name "python-cython")
|
||||
(version "0.25.2")
|
||||
(version "0.26")
|
||||
(source
|
||||
(origin
|
||||
(method url-fetch)
|
||||
(uri (pypi-uri "Cython" version))
|
||||
(patches (search-patches "python-cython-fix-tests-32bit.patch"))
|
||||
(sha256
|
||||
(base32
|
||||
"01h3lrf6d98j07iakifi81qjszh6faa37ibx7ylva1vsqbwx2hgi"))))
|
||||
"0riciynnr0r68cvg6r3gbhi9x7h44pdwb7926m6n5vfs5p1f492c"))))
|
||||
(build-system python-build-system)
|
||||
;; we need the full python package and not just the python-wrapper
|
||||
;; because we need libpython3.3m.so
|
||||
|
@ -3626,7 +3625,7 @@ is designed to have a low barrier to entry.")
|
|||
(modify-phases %standard-phases
|
||||
(add-before 'check 'set-HOME
|
||||
;; some tests require access to "$HOME/.cython"
|
||||
(lambda _ (setenv "HOME" "/tmp")))
|
||||
(lambda _ (setenv "HOME" "/tmp") #t))
|
||||
(replace 'check
|
||||
(lambda _ (zero? (system* "python" "runtests.py" "-vv")))))))
|
||||
(home-page "http://cython.org/")
|
||||
|
|
Loading…
Reference in New Issue