gnu: libotr: Fix tests on mips64el.

* gnu/packages/patches/libotr-test-auth-fix.patch: New file.
* gnu-system.am (dist_patch_DATA): Add it.
* gnu/packages/messaging.scm (libotr)[source]: Add patch.
master
Mark H Weaver 2016-03-17 19:03:15 -04:00
parent b879b3e848
commit e3d3546eda
3 changed files with 19 additions and 1 deletions

View File

@ -582,6 +582,7 @@ dist_patch_DATA = \
gnu/packages/patches/libevent-dns-tests.patch \
gnu/packages/patches/libmtp-devices.patch \
gnu/packages/patches/liboop-mips64-deplibs-fix.patch \
gnu/packages/patches/libotr-test-auth-fix.patch \
gnu/packages/patches/liblxqt-include.patch \
gnu/packages/patches/libmad-armv7-thumb-pt1.patch \
gnu/packages/patches/libmad-armv7-thumb-pt2.patch \

View File

@ -70,7 +70,9 @@
version ".tar.gz"))
(sha256
(base32
"1x8rliydhbibmzwdbyr7pd7n87m2jmxnqkpvaalnf4154hj1hfwb"))))
"1x8rliydhbibmzwdbyr7pd7n87m2jmxnqkpvaalnf4154hj1hfwb"))
(patches
(list (search-patch "libotr-test-auth-fix.patch")))))
(build-system gnu-build-system)
(propagated-inputs
`(("libgcrypt" ,libgcrypt))) ; libotr headers include gcrypt.h

View File

@ -0,0 +1,15 @@
Initialize the context in 'test_auth_clear'.
Fixes the test suite on mips64el.
Patch by Mark H Weaver <mhw@netris.org>
--- libotr-4.1.1/tests/unit/test_auth.c.orig 2015-12-25 12:39:45.000000000 -0500
+++ libotr-4.1.1/tests/unit/test_auth.c 2016-03-17 18:53:10.169999706 -0400
@@ -67,6 +67,7 @@
OtrlAuthInfo *auth = &ctx.auth;
/* API call. */
+ otrl_auth_new(&ctx);
otrl_auth_clear(auth);
ok(auth->authstate == OTRL_AUTHSTATE_NONE &&