gnu: libtasn1: Add replacement to fix CVE-2017-10790.
Based on commit 01a61d7040
by Leo Famulari <leo@famulari.name>.
* gnu/packages/patches/libtasn1-CVE-2017-10790.patch: New file.
* gnu/local.mk (dist_patch_DATA): Add it.
* gnu/packages/tls.scm (libtasn1)[replacement]: New field.
(libtasn1/fixed): New variable.
This commit is contained in:
parent
a56bf101c6
commit
e3df6938ac
|
@ -2,7 +2,7 @@
|
||||||
# Copyright © 2012, 2013, 2014, 2015, 2016, 2017 Ludovic Courtès <ludo@gnu.org>
|
# Copyright © 2012, 2013, 2014, 2015, 2016, 2017 Ludovic Courtès <ludo@gnu.org>
|
||||||
# Copyright © 2013, 2014, 2015, 2016, 2017 Andreas Enge <andreas@enge.fr>
|
# Copyright © 2013, 2014, 2015, 2016, 2017 Andreas Enge <andreas@enge.fr>
|
||||||
# Copyright © 2016 Mathieu Lirzin <mthl@gnu.org>
|
# Copyright © 2016 Mathieu Lirzin <mthl@gnu.org>
|
||||||
# Copyright © 2013, 2014, 2015, 2016 Mark H Weaver <mhw@netris.org>
|
# Copyright © 2013, 2014, 2015, 2016, 2017 Mark H Weaver <mhw@netris.org>
|
||||||
# Copyright © 2016 Chris Marusich <cmmarusich@gmail.com>
|
# Copyright © 2016 Chris Marusich <cmmarusich@gmail.com>
|
||||||
# Copyright © 2016, 2017 Kei Kebreau <kei@openmailbox.org>
|
# Copyright © 2016, 2017 Kei Kebreau <kei@openmailbox.org>
|
||||||
# Copyright © 2016, 2017 Rene Saavedra <rennes@openmailbox.org>
|
# Copyright © 2016, 2017 Rene Saavedra <rennes@openmailbox.org>
|
||||||
|
@ -767,6 +767,7 @@ dist_patch_DATA = \
|
||||||
%D%/packages/patches/libssh-hostname-parser-bug.patch \
|
%D%/packages/patches/libssh-hostname-parser-bug.patch \
|
||||||
%D%/packages/patches/libssh2-fix-build-failure-with-gcrypt.patch \
|
%D%/packages/patches/libssh2-fix-build-failure-with-gcrypt.patch \
|
||||||
%D%/packages/patches/libtar-CVE-2013-4420.patch \
|
%D%/packages/patches/libtar-CVE-2013-4420.patch \
|
||||||
|
%D%/packages/patches/libtasn1-CVE-2017-10790.patch \
|
||||||
%D%/packages/patches/libtheora-config-guess.patch \
|
%D%/packages/patches/libtheora-config-guess.patch \
|
||||||
%D%/packages/patches/libtiff-CVE-2016-10688.patch \
|
%D%/packages/patches/libtiff-CVE-2016-10688.patch \
|
||||||
%D%/packages/patches/libtiff-CVE-2017-9936.patch \
|
%D%/packages/patches/libtiff-CVE-2017-9936.patch \
|
||||||
|
|
|
@ -0,0 +1,63 @@
|
||||||
|
Fix CVE-2017-10790:
|
||||||
|
|
||||||
|
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-10790
|
||||||
|
|
||||||
|
Patch copied from upstream source repository:
|
||||||
|
|
||||||
|
https://git.savannah.nongnu.org/cgit/libtasn1.git/commit/?id=d8d805e1f2e6799bb2dff4871a8598dc83088a39
|
||||||
|
|
||||||
|
From d8d805e1f2e6799bb2dff4871a8598dc83088a39 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Nikos Mavrogiannopoulos <nmav@redhat.com>
|
||||||
|
Date: Thu, 22 Jun 2017 16:31:37 +0200
|
||||||
|
Subject: [PATCH] _asn1_check_identifier: safer access to values read
|
||||||
|
|
||||||
|
Signed-off-by: Nikos Mavrogiannopoulos <nmav@redhat.com>
|
||||||
|
---
|
||||||
|
lib/parser_aux.c | 17 ++++++++++++-----
|
||||||
|
1 file changed, 12 insertions(+), 5 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/lib/parser_aux.c b/lib/parser_aux.c
|
||||||
|
index 976ab38..786ea64 100644
|
||||||
|
--- a/lib/parser_aux.c
|
||||||
|
+++ b/lib/parser_aux.c
|
||||||
|
@@ -955,7 +955,7 @@ _asn1_check_identifier (asn1_node node)
|
||||||
|
if (p2 == NULL)
|
||||||
|
{
|
||||||
|
if (p->value)
|
||||||
|
- _asn1_strcpy (_asn1_identifierMissing, p->value);
|
||||||
|
+ _asn1_str_cpy (_asn1_identifierMissing, sizeof(_asn1_identifierMissing), (char*)p->value);
|
||||||
|
else
|
||||||
|
_asn1_strcpy (_asn1_identifierMissing, "(null)");
|
||||||
|
return ASN1_IDENTIFIER_NOT_FOUND;
|
||||||
|
@@ -968,9 +968,15 @@ _asn1_check_identifier (asn1_node node)
|
||||||
|
if (p2 && (type_field (p2->type) == ASN1_ETYPE_DEFAULT))
|
||||||
|
{
|
||||||
|
_asn1_str_cpy (name2, sizeof (name2), node->name);
|
||||||
|
- _asn1_str_cat (name2, sizeof (name2), ".");
|
||||||
|
- _asn1_str_cat (name2, sizeof (name2), (char *) p2->value);
|
||||||
|
- _asn1_strcpy (_asn1_identifierMissing, p2->value);
|
||||||
|
+ if (p2->value)
|
||||||
|
+ {
|
||||||
|
+ _asn1_str_cat (name2, sizeof (name2), ".");
|
||||||
|
+ _asn1_str_cat (name2, sizeof (name2), (char *) p2->value);
|
||||||
|
+ _asn1_str_cpy (_asn1_identifierMissing, sizeof(_asn1_identifierMissing), (char*)p2->value);
|
||||||
|
+ }
|
||||||
|
+ else
|
||||||
|
+ _asn1_strcpy (_asn1_identifierMissing, "(null)");
|
||||||
|
+
|
||||||
|
p2 = asn1_find_node (node, name2);
|
||||||
|
if (!p2 || (type_field (p2->type) != ASN1_ETYPE_OBJECT_ID) ||
|
||||||
|
!(p2->type & CONST_ASSIGN))
|
||||||
|
@@ -990,7 +996,8 @@ _asn1_check_identifier (asn1_node node)
|
||||||
|
_asn1_str_cpy (name2, sizeof (name2), node->name);
|
||||||
|
_asn1_str_cat (name2, sizeof (name2), ".");
|
||||||
|
_asn1_str_cat (name2, sizeof (name2), (char *) p2->value);
|
||||||
|
- _asn1_strcpy (_asn1_identifierMissing, p2->value);
|
||||||
|
+ _asn1_str_cpy (_asn1_identifierMissing, sizeof(_asn1_identifierMissing), (char*)p2->value);
|
||||||
|
+
|
||||||
|
p2 = asn1_find_node (node, name2);
|
||||||
|
if (!p2 || (type_field (p2->type) != ASN1_ETYPE_OBJECT_ID)
|
||||||
|
|| !(p2->type & CONST_ASSIGN))
|
||||||
|
--
|
||||||
|
2.13.3
|
||||||
|
|
|
@ -1,6 +1,6 @@
|
||||||
;;; GNU Guix --- Functional package management for GNU
|
;;; GNU Guix --- Functional package management for GNU
|
||||||
;;; Copyright © 2012, 2013, 2014, 2015, 2016, 2017 Ludovic Courtès <ludo@gnu.org>
|
;;; Copyright © 2012, 2013, 2014, 2015, 2016, 2017 Ludovic Courtès <ludo@gnu.org>
|
||||||
;;; Copyright © 2014, 2015, 2016 Mark H Weaver <mhw@netris.org>
|
;;; Copyright © 2014, 2015, 2016, 2017 Mark H Weaver <mhw@netris.org>
|
||||||
;;; Copyright © 2014 Ian Denhardt <ian@zenhack.net>
|
;;; Copyright © 2014 Ian Denhardt <ian@zenhack.net>
|
||||||
;;; Copyright © 2013, 2015 Andreas Enge <andreas@enge.fr>
|
;;; Copyright © 2013, 2015 Andreas Enge <andreas@enge.fr>
|
||||||
;;; Copyright © 2015 David Thompson <davet@gnu.org>
|
;;; Copyright © 2015 David Thompson <davet@gnu.org>
|
||||||
|
@ -55,6 +55,7 @@
|
||||||
(package
|
(package
|
||||||
(name "libtasn1")
|
(name "libtasn1")
|
||||||
(version "4.12")
|
(version "4.12")
|
||||||
|
(replacement libtasn1/fixed)
|
||||||
(source
|
(source
|
||||||
(origin
|
(origin
|
||||||
(method url-fetch)
|
(method url-fetch)
|
||||||
|
@ -74,6 +75,13 @@ networking, allowing for formal validation of data according to some
|
||||||
specifications.")
|
specifications.")
|
||||||
(license license:lgpl2.0+)))
|
(license license:lgpl2.0+)))
|
||||||
|
|
||||||
|
(define libtasn1/fixed
|
||||||
|
(package
|
||||||
|
(inherit libtasn1)
|
||||||
|
(source (origin
|
||||||
|
(inherit (package-source libtasn1))
|
||||||
|
(patches (search-patches "libtasn1-CVE-2017-10790.patch"))))))
|
||||||
|
|
||||||
(define-public asn1c
|
(define-public asn1c
|
||||||
(package
|
(package
|
||||||
(name "asn1c")
|
(name "asn1c")
|
||||||
|
|
Loading…
Reference in New Issue