gnu: knot: Update to 2.8.1.
* gnu/packages/dns.scm (knot): Update to 2.8.1. [source]: Remove patch. * gnu/packages/patches/knot-include-system-lmdb-header.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Remove it.
This commit is contained in:
parent
a8f52ad7c1
commit
e41ddf7605
|
@ -949,7 +949,6 @@ dist_patch_DATA = \
|
||||||
%D%/packages/patches/kio-search-smbd-on-PATH.patch \
|
%D%/packages/patches/kio-search-smbd-on-PATH.patch \
|
||||||
%D%/packages/patches/kmod-module-directory.patch \
|
%D%/packages/patches/kmod-module-directory.patch \
|
||||||
%D%/packages/patches/kmscon-runtime-keymap-switch.patch \
|
%D%/packages/patches/kmscon-runtime-keymap-switch.patch \
|
||||||
%D%/packages/patches/knot-include-system-lmdb-header.patch \
|
|
||||||
%D%/packages/patches/kpackage-allow-external-paths.patch \
|
%D%/packages/patches/kpackage-allow-external-paths.patch \
|
||||||
%D%/packages/patches/kobodeluxe-paths.patch \
|
%D%/packages/patches/kobodeluxe-paths.patch \
|
||||||
%D%/packages/patches/kobodeluxe-enemies-pipe-decl.patch \
|
%D%/packages/patches/kobodeluxe-enemies-pipe-decl.patch \
|
||||||
|
|
|
@ -569,23 +569,21 @@ Extensions} (DNSSEC).")
|
||||||
(define-public knot
|
(define-public knot
|
||||||
(package
|
(package
|
||||||
(name "knot")
|
(name "knot")
|
||||||
(version "2.8.0")
|
(version "2.8.1")
|
||||||
(source (origin
|
(source
|
||||||
(method url-fetch)
|
(origin
|
||||||
(uri (string-append "https://secure.nic.cz/files/knot-dns/"
|
(method url-fetch)
|
||||||
"knot-" version ".tar.xz"))
|
(uri (string-append "https://secure.nic.cz/files/knot-dns/"
|
||||||
(sha256
|
"knot-" version ".tar.xz"))
|
||||||
(base32
|
(sha256
|
||||||
"1vw7xx7bm440jwrpvdd04vrp6ccz2b11swcn9msvs62hf0kdjjj9"))
|
(base32 "1im2wb8hl394mzni1wavmvfqd7il8s28kcz8w3s4v05nbhzg06xj"))
|
||||||
(patches
|
(modules '((guix build utils)))
|
||||||
(search-patches "knot-include-system-lmdb-header.patch"))
|
(snippet
|
||||||
(modules '((guix build utils)))
|
'(begin
|
||||||
(snippet
|
;; Delete bundled libraries.
|
||||||
'(begin
|
(with-directory-excursion "src/contrib"
|
||||||
;; Delete bundled libraries.
|
(delete-file-recursively "lmdb"))
|
||||||
(with-directory-excursion "src/contrib"
|
#t))))
|
||||||
(delete-file-recursively "lmdb"))
|
|
||||||
#t))))
|
|
||||||
(build-system gnu-build-system)
|
(build-system gnu-build-system)
|
||||||
(native-inputs
|
(native-inputs
|
||||||
`(("pkg-config" ,pkg-config)))
|
`(("pkg-config" ,pkg-config)))
|
||||||
|
|
|
@ -1,34 +0,0 @@
|
||||||
From: Tobias Geerinckx-Rice <me@tobias.gr>
|
|
||||||
Date: Wed, 20 Mar 2019 00:08:00 +0100
|
|
||||||
Subject: [PATCH] gnu: knot: Include system <lmdb.h>.
|
|
||||||
|
|
||||||
Copied verbatim from Knot master[0].
|
|
||||||
|
|
||||||
[0]: https://gitlab.labs.nic.cz/knot/knot-dns/commit/b557430cffbb1c6b30617a394b02acc514e7e536
|
|
||||||
|
|
||||||
From b557430cffbb1c6b30617a394b02acc514e7e536 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Daniel Salzman <daniel.salzman@nic.cz>
|
|
||||||
Date: Wed, 6 Mar 2019 17:35:44 +0100
|
|
||||||
Subject: [PATCH] journal: include proper header <lmdb.h>
|
|
||||||
|
|
||||||
fixes #638
|
|
||||||
---
|
|
||||||
src/knot/journal/knot_lmdb.h | 2 +-
|
|
||||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
||||||
|
|
||||||
diff --git a/src/knot/journal/knot_lmdb.h b/src/knot/journal/knot_lmdb.h
|
|
||||||
index 35a88845c..b1d09cbb4 100644
|
|
||||||
--- a/src/knot/journal/knot_lmdb.h
|
|
||||||
+++ b/src/knot/journal/knot_lmdb.h
|
|
||||||
@@ -16,7 +16,7 @@
|
|
||||||
|
|
||||||
#pragma once
|
|
||||||
|
|
||||||
-#include "contrib/lmdb/lmdb.h"
|
|
||||||
+#include <lmdb.h>
|
|
||||||
|
|
||||||
#include <stdbool.h>
|
|
||||||
#include <stdlib.h>
|
|
||||||
--
|
|
||||||
2.18.1
|
|
||||||
|
|
Loading…
Reference in New Issue