gnu: clisp: Update to 2.49.92.

* gnu/packages/lisp.scm (clisp): Update to 2.49.92.
[source]: Switch to git-fetch. Remove unneeded patch.
[arguments]: Remove '--enable-portability' flag, add CFLAGS for
armhf-linux. Update list of files needing substitutions in custom
'patch-sh-and-pwd phase.
[home-page]: Update to new home-page.
* gnu/packages/patches/clisp-glibc-2.26.patch: Remove file.
& gnu/local.mk (dist_patch_DATA): Remove it.
master
Efraim Flashner 2018-10-09 20:27:37 +03:00
parent 006a1d59ba
commit e4c399fe15
No known key found for this signature in database
GPG Key ID: 41AAE7DCCA3D8351
3 changed files with 21 additions and 36 deletions

View File

@ -621,7 +621,6 @@ dist_patch_DATA = \
%D%/packages/patches/clementine-fix-sqlite.patch \
%D%/packages/patches/clementine-remove-crypto++-dependency.patch \
%D%/packages/patches/clementine-use-openssl.patch \
%D%/packages/patches/clisp-glibc-2.26.patch \
%D%/packages/patches/clisp-remove-failing-test.patch \
%D%/packages/patches/clucene-pkgconfig.patch \
%D%/packages/patches/clx-remove-demo.patch \

View File

@ -35,7 +35,6 @@
#:use-module (gnu packages m4)
#:use-module (guix download)
#:use-module (guix git-download)
#:use-module (guix hg-download)
#:use-module (guix utils)
#:use-module (guix build-system gnu)
#:use-module (guix build-system asdf)
@ -256,28 +255,31 @@ supporting ASDF, Sockets, Gray streams, MOP, and other useful components.")
(define-public clisp
(package
(name "clisp")
(version "2.49-60")
(version "2.49-92")
(source
(origin
(method hg-fetch)
(uri (hg-reference
(url "http://hg.code.sf.net/p/clisp/clisp")
(changeset "clisp_2_49_60-2017-06-25")))
(file-name (string-append name "-" version "-checkout"))
(method git-fetch)
(uri (git-reference
(url "https://gitlab.com/gnu-clisp/clisp")
(commit "clisp-2.49.92-2018-02-18")))
(file-name (git-file-name name version))
(sha256
(base32 "0qjv3z274rbdmb941hy03hl63f4z7bmci234f8dyz4skgfr82d3i"))
(patches (search-patches "clisp-glibc-2.26.patch"
"clisp-remove-failing-test.patch"))))
(base32 "0k2dmgl0miz3767iks4p0mvp6xw0ysyxhjpklyh11j010rmh6hqb"))
(patches (search-patches "clisp-remove-failing-test.patch"))))
(build-system gnu-build-system)
(inputs `(("libffcall" ,libffcall)
("ncurses" ,ncurses)
("readline" ,readline)
("libsigsegv" ,libsigsegv)))
(arguments
'(#:configure-flags '("--enable-portability"
"--with-dynamic-ffi"
"--with-dynamic-modules"
"--with-module=rawsock")
`(#:configure-flags '(,@(if (string-prefix? "armhf-linux"
(or (%current-system)
(%current-target-system)))
'("CFLAGS=-falign-functions=4")
'())
"--with-dynamic-ffi"
"--with-dynamic-modules"
"--with-module=rawsock")
#:build #f
#:phases
(modify-phases %standard-phases
@ -288,6 +290,10 @@ supporting ASDF, Sockets, Gray streams, MOP, and other useful components.")
;; many places where our automatic patching misses them. Therefore
;; we do the following, in this early (post-unpack) phase, to solve
;; the problem from its root.
(substitute* '("src/clisp-link.in"
"src/unix.d"
"src/makemake.in")
(("/bin/sh") (which "sh")))
(substitute* (find-files "." "configure|Makefile")
(("/bin/sh") "sh"))
(substitute* '("src/clisp-link.in")
@ -295,7 +301,7 @@ supporting ASDF, Sockets, Gray streams, MOP, and other useful components.")
#t)))
;; Makefiles seem to have race conditions.
#:parallel-build? #f))
(home-page "http://www.clisp.org/")
(home-page "https://clisp.sourceforge.io/")
(synopsis "A Common Lisp implementation")
(description
"GNU CLISP is an implementation of ANSI Common Lisp. Common Lisp is a

View File

@ -1,20 +0,0 @@
This patch comes from Debian.
Description: cfree is not present in glibc-2.26, stop wrapping it
Author: Adam Conrad <adconrad@ubuntu.com>
Bug: https://sourceforge.net/p/clisp/bugs/717/
Bug-Debian: https://bugs.debian.org/880686
Applied-Upstream: https://sourceforge.net/p/clisp/clisp/ci/3bc928712d150ff1e5f6b2bfb7838655f3ff52fa/
Reviewed-By: Sébastien Villemot <sebastien@debian.org>
Last-Update: 2017-11-27
--- clisp-2.49.20170913.orig/modules/bindings/glibc/linux.lisp
+++ clisp-2.49.20170913/modules/bindings/glibc/linux.lisp
@@ -649,7 +649,6 @@
(def-call-out calloc (:arguments (nmemb size_t) (size size_t))
(:return-type c-pointer))
(def-call-out free (:arguments (ptr c-pointer)) (:return-type nil))
-(def-call-out cfree (:arguments (ptr c-pointer)) (:return-type nil))
(def-call-out valloc (:arguments (size size_t)) (:return-type c-pointer))
(def-call-out abort (:arguments) (:return-type nil))