gnu: khal: Disable failing tests.
* gnu/packages/patches/khal-disable-failing-tests.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/calendar.scm (khal): Use it.
This commit is contained in:
parent
e0c32fc817
commit
e50d5b8c9d
|
@ -642,6 +642,7 @@ dist_patch_DATA = \
|
||||||
%D%/packages/patches/jbig2dec-ignore-testtest.patch \
|
%D%/packages/patches/jbig2dec-ignore-testtest.patch \
|
||||||
%D%/packages/patches/jq-CVE-2015-8863.patch \
|
%D%/packages/patches/jq-CVE-2015-8863.patch \
|
||||||
%D%/packages/patches/kdbusaddons-kinit-file-name.patch \
|
%D%/packages/patches/kdbusaddons-kinit-file-name.patch \
|
||||||
|
%D%/packages/patches/khal-disable-failing-tests.patch \
|
||||||
%D%/packages/patches/khmer-use-libraries.patch \
|
%D%/packages/patches/khmer-use-libraries.patch \
|
||||||
%D%/packages/patches/kmod-module-directory.patch \
|
%D%/packages/patches/kmod-module-directory.patch \
|
||||||
%D%/packages/patches/kobodeluxe-paths.patch \
|
%D%/packages/patches/kobodeluxe-paths.patch \
|
||||||
|
|
|
@ -88,6 +88,7 @@ data units.")
|
||||||
(source (origin
|
(source (origin
|
||||||
(method url-fetch)
|
(method url-fetch)
|
||||||
(uri (pypi-uri "khal" version))
|
(uri (pypi-uri "khal" version))
|
||||||
|
(patches (search-patches "khal-disable-failing-tests.patch"))
|
||||||
(sha256
|
(sha256
|
||||||
(base32
|
(base32
|
||||||
"03vy4dp9n43w51mwqjjy08dr5nj7wxqnb085visz3j43vzm42p1f"))))
|
"03vy4dp9n43w51mwqjjy08dr5nj7wxqnb085visz3j43vzm42p1f"))))
|
||||||
|
|
|
@ -0,0 +1,33 @@
|
||||||
|
Disable some tests that are known to fail:
|
||||||
|
|
||||||
|
https://github.com/pimutils/khal/issues/546
|
||||||
|
https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=844081
|
||||||
|
|
||||||
|
diff --git a/tests/khalendar_test.py b/tests/khalendar_test.py
|
||||||
|
index fd8dcc6..17732bf 100644
|
||||||
|
--- a/tests/khalendar_test.py
|
||||||
|
+++ b/tests/khalendar_test.py
|
||||||
|
@@ -65,6 +65,7 @@ class TestCalendar(object):
|
||||||
|
else:
|
||||||
|
mtimes[cal] = mtime
|
||||||
|
|
||||||
|
+ @pytest.mark.xfail
|
||||||
|
def test_db_needs_update(self, coll_vdirs):
|
||||||
|
coll, vdirs = coll_vdirs
|
||||||
|
|
||||||
|
@@ -321,6 +322,7 @@ class TestDbCreation(object):
|
||||||
|
CalendarCollection(calendars, dbpath=dbpath, locale=aux.locale)
|
||||||
|
|
||||||
|
|
||||||
|
+@pytest.mark.xfail
|
||||||
|
def test_default_calendar(coll_vdirs):
|
||||||
|
"""test if an update to the vdir is detected by the CalendarCollection"""
|
||||||
|
coll, vdirs = coll_vdirs
|
||||||
|
@@ -341,6 +343,7 @@ def test_default_calendar(coll_vdirs):
|
||||||
|
assert len(list(coll.get_events_on(today))) == 0
|
||||||
|
|
||||||
|
|
||||||
|
+@pytest.mark.xfail
|
||||||
|
def test_only_update_old_event(coll_vdirs, monkeypatch):
|
||||||
|
coll, vdirs = coll_vdirs
|
||||||
|
|
Loading…
Reference in New Issue